File size – Troubleshooting Guide

by GRAPHISOFT and Greg Kmethy · updated: 10.09.2011

This article describes how to troubleshoot file size issues.

What file size is considered “large” ?

As a rule-of-thumb a file that is over 100 MB (uncompressed) is considered “large”, and files over 300 MB (uncompressed) are critical. Files over 300 MB might still work, but for optimal performance you should not exceed this size. Since ArchiCAD 10, files are compressed, so a 100 MB compressed file requires about 300-500 MB of memory space when uncompressed.

What makes up for the file size?

Go through these steps to determine what makes up for the file size:

  • Make a copy of your file and back up the original
  • Check if file compression is enabled or not. (See below)
  • Check if your file contains IFC data or not. (This applies only to ArchiCAD 13 and older – See below)
  • Export the whole Embedded Library from Library Manager and check the overall size of those objects
  • Using the Navigator, delete all the layouts from the file, save, and see how much does the file shrink.
  • Using the Navigator, delete all Details and Worksheets from the file, save, and see how much does the file shrink.
  • Using the Navigator, delete all sections and elevations from the file, save, and see how much does the file shrink.
  • Using the Layer settings dialog, delete all layers from the file. This will erase all model data from the file. In rare cases this empty file is still considerably large. In this case you need to merge your original file into a new file to get rid of the dead data in your file. (See details below)

This process will show you which type of viewpoints should you investigate further. You can continue checking these viewpoint one by one.

File compression

Save a copy of the file (with “save as”) option and in the file save dialog check under “options” make sure file compression is enabled. (Continue investigation on this copy of the file, and keep the original copy intact)

IFC data

In ArchiCAD 13 and earlier versions, if IFC add-on is ‘active’ in your project file, then it saves IFC data with every new element you create. This grows file size. IFC add-on becomes ‘active’ when any of the IFC commands are used, and stays active as long as you have the IFC add-on loaded. Note, that if the IFC Panel is enabled in any of the tool settings dialogs, it will activate the IFC add-on. To turn off the IFC add-on, go to Options menu/Add-On Manager and un-check the ‘IFC 2×3’ and ‘IFC Common’ Add-Ons.

In ArchiCAD 14 IFC information can only be attached to ArchiCAD elements through the IFC Manager, so the phenomenon detailed above can not occur.

Layout data

Considerations:

  • If you have more than 50 layouts in your file, you should consider braking up the project into a separate model and a separate documentation file. (In this scenario, views set up in the model file are placed as external drawings in the documentation file.) If you have over 100 layouts, you might have several documentation files.
  • Drawings are stored in the file by default. This means that the generated drawings are each stored in the file as a collection of lines, fills and text. In the drawing settings dialog, on the ‘Identification’ panel you can turn off the ‘Store Drawing in the Project File’ option. This may reduce the file size dramatically, if you have many drawings. If this option is off, then drawings are generated ‘on the fly’ when you open a layout. Note, that if you have external drawings, then the external source has to be present at all time, as the drawings are generated from the external source on ‘on the fly’ when you open a layout’StoreDrawingInProjectFile.png
  • Look out for large bitmap images on layouts. (e.g. site plans, survey drawings, company logos). Make sure large bitmaps are not featured on all/many layouts.
  • Look out for cropped drawings – e.g. details that are cropped from entire floor plans or sections. Use the Detail or Worksheet tools to create detail drawings, and place the detail or worksheet as a drawing on the layout.

Embedded Library Objects

The EmbeddedLibrary function is a very practical way to store library parts within a file that are unique to a project. Each embedded library objects add to the file size so be sure to only embed items that are specific to that project. Also make sure that there are not unused objects in the embedded library. Unused objects can be removed within the library manager

To check the number of objects in file open the library manager and look under the embedded library tab. Selecting an object will tell you the size and number of instances in the project.

You can also verify the size of the entire embedded library by exporting it using the library manager.

See also Bugs/FileSizeGrowingWhenBinaryObjectsInEmbeddedLibrary

Details and Worksheets

Details and Worksheets are very useful tools for reducing the file size, if used cleverly. A common misinterpretation of BIM is that the whole building has to be modeled in 1:1 scale. That is not the case – floor plans, sections and elevations are rarely detailed beyond 1:50 scale. If more detailed drawings are required, use the Detail tool and Worksheet tool to show parts of the building at finer scale. (To learn more about the difference between Detail and Worksheet tool, read this: LINK) Consider, however the following:

  • Details and Worksheet may hold a lot of data – model elements broken up to lines and fills may actually occupy more space in the file database than their source model element. E.g. a wall that is a single element on floor plan, breaks up into 5 new elements: one fill and 4 lines.
  • Use the Linework Consolidation and Fill Consolidation tools to remove unnecessary lines and fills from Details and Worksheet.
  • Do not store unnecessary Details in your project. E.g. if you have a standard library of independent details in a file, don’t keep the whole library in your template file. Just use the Details you really need.
  • Note that you can place Hotlink modules on Details and Worksheets. This is one way to import details from an external file. E.g. set up you ‘Standard details library’ file so that each of its story holds one detail. Then you can place the necessary stories as Hotlink modules on your Detail drawings.

Sections and Elevations

Considerations:

  • Sections and Elevations may hold a lot of data – model elements broken up to lines and fills may actually occupy more space in the file database than their source model element. E.g. a wall that is a single element on floor plan, breaks up into 5 new elements: one fill and 4 lines.
  • Use the Linework Consolidation and Fill Consolidation tools to remove unnecessary lines and fills from Details and Worksheet
  • Do not store unnecessary Sections and Elevations in your project. Delete “working sections” when you don’t need them anymore.

Counting elements in 2D views

Select the arrow tool, and use the Select all command to select all elements. The info box will show how many elements you have altogether in the current view

infobox.png

You can use the Edit Selection Set… command (Edit menu/Element Settings) to see the number of elements by type

esitselectionset.png

Considerations:

  • A BIM project typically has a few hundred to a few thousand elements on a floorplan or a section. If you have hundreds of thousands of individual elements, that probably partly accounts for the large file size. Typically this is content that comes from DWG or other third party application. Make sure you only keep data you really need in your file. If you just need DWG data temporarily, consider storing them on Worksheets, and delete them when you don’t need them anymore.

Merging file into a new file

In very rare cases it happens that even after you have deleted every building elements from your file, it is still considerably large. (An empty Archicad file should be 1-2 MB uncompressed, depending on the amount of attributes defined in the file). This indicates that the file contains “dead” data – data that is in the file, but is not used anymore. To solve this problem, do the following:

  • Open the original file
  • Open a new file with ‘last settings used’ option – this creates a new, empty file, with the same attribute set
  • Delete all stories but the ground floor. Make sure that the ground floor has the correct height
  • Merge the original file into the new, empty file
  • Since merge just copies stories, you need to copy all 2D elements that you have created on sections, elevations and details
  • Was this Helpful ?
  • 2   ​0

Related content

Worksheets

About Worksheets Worksheet vs. Detail Create a Worksheet Drawing with Model Source Contents of the Worksheet Window Editing in the Worksheet Window Create an Independent Worksheet Viewpoint Place a Linked Worksheet Marker Place an Unlinked Marker

Details

About Details Create a Detail Drawing Viewpoint with Model Source Contents of the Detail Viewpoint Place a Linked Detail Marker Place an Unlinked Marker Create an Independent Detail Viewpoint Display of Detail/Worksheet Boundary Update Detail/Worksheet…

Elevations

ArchiCAD has a separate tool for creating Elevation viewpoints and linked or unlinked Elevation markers. In contrast to Sections: Elevations generally do not “slice through” the structure, but rather create a cross-section view of the structure from a…

Sections

About Sections Create a Section Viewpoint Define Horizontal/Vertical Range of Section Viewpoint Define Marker Reference for Source Marker Assign Section Status Model Display in the Section Window Open a Section Viewpoint Place a Linked Section Marker…

Fill Consolidation

In the current window, select at least two fills that you wish to include in the Fill Consolidation process. The Fill Consolidation command ( Edit > Reshape > Fill Consolidation ) brings up Fill Consolidation Settings. See details at Fill…

Linework Consolidation

In the window, select at least two line-type elements you wish to include in the Linework Consolidation process. Line-type elements are straight-lines, polylines, arcs and circles. Note: Linework Consolidation does not affect any line-type element having…

Edit Selection Set

The Edit Selection Set dialog box from Edit > Element Settings > Edit Selection Set makes it possible to edit specific attributes (layers, pencolors, and classifications) for a collection of dissimilar element types simultaneously, without affecting…

File Compression

When saving certain file types from ArchiCAD (.pln, .tpl, .pla, .mod), the Options button in the Save dialog box presents you with the option to “Compress file.” This option is enabled by default, and is recommended in most cases, since file compression…

How to Use Standard Details in a Project

This article explains how to embed one or more standard detail drawings into your Project. In this example, we will embed a balcony and Wall-Slab intersection detail into our Project, and place it onto a Layout. We will also create a marker which…

How to Store "Find & Select" Criteria

ArchiCAD’s Find & Select tool in ArchiCAD lets you select the exact elements you wish to manipulate or modify. For general information on this feature, see Find and Select Elements by Criteria in ArchiCAD Help . A less well-known feature of this Tool…

Selecting Elements Across Several Stories

- by Ben Frost, UK and Eric Link, Worldwide ArchiCAD specialist Is there a way to group walls/elements that occur on different stories? - select them in the 3D window and 'Group'. The above answer of Ben Frost is 100% OK, but Link's advice may be of…

Files used (created) by IFC add-on

Setting parameter files: name: edmParam2x3.dat, edmParam.dat, IFC2X3Option.dat, IFC2XPOption.dat location win: C:\Documents and Settings\<user>\Application Data\Graphisoft location mac: user/Library/Preferences/Graphisoft PSET config XML file…