影響のあるバージョン: 全て | 重要度: 解決方法あり問題ライセンスマネージャーツールを使用してソフトウェアキーをアップロード/ダウンロードする際に、「キーのコンテンツにアクセスできません 」というエラーメッセージがポップアップ表示される。
この現象は、
プロテクトキー のコンテンツがアクセスできません(コード:2009)としてライセンスマネージャーで一覧表示される での現象に類似しています。関連するヘルプセンターの記事を参照してください。
原因
ソフトウェアライセンスをダウンロードまたはアップロードするためには、ファイルをコンピューター上の特定の場所に作成し、削除する必要があります。これが行えず、またライセンスマネージャーツールがこれらのファイルを変更できない場合、「キーのコンテンツにアクセスできません」というエラーメッセージが表示されます。この現象の主な理由は、オペレーティングシステムの実際のユーザーが必要なフォルダの読み取り/書き込み権限 を持っていないか、あるいはファイヤーウォールまたはアンチウイルスソフトがライセンスファイルの管理をブロックしているといった、アクセス権の問題にあります。
解決方法
1. オペレーティングシステムの現在のユーザーアカウントが以下のフォルダおよびフォルダ内に格納されたすべての項目(クリックしてスクリーンショットを表示)の読み取り/書き込み権限を持っているようにします。
Windows: C:\ProgramData\CodeMeter\
macOS: Macintosh HD/Library/Application Support/CodeMeter/
2. ファイヤーウォール/プロキシ等によってネットワーク通信を制御している場合、ライセンスマネージャーツール がこれらのホストと通信できるようにします。
3. 全てのアクセス権が設定されたら、次のステップとして、ライセンス管理の際に全てのファイヤーウォールとアンチウイルスソフトを無効にします。これら一部のセキュリティ対策は非常に強固で、終了させたり停止させただけでは十分でないため、完全に無効化する必要があります。
また、オペレーティングシステムの更新により、これらの設定が変わる場合があります。(例:WindowsアップデートはWindows Defender設定を容易に変更します。)
4. これでもライセンスが機能せず、同じエラーが表示される場合は、ライセンスマネージャーツールとCodeMeter ドライバをアンインストールし、再インストールすることを推奨します。
- ライセンスマネージャーツール: アンインストーラは、GRAPHISOFT/License Manager Toolフォルダ内にあります。最新のインストーラはGRAPHISOFTダウンロードサイトからダウンロードできます。ライセンスマネージャーツールをWindowsからアンインストールするには、コントロールパネルから「プログラム」または「プログラムの追加と削除」ユーティリティを使用します。
- CodeMeter: 最新のインストーラパッケージはGRAPHISOFT ダウンロードサイトで入手できます。インストーラパッケージのアンインストーラを使用し、次にCodeMeterに関連するフォルダやファイルがProgramDataフォルダ内とLibrary/Application Supportフォルダ内に残っていないか確認します。 CodeMeterをWindowsからアンインストールするには、コントロールパネルから「プログラム」または「プログラムの追加と削除」ユーティリティを使用します。その後、インストーラを使用して最新のCodeMeterドライバをインストールし、コンピューターを再起動します。
注記:
問題が継続する場合は、テクニカルサポートに問題を報告するよう販売店に依頼して下さい。