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PDF - Troubleshooting Guide

Greg Kmethy
Graphisoft
Graphisoft

PostScript fonts are not displayed

Affected version: 18| Severity: workaround applicable | ID: 177770
Note: This issue was fixed in ARCHICAD 19 release version.
 
Issue
PostScript Fonts are not displayed in PDFs, that are published from ARCHICAD 18 on MAC. When printing with the File/Print command the fonts print ok.
 
Cause
In the ARCHICAD 18 PDF engine PostScript fonts are not supported. The issue is planned to be fixed in the upcoming ARCHICAD version.
 
Solution
As a solution use the True Type or Open Type fonts in place of the PostScript fonts. Most of the PostScript fonts are available in True Type or Open Type version. On the Internet several Font Converters are provided which can convert PostScript Type fonts to Open Type or True Type Fonts.

 

Printing Problem with placed PDF on Windows

Affected version: 18| Severity: workaround applicable | ID: 178258
Note: This issue is in the PDF creator engine that ARCHICAD uses.
 
Issue
A PDF file placed on a Layout or on a Story may not be printed correctly.
 
wp-content_uploads_pdf_windows_trouble1-300x102.png
 
Cause
When printing a placed PDF ARCHICAD exports it in a vector format using a Windows API called GDI+. GDI+ is responsible for submitting graphical elements to the printer, but there are elements (patterns, fills) it cannot manage.
 
Solutions
  • Save the output as PDF file. Print this PDF
or
  • From Start menu choose or select Run, type regedit to open Windows Registry Editor
  • Find the key: HKEY_CURRENT_USER\Software\Graphisoft\ARCHICAD\<ARCHICAD version>\PDF 
  • Double-click the DWORD entry named Drawing Methode and set the value to 2. (The PDF will be printed as an image not in vector format)

 

Calibri font problem in the saved PDF

Affected version: 17 and earlier| Severity: workaround applicable | ID: 67698
Note: This issue was fixed in ARCHICAD 18 release version.

 

Issue

If Calibri font is used in ARCHICAD, the ligature fonts (when two characters merge for better readability: http://en.wikipedia.org/wiki/Typographic_ligature) are not visible in the saved PDF.
wp-content_uploads_archicadwiki_bugs-calibrifontprobleminpdf--calibriletters.png

 

Cause

The problem with Calibri font type is related to PDF engine that we license. The manufacturer of the engine promised a fix in one of their updates.

 

Solution

It is not possible to turn off ligature. On Windows XP it only occurs when asian fonts are enabled (Control Panel -> Regional and Language Options -> Languages -> Install files for East Asian languages). Disabling this option turns off ligature in Calibri font, so that is a workaround on XP. This workaround does not work on Windows 7.

 

Publishing PDF is not possible on Mac

Affected version: All ARCHICAD versions| Severity: workaround applicable | ID: 128624
 
Issue
  • Publishing PDF is not possible.

 

Cause

  • The former version of this PDF has already been published to the same location, might be larger than 10 MB and it is open in Finder in column view. ARCHICAD thinks this PDF is in use by another application and refuses to publish a new PDF.

 

Solution

  • Make sure that the PDF file is not selected in Finder.

 

Texts collapse after printing PDF with Adobe Reader on Mac

Affected version: All ARCHICAD versions| Severity: workaround applicable | ID: 177297
Note: This issue is not present with Adobe Reader Version 2015.017.20050
 
Issue
A PDF saved by ARCHICAD 18 on MAC OS X and printed from Adobe Acrobat Reader will appear with collapsed text strings on the print. MAC’s built in Preview app will print the PDF’s correctly:
wp-content_uploads_text-collapse-after-print-with-adobe.png
Cause
Starting with ARCHICAD 18 the PDF engine has been replaced to PDFNet on Macintosh (this engine was used only on Windows in the previous versions). This change has triggered an issue with Adobe's pdf printing mechanism on Mac that was hidden before. The issue has been reported to Adobe since the correction is needed at their end as Acrobat uses the system function incorrectly while printing. There are a few workarounds to avoid the issue:
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Solution A
Turn on the "Print As Image" checkbox in Adobe Reader's Advanced Print settings. This will send the pdf to the printer as an image and you will get the correct result. (This might raise the size of the file sent to the printer and can lower the quality of the printed document.)
wp-content_uploads_print-as-image.png
 
Solution B
Print the PDF from Preview.
 
Solution C
Work-around the problem by changing the PDF/Font Subsetting key from True to False in the com.graphisoft.AC-64 18.0.0 XXX v1.plist file. This change makes sure that all placed font instances are being exported one by one rather than exporting the font type with the position information of the placed fonts. This might result in larger file size. These are the detailed steps for changing the key:
1. Quit ARCHICAD 18.
2. Run PrefSetter application to unzip it. If you don’t have PrefSetter application yet, you can download it from here
3. Open Users/<username>/Library/Preferences/com.graphisoft AC-64 18.0.0 XXX v1.plist file
4. Scroll down in the page until you see PDF in the left column. Click the arrow next to it to expand.
5. In the "Font Subsetting Boolean true" line item, click to make it false. Then go to File>Save in the menu bar.
6. Quit Pref Setter and close all Finder windows if you like.
7. Start ARCHICAD and publish PDF(s). Print the created PDF(s) from within Adobe Acrobat. More about preferences setting here

 

Missing text in PDF published from ARCHICAD 11 or higher

Affected version: ARCHICAD 11-16| Severity: workaround applicable | ID: 66304 Note: This issue was fixed in ARCHICAD 17
 
Issue
Text is missing from PDF files published from ARCHICAD 11 or higher on Windows.

 

Cause

A Font embedding problem in the PDF engine causes that certain (not widely used) font types appear white in the output file.

 

Solution

  • From Start menu choose or select Run, type regedit to open Windows Registry Editor
  • Find the key: HKEY_CURRENT_USER\Software\Graphisoft\ARCHICAD\<ARCHICAD version>\PDF
  • Double-click the DWORD entry named Font subsetting and set the value to 0.
wp-content_uploads_archicadwiki_bugs-textmissinginpdf--registryeditor.png
This will change how fonts are saved into the PDF file. The result will be larger PDF files, since now all subsets of all font types will be embedded into the PDF file.

 

Printing problem with too dense Fills

 
Issue
Printing takes enormously long time or it won't print at all - ARCHICAD freezes when printing.

 

Cause

There are too dense fills on the piece of project you want to print. Thus simply too many lines will be generated during printing - this is what takes a long time. These fills can be made too dense either by distorting them or by editing their vectorial pattern in the Options Menu Element Attributes/Fill Types. In general ARCHICAD detects such dense fills but only in the case of standard fills, not distorted fills. If a fill is found to be too dense, it is replaced by a solid one during printing to avoid such cases.

 

Solution

If you face such problems when printing, check your fills, especially the distorted ones.

 

Printing problem with transparent fills

Affected version: ARCHICAD 11-20 | Severity: workaround applicable | ID: 77675
 
Issue
Fills are not printed correctly via the File-Print menu or from printing via the Publisher Dialogue box. Some part of the fills are missing, see examples:
wp-content_uploads_archicadwiki_bugs-printingproblemwithtransparentfills--vegleges001.jpg
wp-content_uploads_archicadwiki_bugs-printingproblemwithtransparentfills--vegleges003.jpg

 

Cause

When transparent solid fills (also known as "percentage fills") overlay other fills, the transparency might appear correctly on screen and in PDF, while it looks bad in printing. The reason is the data conversion that occurs while the data is passed to the printer.
On Mac: When printing from a Mac OSX application, a PDF file is used as an interim "spool" data format between the application and the printer driver. The printer driver converts this PDF file into PostScript data for PostScript printer types. PostScript has limited support for transparency, which is why the end result is sometimes bad while the PDF output from ARCHICAD still looks good.
On Windows: ARCHICAD sends information to the printer driver in GDI plus format. This data is then converted by the printed driver to the printer's own language. (Some common printer languages include PostScript, PCL5, GDI). Some of these languages have limited support for transparency, therefore some of the visual information is lost in translation.

 

Solution

  • As a workaround save the output as PDF file. Print this PDF with Adobe Reader. Adobe Reader re-processes the content of the PDF file and has sophisticated algorithms to circumvent many of the PostScript limitations. Adobe Reader is free on both Mac and PC.
  • Use a non-PostScript printer driver.
  • Avoid overlaying pattern fills with semi-transparent (percentage) fills.
wp-content_uploads_archicadwiki_bugs-printingproblemwithtransparentfills--3.jpg

 

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