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ARCHICAD 18 performance troubleshooting guide

Katalin Borszeki
Graphisoft
Graphisoft
Performance related issues can come from various causes. Most of these issues can be due to the insufficient Software/Hardware availability or the way how the project is created in ARCHICAD. Depending on the nature of the issue you experience check the categories below. For generic issues, please see this article

2D pan and zoom gets slow, laggy and unresponsive when Trace Reference is on

Info_18x18.png NOTE: This issue is fixed in ARCHICAD 18 Update 7000
  • Issue:
If you turn on Trace Reference in 2D view, navigation (Pan and Zoom) may become unresponsive, slow and laggy. This is a known issue with the latest update of ARCHICAD 18 (build 6000), on Windows platform.
  • Cause:
If you experience such symptoms, you probably have the Renovation palette turned on. Renovation palette keeps refreshing itself as you navigate in the 2D window, and this constant refreshing causes the navigation to lag, in case you have a complex model, with a lot of snap points (also, the Renovation palette may start flashing).
  • Solution:
Close the Renovation palette while you're using the Trace Reference, and vice-versa. Note: We plan to fix this issue in an upcoming update of ARCHICAD 18.

Multiple ARCHICAD instances cause Freeze/Crash

Info_18x18.png NOTE:This issue has been reported to Nvidia.
  • Issue:
Multiple ARCHICAD instances can exhaust the RAM. The instance is consuming the memory until ARCHICAD freezes. This issue can occur in any version of ARCHICAD on Windows computers. In some cases Drawing Updates between the two instances lead to crashes as well.
  • Cause:
One possible cause of this problem is an nVidia graphic card related application, called nVidia GeForce Experience. The application disturbs the Inter-process Communication (IPC) between the ARCHICAD instances. The memory being used up is the consequence of this disturbed connection between the two ARCHICAD instance.
  • Solution:
Stop and disable 'NVIDIA Streamer Service'. Steps:
  • Launch the Computer Management by right clicking on 'Computer' (select 'Manage' from the drop-down menu) or you can also open it from command prompt or from Run (the run command for opening: compmgmt.msc)
  • Double Click on 'Services and Applications'
  • Open 'Services'
  • Select 'NVIDIA Streamer Service' and open the Properties from the drop-down menu by right clicking on the service
  • Click on 'Stop'
  • Change the Startup Type to 'Disable'
  • Apply the changes
wp-content_uploads_troubleshooting_nvidia-265x300.png
Info_18x18.png NOTE: You must be logged in as an administrator to disable Services. Note: An update for nVidia driver might enable and start this Service. Please check the Service Properties after installing an update and if it is necessary sotp and disable it again.
  • Solution:
Reconfigure 'NVIDIA Streamer Service'. Steps:
  • Open Registry Editor
  • Go to HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation key
  • Select MessageBusPort and change its value lower than 65000

Insufficient Software/Hardware

Check here if your setup meets the minimum or recommended software and hardware requirements. This article gives you further - under the hood - information on the recommended hardware setup.

General Speed issues

This article describes how to tackle generic 2D and 3D speed issues in ARCHICAD – what functions and components affect speed and how to fine-tune your system and your ARCHICAD for optimal performance.

Rendering issues

For rendering related issues, please see our Rendering Troubleshooting Guide

ARCHICAD 18 specific issues

Opening of Render Settings and Surface Settings dialogue slow in all localised versions, Windows only

Info_18x18.png NOTE: This issue is fixed in ARCHICAD 18 Update 4020
  • Issue: When pulling up the Render Settings and Surface Settings dialogue, ARCHICAD is loading a c4d.xml file that causes the window to appear on the interface slowly, possibly only after 6-7 seconds
wp-content_uploads_images_Screen-Shot-2014-06-18-at-16.47.28-e1403102899375.png
  • Solution:
This issue is planned to be fixed in the next regular update.

Complex profiled walls causing slowness

  • Issue:
The presence of a large number of very detailed complex profiles causes slowness by creating an excessive number of polygons and decelarating priority based connection calculations
wp-content_uploads_fig9.gif
  • Solution: 
As a recommended workflow details of complex profiles should be developed in BIM up to a 1:50 (1/4″=1′-0″) scale level.

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