Far From Origin – Troubleshooting Guide

by GRAPHISOFT, Katalin Götz, ShaunCoomber, Márta Trón and Tamás Gáspár · updated: 12.01.2016

About Origins in ARCHICAD

In ARCHICAD, as in any coordinate system, all measurements are made in reference to an origin. The location of the origin is always interpreted as (0, 0).

 

ARCHICAD defines three coordinate system origins:

Project Origin

The Project Origin is a constant location which remains fixed for the life of your Project. (The Coordinates Palette shows the coordinates as (0, 0).
In Floor Plan and other 2D views, the origin is always marked by a bold X.

origin.PNG

In 3D Views, the origins and their X, Y and Z axes are displayed with bold black lines.

origin3d.PNG

User Origin

By default, the User Origin is located at the Project Origin. However, the User Origin can be moved to any location, allowing you to “reset the zero point” to any location.

Edit Origin

The Edit Origin is also temporary; it appears only during drafting and editing operations and is used to display the distance and angle of a rubber band line from the starting point of a drawing operation.


Why can Projects be Located Far From Origin

Loss of precision or malfunction can be experienced if the project elements are located very far from the project origin or from each other. It can usually happen:

  • if the project is located at real world coordinates in ARCHICAD, according to standards in certain countries. (You can avoid it by using the Survey Point object.)
  • if you made a draft in the plan placed far from the project model
  • by mistake during numeric input or a multiply operation
  • if you import a DWG file that is placed far from AutoCAD ‘s WCS (World Coordinate System), probably it has been set relative to UCS (User Coordinate System)

Potential Issues

There is a model placed very far from the origin

This case, if there aren’t any other elements near to the origin, the model can be placed ~108 = 100 000 000 m far from project origin

There are more elements placed far from each other

The logical origin is generated in the centre of weight of all model elements. This case you can experience some of the following coordinate transformation or display problems:

  • distortion when zooming in a long way in 2D
  • creating Arc/Circle
  • flickering when orbiting/moving in 3D Open GL view (~up to 2-3 000 m)
  • rendering with Lightworks Engine (~up to 10 000 m)
  • drawings disappearing or displaying as empty on layouts

Teamwork

The offset value that is set at the time of sharing will be “hard-wired” into the project. It is not possible to change it afterwards.


How offsetting works

From the nature of floating point number representation point coordinates near the origin are different in comparison to those far from the origin.

To avoid the potential accuracy problems, ARCHICAD is using Double Precision to calculate coordinate transformations. In case you need to work with huge coordinates, a new, invisible origin is created in the centre of weight of the placed elements every time you open the file. It results a new reference coordinate system.
Elements across all storeys and views (Section, Elevation, 3D, etc.) placed to the model will be included in the same calculation.

  • Origin01.png

Check Your Project

Far from origin models can be checked the following way:

Set all elements visible in the project

  • Open Layer Settings (Document > Layers > Layer Settings) where you can set all the layers visible.
  • Open Renovation Filter Options (Document > Set Renovation Filter > Renovation Filter Options) and set the existing, to be demolished and new elements in “Show” status on the current Renovation Filter.

Fit in Window
You can resize your view to accommodate all elements placed in the project.
Choose the View > Fit in Window command or click the corresponding shortcut button on the bottom scrollbar of the active window.

This step should be repeated on all Stories.


Fix Your Project

If it is necessary for the model data to be located far from the origin and display problems are experienced, all elements should be positioned close together and on a similar position across all stories. The center of weight will be recalculated after the file has been saved and reopened (unless it is a Teamwork project – see below).

When exporting and importing an IFC model, ARCHICAD 20 supports the survey point (site local placement) definition.

An alternative solution is to move the User Origin away from the Absolute Origin, and use coordinated relative to the User Origin. The model can then be left at the Absolute Origin.

Relocate Projects Placed far from the Project Origin

Loss of precision, malfunction can happen if the Project is located very far from the ArchiCAD Project Origin, e.g. according to standards in certain countries or while importing DWG.

From the nature of floating point number representation point coordinates near the origin is different in comparison to those far from the origin.

Solution

In order to relocate the project back to the ArchiCAD Origin follow the steps below:

Step 1: Set all the Layers

Set all the Layers and Renovation Filters to Show and Unlock. Elements locked by Lock command can be unlocked in Edit menu/Locking.

Step 2: Show Absolute Coordinates

Check the Coordinate Palette if relative coordinates are displayed, if yes switch this button off to show absolute coordinates.

CoordinateP.jpg

Step 3: Return the Origin

Double click on User Origin button on Coordinate Palette to return the origin to the Project Origin.

Step 4: Place a New Hotspot

Place a new hotspot at the project origin by typing the coordinates x=0, y=0.

Step 5: Fit in Window

Click on the command Fit in window in the Display menu. The project and hotspot together with the project origin should appear in two different corners of the screen. You can check it with Select All (ctrl+A) command.

Step 6: Select All Stories

Use the bold Marquee to frame the project and use Edit/Select all command, so all the stories become selected.

Step 7: Drag the Project

Drag the project to the project origin.

By using Fit in window the project will be adjusted to the screen.

Step 8: Save and reopen the Project

Origins are counted during the opening of files. After you repaired the plan, it should be saved, closed and opened again to get the updated origins.

 

A Worksheet is Far from Origin

Affected versions: All ARCHICAD versions | Severity: workaround applicable | ID: 215006

There are cases when the model itself is near the Origin, but Zooming causes phenomenon like on the following screen shot. This is the typical sign of a Worksheet with drawings Far from Origin.
ffo
In this very case, the solution – that we discussed above – can’t fix the Far from Origin issue, because ARCHICAD doesn’t offset on the Worksheets if the floor plan doesn’t need to be offset.

Solution

As a workaround it is needed to cause Far from Origin on the floor plan, then offsetting will be done on the Worksheets as well. After these, the caused FFO of the floor plan should be fixed again. This method step-by-step:

  1. Place an element on the floor plan far away from the rest of the plan;
  2. Save the plan, close and open it again;
  3. The Worksheet is fixed and the placed element can be deleted again. – If not, move the new element much more far away and continue from the 2nd step.
  • Was this Helpful ?
  • 0   ​6

Related content

Renovation Filter Options

Use this dialog box ( Document > Renovation > Renovation Filter Options ) to define how to display elements for each Renovation Filter. You can change the settings of existing filters, or create new Renovation Filters. Renovation Filter Options are…

About Origins in ArchiCAD

In ArchiCAD, as in any coordinate system, all measurements are made in reference to an origin. The location of the origin is always interpreted as (0, 0). ArchiCAD defines three coordinate system origins: Project Origin The Project Origin is a constant…

Relocate Projects Placed far from the Project Origin

See also: FarFromOrigin It can be experienced loss of precision, malfunction, if the Project must be located very far from the ArchiCAD Project Origin, e.g. according to standards in certain countries or while importing DWG . From the nature of floating…