Tips to Import DWG Files as Trace Reference

by GRAPHISOFT and Katalin Götz · updated: 12.13.2012

Sometimes we get reference files such as site plans, drafting aids, plans from co-workers in DWG format that we should not modify. To display two different views concurrently in any ArchiCAD model or layout window, we can use the Trace Reference feature as a temporary editing aid.

The cursor will be sensitive to elements in the Reference and we can use the Pick up Parameters and Trim command, the Magic Wand and the snap points with elements in the DWG Reference to edit Active elements.

TraceReference.png

In the following, you can read about how to import DWG files and use them as Reference effectively:

Step 1: Create a New Worksheet

The Worksheet is a great tool to store 2D information used as a design or editing aid.
To create a new independent Worksheet viewpoint, use the Create Independent Worksheet command from the Worksheet folder context menu in the Project Map of the Navigator.

NewWorksheet.png

Step 2: Place DWG as Reference

In our example we prefer to place the DWG file as a Drawing in the Worksheet, because it has many advantages:

  • It can be placed into the currently open ArchiCAD project
  • Cannot be edited accidentally, but it can be exploded to simple 2D elements if necessary
  • It places the entire plan onto one ArchiCAD layer
  • The embedded DWG layers are stored and can be turned on/off very simply: DWG/Import/Layers

  • You can define the assignment of pen sets to placed DWG Drawings: Drawing Settings

  • It will not import all attributes of the DWG file

To place the DWG as Drawing into the Worksheet window, activate the Drawing tool and click in the model window where you want to place the Drawing. In the appearing Link to dialog, browse for the desired DWG file. Select the DWG and click to Open.

PlaceDrawing.png

Depending on your requirements, other import functions can be also used to open the DWG as reference file:

Merge:

  • Native ArchiCAD elements are generated during the import that can be immediately edited in ArchiCAD
  • A selected DXF/DWG Translator can be used during the conversion
  • Only the selected layers are imported

XRef:

  • A selected DXF/DWG Translator can be used during the conversion
  • Keeps the connection between the source (DWG) and the host (ArchiCAD) file, so if the external DWG file has been modified, it can be simply reloaded
  • XRef layers can be listed and managed in Layer Settings dialog

Further reading about differences in DWG import options: DWG/Import

Step 3: Set as Trace Reference on Floor Plan

The Drawing we placed on Worksheet can now be used on any Model or Layout Views as Trace Reference.

Select the Worksheet from the Navigator and right-click to bring up its context menu. Choose Show as Trace Reference.

ShowAsTrace.png

Go to Floor Plan and activate the Trace content.

ActivateTrace.png

TIP: When working with Trace References, it is worth opening the Trace & Reference Palette, which contains all controls that affect the Reference: Window > Palettes > Trace & Reference.

Step 4: Drag Reference

The Drag Reference command is accessible from View > Trace Options > Drag Reference or from the Trace & Reference palette.
Click on the drag command to set the correct position of the DWG Reference. You can use the snap points with elements in the reference, too.

DragTrace.png


Tutorial and Further Tips

In this video by BIMES you can follow all these steps live and get further tips on working with Reference files.



How to Trace 2D Drawings to Quickly Create a 3D Model by EricBobrow



  • Was this Helpful ?
  • 3   ​0