Using Partial Structure Display for Structural Connection

by Emőke Csikós and GRAPHISOFT · updated: 01.20.2017

In the AEC industry it is a daily demand to architects to be able to present, display and export their architectural models simplified or filtered in certain ways. Cooperation with structural engineers usually require a structural model.

There are several ways to appropriately filter the content to be exported:

  • using layers and layer combinations (Document > Layer > Layer Settings…)
  • using Partial Structure Display options (Document > Partial Structure Display)
  • filtering the content of the 3D Window (View > Elements in 3D View > Filter and Cut Elements in 3D…)

You can set the structural function of all model elements in their Settins dialog under the Categories and Properties tab:

structural function

There are four different options for Partial Structure Display:

psd

The Partial Structure Display settings define how composite and complex structures appear. Walls, Slabs, Roofs and Shells can be defined as composite structures. Composites can be created and managed in Options/ Element Attributes/ Composites. 

structure options

 

core skin in composite

Walls, Beams and Columns can have a Complex Profile structure as well. Complex Profiles can be created and managed in Profile Manager in Options/ Element Attributes/ Profile Manager .

beam

The load-bearing skin of a composite or complex structure is called the  Core. Skins can be defined as Core, Finish or Other.

Partial Structure Display affects the display of elements in 2D and 3D windows alike, and it can be assigned to the following window types:

  • Floor Plan
  • 3D Window
  • Section / Elevation / Interior Elevation/ 3D Document
    Each instance of these window types can have its own Partial Structure Display setting (for example, you can have three Section windows with three different Partial Structure Display settings).
  • Worksheet / Detail
    If the source viewpoint is in the Floor Plan or is an Auto-update viewpoint, you can set Partial Structure Display settings for Worksheets and Details (separate ones for each window, if needed).

Partial Structure Display can be set for the current window at four different locations::

  1. Document > Partial Structure Display
  2. Properties / Settings in the Organizer / Navigator Project / View Map
  3. Partial Structure Display pop-up in the Quick Options palette (Window > Palettes > Quick Options)
  4. at the bottom of ARCHICAD’s main window on the tab dedicated for Partial Structure Display

The Partial Structure Display setting is saved with the view. The following figures are examples of Partial Structure Display settings applied for different views.

Sections

entire model > without finishes > core only

sections all

 

3D View

entire model > without finishes > core only

all

featured

entire model > core only

 

 

Exporting to IFC

There is a model filtering option when saving the file as IFC:

IFC

See more on IFC export and the OPEN BIM workflow in this series of articles:

IFC Based OPEN BIM Workflow – Part 1

IFC Based OPEN BIM Workflow – Part 2

IFC Based OPEN BIM Workflow – Part 3

  • Was this Helpful ?
  • 0   ​0