Top 12 ArchiCAD Commands You Should Use all the Time

by Greg Kmethy, Katalin Götz and GRAPHISOFT · updated: 07.25.2013

Would you like to work faster and more efficiently in ArchiCAD?

We have collected 12 lesser known shortcuts in ArchiCAD International version that can ease your daily workflow:


Highlight Toggle

Shortcut: TAB

Have you ever wanted to select a Zone instead of a Slab?
The TAB button allows you to toggle through overlapping elements. The active element will be highlighted.

QuickSelection.png

Quick selection Toggle

Shortcut: Spacebar

Do you want to modify a text, but cannot open up its Text Editor?
By pressing the Spacebar with the Arrow Tool active, you can temporarily activate or deactivate the selection of elements by their surfaces.

QuickSelection01.png

Force Guide Line Display

Shortcut: Q

“Force Guide Line Display” is a keyboard shortcut that makes using Guide Lines even smoother.
Use this shortcut to:

  • Make multi-choice Guide Lines appear during element input without having to press the mouse button.Note: Your cursor needs to be resting on any point of the element for this to work.
  • Create or activate a Guide Line along an edge without having to click the Guide Line handle.
  • Grab and move the Guide Line with your cursor without having to click the Guide Line handle.Note: Your cursor must be over top of the Guide Line handle (the orange dot) for this to work.

Read more: GuideLines

ForceGuideLines.png

Show/Hide Guide Lines

Shortcut: L

Are you lost in the jungle of Guide Lines?
Use the “L” shortcut to turn Guide Lines on and off.

HideGuideLines.png

Pick Up/ Insert Parameters

Shortcut: Alt and Ctrl/Cmd+Alt

Press the “Alt (option)” button to pick element parameters to set them as default. Use the inject (Ctrl/Cmd+Alt) command to transfer the parameters into an element. You can inject parameters into an element in any view, 3D, or in the Door, Window or Object Settings dialog.

See also: How to Transfer Door/Window Parameters

ParameterTransfer.png

Measure Distance and Area

Shortcut: M

The Measure Tool is usually used for measuring distances between two points. But with two or more clicks, the Tracker also shows the cumulative distance and area.

Measure.png

Temporary Orbit Mode

Shortcut: Middle mouse button plus Shift key

While in editing mode (not in Orbit mode), you can temporarily simulate Orbit mode by pressing Shift together with the mouse scrolling button. Release the keys to stop orbiting.

TIP: How to set the middle button on Magic Mouse?

3dOrbit.png

Fit in Window

Shortcut: Double-click middle mouse button

Double clicking your middle mouse button will resize your view to accommodate all elements placed in the project. This provides a good way to check whether you have placed something in the far corners of your window.

FitInWindow.png

Switch between Pet Palette Items

Shortcut: F

Move your cursor over the icons to read the tool tip for each one, and click on the icon for the function you need. Use the shortcuts “F” and Shift+F (Opt+F) to move between the next and previous icons in the current pet palette.

PetPalette.png

Instant Arrow Tool

Shortcut: Shift

While another tool is active, hold down the “Shift” button and the Arrow tool will be available in the Info Box since ArchiCAD 16.

You can point at the desired element and click; or drag the mouse to draw a rectangle around the element you want to select.

ArrowSelection.png

Activate Last Used Tool

Shortcut: W

Pressing “W” allows you to toggle between the Arrow tool and the last used tool. The active tool will be selected in the Toolbar.

LastUsedTool.png

Previous/Next Tool in Toolbox

Shortcut: Page Up and Page Down

“Page Up” and “Page Down” toggles between and activates the tools located directly above or below whatever tool is currently active in the Classic Toolbox.

PageUpDown.png

What’s More

The entire list of all ArchiCAD commands is available within ArchiCAD:

Options/ Work Environment/ Keyboard Shortcuts

WE.png

Tips

Recommended shortcuts by ArchiCAD experts:



  • Was this Helpful ?
  • 9   ​0

Related content

Zoom to Selection

Use this command ( View > Zoom > Zoom to Selection ) to move in on only selected elements. This command is also available from the context menu, if you right-click in an empty space on the screen…

Shortcuts

ArchiCAD is shipped with several predefined shortcut schemes. To view or print out a list of the shortcuts of the Work Environment, go to Options > Work Environment > Keyboard Shortcuts , and click the Show Shortcut List in Browser button at the…

Keyboard Shortcuts

ArchiCAD is shipped with several predefined shortcut schemes. These can be listed and most of the shortcuts can be redefined in Options > Work Environment > Keyboard Shortcuts dialog box. Show Shortcut List in Browser The currently assigned keyboard…

Parameter Transfer Between Objects

After you have adjusted an object’s parameters, Parameter Transfer offers a way to transfer your edits to a different object of the same subtype (e.g. transfer parameters between two window objects). See also Parameter Transfer for other ways to use…

Fit in Window

You can resize your view to accommodate all elements placed in the project. This provides a good way to check whether you have placed something in the far corners of your window by mistake during numeric input or a multiply operation. Choose the View >…