Quick Layers Palette

by GRAPHISOFT and EricBobrow · updated: 08.27.2008
  • {i} ForWikiEditors : ToDoTechTip/ – check and update article, merge with LayerSettings

Originally published at Cadalyst: http://aec.cadalyst.com/aec/Column%3A+ArchiCad/Quick-Layers-Palette-ARCHICAD-Insights-Tutorial/ArticleStandard/Article/detail/545212?contextCategoryId=6575

written by Eric Bobrow Principal, Bobrow Consulting Group


Editor’s note:

This tutorial courtesy of ARCHICAD. ARCHICAD’s Quick Layers palette is a complement to the Layer Settings dialog box that allows layers to be turned on and off or locked on the fly to suit various needs. It is elegant, intuitive, and compact, and it has a memory of layer states so you can retrace steps and undo and redo layer manipulations instantly.

Layers are a classic, versatile way to control the visibility of elements and to focus or restrict the effects of editing to specific parts of the model or drawing. ARCHICAD’s concept of Layer Combinations is integrated beautifully into the definition of views to guarantee that drawings are created and maintained with predictable sets of information without effort. Whenever a view is created (typically by clicking the Save Current View button at the bottom of the Navigator palette’s View Map), the current layer combination is stored along with all other context settings. Double-clicking will activate a view and restore the layers to the proper state for that particular drawing or editing mode.

Unlike some BIM solutions that reject the concept of layers, ARCHICAD’s methodology is fully extensible and customizable by each user. It allows creative adaptation for all project types, sizes, and phases, as well as accommodating a range of user preferences and output requirements.

Showing the Quick Layers Palette

To show (or hide) the Quick Layers palette, simply select Window / Palettes / QuickLayers :

1.jpg

The palette will then appear onscreen, and can be dragged to a convenient location by its title bar.

2.jpg

The palette can be hidden by clicking on the Close button in the title bar, or selecting the Quick Layers command again. Of course, like all other commands in ARCHICAD, you can create a keyboard shortcut in Options / Work Environment / Keyboard Shortcuts or add a button to the Toolbar to show or hide the palette with a single click.

Retrieving Data on Hidden Layers

The left-hand button on the palette will toggle the visibility of all layers (hiding whatever layers are currently showing, and conversely showing the layers that were hidden):

3.jpg

One case in which I’ve found this very helpful is when there is data on a hidden layer, and I’m not sure which layer it is on. This situation can be tricky when dealing with information from a consultant, such as a survey that has been brought in as an xrefed DWG file. There may be many layers in the imported file, and it is hard to know what layers these elements are placed on. If you opens the Layer Settings dialog box and looks through the list, then guesses which layer(s) to turn on, it may be hit or miss. It may take several tries and some frustration to find and show all the data that is needed.

For example, let’s say you need to see the property lines to check on setbacks. Here is a floor plan without the property boundary data showing:

4.jpg

With QuickLayers , it’s very simple to do this:

  • 1 Click the Show/Hide Toggle button. Now all the layers that were hidden are showing, and all that were showing are now hidden.
  • 2 Select one or more (formerly hidden) elements you would like to make visible for the next modeling or editing task — in this case, one of the property lines and its label:

5.jpg

  • 3 With these items selected, click the button to Unlock the Selection’s Layer (this step is optional, and only necessary if the layer is locked and you will need to edit the data):

6.jpg

  • 4 With the items still selected, click the button to Hide the Selection’s Layer:

7.jpg

  • 5 Finally, click the Show/Hide Toggle button (the one on the far-left used in step 1).

At this point, the “missing” property line layers are now showing, along with all the original visible layers.

8.jpg

Once you get used to this sequence, it takes only a few seconds: Toggle, Select, Unlock, Hide, Toggle back. You can virtually instantly “retrieve” information from one or more hidden layers using this method.

At this point, of course, the layer combination has been modified manually, and the Quick Options palette will show that a custom layer combination is in effect:

9.jpg

TIP: If you haven’t been using the Quick Options palette, this may be unfamiliar to you. It can be shown or hidden using Window / Palettes / Quick Options, or by clicking the Quick Options button (third from the left at the bottom left of most working windows, next to the drawing scale button). Quick Options is often docked or snapped below the Navigator, but may be moved around as desired. The Quick Options palette is also one of my personal favorites, since it allows instant manipulation not only of layer combinations, but also model view options and more. Note that the ARCHICAD v12 version of Quick Options (pictured above) has been expanded and now also controls pensets, partial structure display, and dimension settings.

If you need to re-use this particular custom layer combination, either for modeling/editing or for output, then it may be appropriate and useful to create and name a new Layer Combination in the Layer Settings dialog box:

10.jpg

If you don’t need to re-use this custom layer combination, then when the current modeling or editing task is completed, simply choose a layer combination from the Quick Options palette, or double-click a view in the View Map to activate a layer combination.

Simplifying the Working View

Sometimes you need to focus on just certain elements, and others are nearby that make it harder to get the work done. In this case, there are two palette buttons you can use to simplify the working view. One of these buttons will selectively hide layers, while the other shows only the layers of selected elements.

Suppose in this view that you would like to work on the building partitions without the furniture, fixtures, and room names:

11.jpg

Select one or more fixtures and room labels, then click on the button to hide selection’s layer:

12.jpg

Now you have a simpler view in which to work:

13.jpg

If you’d like to hide additional layers, simply select items on those layers, and click the button again. After completing the task, you can step backwards through the layer manipulations by clicking on the Undo QuickLayer Actions button:

14.jpg

Layers that have been hidden will again be seen. After using this Undo option, you can redo one or more steps manipulating layers by clicking on the Redo QuickLayers Actions button, directly above it.

TIP: You can also hide or lock the layers of selected elements using the context menu (right-click), however then there is no Undo option. Sometimes I use the right-click method when I don’t expect to Undo my layer actions, and then re-establish the layer combination using the Quick Options palette or the View Map.

An alternative to the Hide Selection’s Layer method above is to select one or more elements (for example, the exterior and interior walls), then click the Hide Others’ Layer button:

15.jpg

Now (in this case) you have a view of just the walls:

16.jpg

TIP: If you’d like to hide door and window markers, these are not controlled by layer manipulation. Instead, they are turned on and off by the Model View Options, which can be accessed instantly in the Quick Options palette.

Sometimes it’s better not to hide other elements, but instead to lock their layers using the Lock Other’s Layer button:

17.jpg

Then it’s easy to select and drag or stretch elements only on certain layers, without disturbing others.

NOTE: In older versions of ARCHICAD, if you had a selection set in which some elements were on locked layers, you couldn’t drag or edit the selected elements, since ARCHICAD recognized that the locked elements would not be moveable. However, in recent releases of ARCHICAD (including at least v11 and v12), it is possible to Select All, or use an Arrow selection of elements, then move or stretch the elements on the unlocked layers, while leaving the elements on locked layers undisturbed.

I keep the Quick Layers palette visible onscreen most of the time while I work or teach ARCHICAD classes, since it is compact, and so useful to have at hand.

  • Was this Helpful ?
  • 2   ​1

Related content

Quick Options Palette

The Quick Options Palette displays the current settings of the active (frontmost) window. The Quick Options Palette is displayed by default at the lower right corner of your screen. (You may have to drag the palette to a new position or stretch it to see…

Navigator Palette

About the Navigator Palette How to Display the Navigator Using the Navigator to Open Project Windows Project Workflow in the Navigator Organizer Palette Navigator Color Codes Navigator Project Map Navigator View Map Clone a Folder in the View Map Setting…

Layer Combinations

Layer Combinations are named sets of Layer settings. For example, you can set up a “Show All, Lock 3D Elements” Layer Combination, in which all the layers are visible, yet all Layers assigned to 3D model elements are locked, making those elements…

Quick Layers

The Quick Layers palette lets you quickly change the state of the Layers in your Project without having to open the Layer Settings dialog box. To display this palette, choose the Window > Palettes > Quick Layers command. Select the element(s) whose…

Layers

About Layers Layer Settings Dialog Box Quick Layers Layer Combinations Use Layers to Prevent Intersections Use Separate Layer Settings for the Layout Book Place All Elements on a Single “Active Layer” (Simulate AutoCAD Work Methods) Show/Hide Layers of…

Keyboard Shortcuts

ArchiCAD is shipped with several predefined shortcut schemes. These can be listed and most of the shortcuts can be redefined in Options > Work Environment > Keyboard Shortcuts dialog box. Show Shortcut List in Browser The currently assigned keyboard…

QuickTime

QuickTime, Apple's multimedia environment was used in ARCHICAD up until version 17 for: processing image files, creating Fly-Through & Sun Study movies, Virtual Reality Scenes and Panoramic Views.

DWG Layers' visibility in ARCHICAD

  To control the visibility of objects, usually there are more Layers used in DWG projects. Let's see how can the different import options in ArchiCAD manage the DWG layers:   Open File » Open To define how elements in ArchiCAD will be…