How to Transfer Projects to Another Computer

by GRAPHISOFT, Katalin Götz and Emőke Csikós · updated: 01.18.2017

This article discusses the process of transferring the ARCHICAD Projects, Libraries, Images, Linked Files from one computer to another.


Step 1: Export Projects, Library Items and Drawing Files

To ease your further work with ARCHICAD projects on another computer, save the ARCHICAD files in .pln format.

In addition to all the model data and views generated from the project, the default settings and attributes, the .pln file also includes the:

  1. Embedded library items and library references
  2. Hotlink modules references
  3. Drawing references

If you save the project in .pla format, it stores only the library parts used in the project by default. In the Save as… dialog under “Options” you can also set further content to be saved with the project:

save as dialog

save as pla

Please note that included files can largely increase the project’s file size!


Step 2: Import Projects, Library Items and Drawing Files

While you are opening the ARCHICAD project on the other computer, warnings will inform you about the missing reference files:

  1. Missing Linked Libraries
  2. Missing Hotlinks
  3. Missing sources of Drawings

warnings all

 


The missing reference files should be relinked by type:

1. Missing Linked Libraries » Library Manager

To relocate the missing library references, please open the File/ Libraries and Objects/ Library Manager… dialog.

  • Restoring Missing ARCHICAD Libraries:
    • The default ARCHICAD Library of the current ARCHICAD version (e.g. ARCHICAD Library 20 in ARCHICAD 20) can be found automatically.
    • ARCHICAD libraries from previous ARCHICAD versions that are already loaded need to be updated: select the ARCHICAD Library item on the “Libraries in Project” tab page of Library Manager. Clicking on the yellow triangle under the list of libraries you can consolidate your ARCHICAD libraries easily.
      Consolidating ARCHICAD libraries is highly recommended, because it replaces old ARCHICAD libraries with the latest one and also loads the requisite Migration Libraries so that you still have access any now-obsolete library parts you may be using.

after consolidation
Read more about migration here.

  • Unavailable Linked Library Folders
    • Library folders that are not ARCHICAD libraries and are not loaded automatically, appear as missing in the Library Manager. They should be relinked manually. Locate these libraries and add them as linked libraries, using the Library Manager’s “Add” command.

library warning

 

To relocate the missing hotlinks, please open the File/ External Content/ Hotlink Manager dialog.

  • Restoring Missing Hotlinks
    • The hotlink modules are actual elements, not just references to them. If the connection to the hotlinked module file is lost, the modules cannot be updated.
      To recreate a live Hotlink to a module, select the affected project in the Hotlink Manager dialog and relink with the new Hotlink Source manually.

hotlink manager

Read more about Managing Hotlinks here or in ARCHICAD 20 Reference Guide available in ARCHICAD’s Help Menu.

 

3. Missing Sources of Drawings » Drawing Manager

To relocate the missing drawing references, please open the File/ External Content/ Drawing Manager dialog.

  • Link Drawings from the Same Source Folder
    • If the missing drawings of the project are located in the same folder on the new computer, it is very easy to relink them. Select the missing drawings in the Drawing Manager and click on the chain icon (“Link Drawing to”) at the left corner of the dialog. If several items are selected in the dialog, it allows you to link the drawings to an external source folder.
  • Link Drawings to the Source File one-by-one
    • If the missing drawings are located in different source folders, you need to relink them with the chain button (“Link Drawing to…”) one-by-one.

drawing manager2

Read more about Managing and Updating Placed Drawings here or in ARCHICAD 20 Reference Guide available in ARCHICAD’s Help Menu.

  • Was this Helpful ?
  • 0   ​2

Related content

Libraries

Each version of ARCHICAD is shipped with a standard object library containing hundreds of preconfigured, editable objects (also ...

Managing Hotlinks

Use the Hotlink Manager (File > External Content > Hotlink Manager) to gain an overview of and manage all the modules in ...

Drawing Manager

For more information, see Managing and Updating Placed Drawings. To open the Drawing Manager, do one of the following: ...