How to Create Custom Line Types

by GRAPHISOFT and Katalin Götz · updated: 08.26.2013

Create Symbol Line Type

In our special example we are demonstrating how to create line types with letters in it, but the described steps can be applied to any custom line type.

1.jpg

When creating custom line types, the stencil of the symbol may be drawn on your Floor Plan using the simplest drawing elements, including Lines, Arcs and Hotspots. Not even Polylines or Splines can be used, let alone Text Blocks.

This means that you will have to draw your letters using lines.
It is recommended not to use Arcs in the stencils of Line Types whenever possible because it can make the Line Type more complicated. Of course one or two such line types is OK, but the more complex symbol line types there are in the file, the more difficult to handle and slower it will become.

  • Step 1: Draw the stencil on the Floor Plan or in another window, using Lines, Arcs and Hotspots.
    Draw one unit of it that will be repeated along the line. Draw it in the size that will be the size you will want it to see on your plans and drawings.
  • Step 2: Select all stencil components, then choose Edit > Copy.
  • Step 3: Choose Options > Element Attributes > Line Types.
  • Step 4: Click New. From the Add New Line dialog box. In the appearing Dialog, select the Symbol radio button and type the desired name for the new line type and click OK.3.jpg
  • Step 5: From the Line Types dialog box, click Paste line components under the graphic editing section.
    The previously captured line component will appear in the graphic editing Window.In the preview field the preview of the Line Type appears.

We need to adjust the Dash and Gap values so they are the values we want. The Dash value in our case is 20 mm. This is because we have drawn a 2000 mm long stencil on the Floor Plan at a scale of M 1:100. This gives us a 20 mm long unit size on paper. The Gap we set to 0 mm since we want the pattern to be continuous.

Click OK to accept the changes and finish creating the new Line Type. On the Floor Plan, activate the Line Tool, select the new Line Type and start drawing Line with the new Line type.

  • 5.jpg

 

Import Line Types from another ARCHICAD project

ARCHICAD Attributes (Line Types, Layers, Fills, Pens, Materials, etc.) are groups of defined settings available to your project which can be managed by opening Attribute Manager dialog: Options/Element Attributes > Attribute Manager.

By default, the ARCHICAD comes with a default set of Attributes, but you can customize them to suit to your design needs with the following steps:

  • The attributes are transfered from “Project A” to “Project B” in our example.
  • Step 1: Open “Project B” (.pln, .pla, .tpl, .mod) as normal in ARCHICAD
  • Step 2: Open Attribute Manager (Options/Element Attributes) and select Line Types icon to list the available line types in the current project

Open.png

  • Step 3: Clicking on the Open button at the right side of the dialog and select “Project A” to load its attributes

AttributeManager.png

  • Step 4: Select the needed line type(s) from the right side of the dialog and click Append button to transfer the line type as new attribute) or Overwrite button to transfer a modified attribute.

Select.png

  • Step 5: Click OK to save to quit the dialog. In the appearing dialog you can confirm and save your changes.
    The line types from “Project B” are added to “Project A” now.

 

Import Line Types using *.aat format

Project Attributes can be simply stored in Attribute Manager File format (*.aat). This file extension can be saved and opened through Attribute Manager.

  • Save .aat file: In Attribute Manager select the needed or all Attributes and click on append or overwrite buttons. The attributes appear on the right side of the dialog and can be saved in .aat or .xml format.
  • Open .aat file: In Attribute Manager click on Open button and select your existing Attribute Manager File to open.

 

Import Line Types from an AutoCAD project

The DWG file you import will merge all used Solid, Dashed or Dotted Line Types to the ARCHICAD project.
Read more: http://helpcenter.graphisoft.com/?p=25752#Line_types

DWGLine.png

 

Note: Symbol line types saved as .dwg or .pdf might be exploded to more lines which can cause extended filesize.

See also: http://archicad-talk.graphisoft.com/viewtopic.php?t=40017&postdays=0&postorder=asc&highlight=create+line&&start=0

  • Was this Helpful ?
  • 2   ​1

Related content

Attribute Manager

The Attribute Manager (Options menu) is a handy tool to create and manage the Company-standards in your ArchiCAD projects. Its commands allows you to copy (append, overwrite) attributes (Layers, Layer Combinations, Pens & Colors, Line Types, Fill…

Attribute Manager

Open the Attribute Manager from Options > Element Attributes > Attribute Manager. Displaying the dialog box might take some time, since it has to list all the attributes of the project. This dialog boxallows you to copy (append, overwrite)…

Line Types

Line types are assigned to each ArchiCAD construction element in its own Tool Settings dialog box, depending on the element type. For example, when defining how a Column should be displayed in a 2D window, you will apply different line types for its core…

Create or Edit Symbol Fill

You can edit the pattern of an existing symbol fill, or create a new symbol fill entirely: Symbol fills can be created by the user from a sketch drawn in any model window, with the following steps: 1. Draw a pattern using Lines, Arcs and Hotspots. 2…