How to clean up Attributes in ArchiCAD?

by GRAPHISOFT and Judit Boros · updated: 04.01.2011

Line and Fill Normalization

Several ArchiCAD features involve the creation of “exploded” elements. Model-based Details, Worksheets and Drawing Sections create 2D elements (lines, fills) out of the model construction elements. Also, imported DWG drawings appear in ArchiCAD in 2D form, as a large collection of lines and fills.

The user often prefers to manually edit these before outputing them as documentation, but the exploded view often contains superfluous elements (extra line segments, overlapping or superfluous fills) that make such editing difficult.

The new Linework and Fill Consolidation functions are user-driven processes to

  • optimize display and behavior of the selected 2D elements resulting from an “explosion” (as when creating Detail from model) or imported 2D drawings.
  • merge or delete unnecessary or duplicate elements (lines, fills)
  • make subsequent 2D editing easy and intuitive

Line and Fill Consolidation are separate functions and are executed independently of each other. The user selects the elements, then executes either the Linework Consolidation or the Fill Consolidation command. At this, the Linework/Fill Consolidation Settings dialog box appears, in which the user sets the desired options, then executes the process. The process follows the order in which the individual options are listed in the Settings dialog box.

Linework Consolidation

With Linework Consolidation, a Wizard – rather than the Settings dialog box – appears the first time the command is issued to simplify the option-setting process. The Wizard contains identical options as the Settings, but with additional explanations.

The Linework Consolidation Wizard:

l01.jpg

The user selects all the lines that are to take part in the Consolidation process.

The Linework Consolidation command (Edit > Reshape > Linework Consolidation) brings up the Linework Consolidation Wizard.

The user pages through the wizard and checks the boxes of every Line Consolidation option that s/he would like to execute:

  • Delete Duplicates (those which have identical attributes and positions). One line will remain.

  • Explode Polylines into Drawing Primitives

  • Ignore Attributes: On the next page of the Wizard, the user defines which line attributes (Layers, Pens, and/or Categories) the program should NOT consider when determining whether any two lines are “identical”. For example, if the user checks “Layers”, then identical lines will be consolidated even if they are on different layers.

On the same page, the user can then choose attributes for the newly consolidated lines. For example, if lines on different layers have been consolidated, then the new line will be placed on the layer chosen here.

  • Merge Connecting Lines: collinear line segments which are connected and which have identical line types will be merged into a single line.

  • Force Solid Lines: This option will apply if several lines overlap each other, and one of them is a solid line which completely overlaps the other line(s). Checking this box will delete the other line(s), with the single solid line remaining in place.

  • Merge Overlapping Lines: Lines which partially overlap and which have identical line types will be merged into a single line.

  • Adjust Overlapping Lines: This option will apply if two or more lines of different line types partially overlap each other. If you check this box, only the topmost line (as defined in the display order) will remain in place of the overlapping part.

Following the linework consolidation, a report appears, listing the number of elements (if any) that have been deleted or merged for each type of line consolidation.

At the bottom of this page, a checkbox gives you the option of using the Linework Consolidations Settings (rather than the wizard) the next time you issue the command.

Fill Consolidation

The user selects all the fills that are to take part in the Consolidation process.

The Fill Consolidation command (Edit > Reshape > Fill Consolidation) brings up a Settings dialog box, in which the user checks the options to execute:

The Fill Consolidation Dialog:

l02.jpg

At the top, in the Ignore Attributes section, the user defines which fill attributes (Layers and/or Categories) the program should NOT consider when determining whether any two adjoining fills are “identical” before merging them. For example, if the user checks “Layers”, then identical fills will be merged even if they are on different layers.

The Merge Settings button opens a dialog box in which the user can then choose a layer/category for the newly merged fills. For example, if fills on different layers have been consolidated, then the new fill will be placed on the layer chosen here.

Trim Overlapping Fills: Any selected fills that partially or entirely overlap each other will be trimmed so that only the top fill remains; any other fill (or part of a fill) that is covered up beneath the top fill will be deleted.

  • Note on Overlapping Fills with Transparent backgrounds: If the top-level fill has a transparent background, any solid-background fill beneath it will remain intact, because it will be visible.

    Exception: If there are multiple transparent fills atop each other, only the top-level fill will remain in full; any fills or parts of fills underneath, if they have transparent backgrounds and are covered by the top-level fill, will be deleted.

Convert Fill Outlines: Any fill contours will be exploded into simple line segments/arcs.

Merge Adjoining Fills: Any adjoining fills (regardless of display order) which have identical fill patterns/colors will be merged into one.

The resulting fill will carry the ID of the largest of the original fills.

If the user directed the program to merge fills even if they have different layers/categories (“Ignore Attributes”), the new resulting fill will be placed on the layer/fill category chosen in the “Merge Settings” sub-dialog box.

Fills that have different pattern orientations (project origin/fill origin/distorted) will not be merged.

  • Outlines of Merged Fills:* You have three different options for handling the merging of fills that have outlines.

    • Don’t merge fills with outlines: Such fills are not merged at all.
    • Merge fills with identical outlines only
    • Merge fills with any outlines
    • If you checked “Convert Fill Outlines”, these options are not available, since the fill outlines will no longer exist after the consolidation process.

Use Cases for Linework/Fill Consolidation

1. You’ve created a model-based Detail. After opening the Detail window, you want to fine-tune the display, but upon moving a few lines you notice that there are a great many extraneous lines that are not necessary to the drawing. Now you want these lines and arcs, which originate from different construction elements but otherwise coincide, to be transformed so that the duplicate parts are all deleted and you are left with only the necessary drawing elements.

  • Select the area of the Detail in which you want to consolidate, then issue the Linework Consolidation command. Choose “Delete Duplicates” and OK. The duplicates are deleted.

2. Your Detail drawing includes intersected composite walls, yet you want to edit the detail further to improve the output. However, even neighboring fills with identical fill patterns have been dismantled into multiple triangular shapes, making it difficult to achieve the final drawing you need.

  • Select the fills which you want to consolidate, then issue the Fill Consolidation command and check the “Merge Adjoining Fills” option. If the fills have contour lines, you can delete them with the “Convert Fill Outlines” option, or else choose one of three options for merging them together, as necessary. Choose OK. The adjoining identical fills have been merged into one.

3. You have imported a DWG drawing, which appears in ArchiCAD as a collection of 2D elements, many of them small “garbage” line segments which are not even visible due to overlapping elements. You want to get rid of these extraneous line segments.

  • Select the area of the Detail in which you want to consolidate, then issue the Linework Consolidation command. Check all the options, then OK. The unneeded lines and segments will be deleted.

4. You have a model-based Drawing Section. Before editing it manually, you want to make sure that you have just one “layer” of drawing elements – that is, it should not contain duplicate lines or overlapping fills.

  • Select the area for consolidation. Use both the Linework Consolidation options and the Fill Consolidation options to delete, trim and merge the superfluous line segments and invisible fills.

Pen Sets in Views

  • Assign Pen Sets separately to each View, using a new Pen Set pop-up in View Settings

  • Pen Sets are saved with and applied to the view
  • Easier modification of specific pens used in a drawing
  • Work on WYSYWYG model views

Pen Sets are available from the View Settings dialog

l03.jpg

  • Was this Helpful ?
  • 1   ​0

Related content

Fill Consolidation

In the current window, select at least two fills that you wish to include in the Fill Consolidation process. The Fill Consolidation command ( Edit > Reshape > Fill Consolidation ) brings up Fill Consolidation Settings. See details at Fill…

Linework Consolidation

In the window, select at least two line-type elements you wish to include in the Linework Consolidation process. Line-type elements are straight-lines, polylines, arcs and circles. Note: Linework Consolidation does not affect any line-type element having…

Display Order

When drawing a Project with ArchiCAD, overlapping elements will be drawn according to a specified stacking order. By default, elements are stacked in an order typically used in architectural drawings. By default, stacking order is determined by element…

Pen Sets

ArchiCAD comes with several predefined Pen Sets. These are listed and managed Options > Element Attributes > Pens & Colors or Document > Pen Sets > Pens & Colors . See Predefined Pen Sets for Specific Functions for an overview of the…

Line Types

Line types are assigned to each ArchiCAD construction element in its own Tool Settings dialog box, depending on the element type. For example, when defining how a Column should be displayed in a 2D window, you will apply different line types for its core…

Attributes

ArchiCAD Attributes are groups of defined settings available to your project. For example, Line Types and Surfaces are Attributes which you can apply to many project elements as you create them. You will access these attributes in the appropriate dialog…

Number of attributes

ForWikiEditors : ToDoTechTip/ - update article Speed becomes an increasing concern as the size of the Project grows. Following the below guidelines you can make sure you do not unnecessarily slow yourself down or if you do, you know where to look for the…