ARCHICAD 15 changes guide

by GRAPHISOFT and IllesArvay · updated: 08.05.2011

This list contains a collection of changes that are not reflected in the ArchiCAD 15 Reference Guide. Such as retired features, long term bug fixes, and smaller usability or interface changes.

 

1. New ArchiCAD icon is introduced

A different colorstyle icon is created for the newest release of ArchiCAD.

  • alt text

2. Interactive Training guide videos accessible from Help menu

YouTube training videos on ArchiCAD YouTube Channel now accessable from ArchiCAD Help menu.

  • 02YoutubeTraining.png

3. VR Scenes/VR Objects No Longer Supported

VR Scenes and VR Objects are no longer supported in ArchiCAD 15. Any VR Scenes and VR Objects in earlier-version projects will disappear when you migrate these projects to ArchiCAD 15.

4. SketchUp Add-On for 64-bit ArchiCAD

As of ArchiCAD 15, the SketchUp Add-On is available in standalone form for use with 64-bit ArchiCAD programs. In earlier versions, to get the Sketchup Add-On for exchange between ArchiCAD and SketchUp, you downloaded Google Earth Connection, which includes the SketchUp Add-on. Google Earth Connection, together with its SketchUp Add-on, is still available but only as a 32-bit program.

5. Plotflow No Longer Supported

As of ArchiCAD 15, PlotFlow is no longer supported. The reason: MacOSx 10.7 Lion will remove support for the software translator Rosetta, which is necessary to run PlotFlow.

6. New Save Option in DXF/DWG Translator

The DXF-DWG Translation Setup dialog box has an additional Save option. The Saving Floor Plan possibilities now include the option to “Convert Objects to Blocks.”

  • 06NewsaveDWGtranslator.png

Convert Objects to Blocks: With this option, you will convert GDL elements to blocks. All other elements will be exported as drawing primitives.

7. Default for Export and/or Import DXF/DWG

New icons are added to DXF/DWG translator just like it was previously in the IFC translator. The program’s default translators for import and export are distinguished by a blue arrow symbol; these default translators will be shown when you execute the import or export commands. You can define any selected translator as the default (for export and/or import) by using the “Default for” icons.

07DefaultButton.png

8. Change in Shell Construction: Reference Side on Top

The Shell is constructed out of a membrane plus a Shell body attached to one side of the membrane. The membrane is the Reference side of the Shell. In early Beta versions of ArchiCAD 15, and as reflected in the Help for ArchiCAD 15, the Shell body was “grown upwards” from the Reference side, in most cases. In the final version of ArchiCAD 15, the Shell body is “grown downwards,” with the Reference side on top. For example, for an extruded Shell, what you see on the top side of the Shell is the Reference side (in this case, red) and the body is appended underneath it.

  • Shellreferenceside.png

As a result, the Shell materials and reference side order are analogous to that of Roofs. As part of this change, the order of the material controls in the Shell Settings dialog box has also changed. From top to bottom, these controls are now:

08bShellreferenceside2.png

– Reference Side Material – Edge Material – Opposite Side Material

9. Changes in Editing Plane Interactions

New Toggle: Display/Hide Editing Plane This toggle is under View > 3D View Options > Editing Plane.

  • 09EditingPlaneHide.png

Note: Regardless of the state of this toggle, the Editing Plane will be temporarily displayed whenever they are necessary: for example, after you choose a plane for Ruled Shell input.

10. Display Editing Plane during Editing Operations only

New Work Environment option in Options > Work Environment > On-Screen Options. If you check this box, the Editing Plane will appear only during the time you are actively editing in the 3D window (provided that the “Editing Plane Display” toggle is turned on.) When you are done with the operation, the Editing Plane disappears.

11. New menu-based Editing Plane commands

The Editing Plane menu is found under View > 3D View Options > Editing Plane.

  • 11EditingPlaneMenu.png

12. Renamed menus and commands

1. View > 3D View Options (replaces View > 3D View Mode
2. The Look to Perpendicular command applies to the 3D Editing Plane. (In Beta versions of ArchiCAD 15, and in the Help, this command was known as “Perpendicular to Editing Plane”).

The Look to Perpendicular command is found in
• the Editing Plane sub-menu and
• in View > 3D View Options.

  • 12aEditingPlaneMenuRename.png

This command will set up the 3D window so that it is perpendicular to the Editing Plane.
3. Look to Perpendicular of Clicked Surface (replaces the command, from AC14 and earlier, known as “Look to Perpendicular”). (It is still located in View > 3D Navigation Extras.)

  • 12bEditingPlaneMenuRename2.png

This is used when navigating in the 3D window. Choose this command and click to set up the 3D window so that it is perpendicular to the clicked surface.

13. New IFC Translator for exchange with Bentley Building

New predefined IFC translator for exchange with Bentley Building

14. Floor Plan Display of Roofs/Shells

In ArchiCAD 15, if a Roof’s Floor Plan Display is set to “Outlines Only,” the line type will vary depending on the Roof’s location with respect to the Cut Plane:

• Roofs/Shells fully under the cut plane will be displayed with their full contour, with uncut lines

• Roofs/Shells fully above the cut plane will be displayed with their full contour, with overhead lines

  • 14aRoofShellFloorplanDisplay.png14bRoofShellFloorplanDisplay2.png

• Roofs/Shells that are partly above, partly beneath the cut plane will be displayed with their full contour, and uncut lines. (In previous versions, Roofs set to “Outlines Only” were uniformly shown with Uncut lines.)

15. New IFC Add Ins

The „Improved IFC Import” command creates some important additional IFC items during import: those related to Grid elements and Room definitions. You can use this function in place of Revit’s native IFC import. The „Export to ArchiCAD” command creates a more detailed IFC file with Grid elements and Profile definitions. You can use this function in place of Revit’s native IFC export. If you plan to export your IFC data for use in ArchiCAD MEP Modeler, the following add-in is recommended: Graphisoft Export to ArchiCAD for Revit MEP 2012, available from www.graphisoft.com.

16. Renovation Palette

In the ArchiCAD 15 Reference Guide on the page 55 the renovation Palette shows incorrect icons. Find below the dialogue representing the proper ones.

  • 16aRenOldPalette.png

17. “Display name” field for Publisher

In the Work Environment Dialogue under the Publisher settings a field called “Display name” is presented. This field is the remainer from the e-mail settings formerly available in ArchiCAD 14. The function is to enter the name which is chosen to be presented as “Publisher:” in Reviewer application.

17WEDisplayName.png

  • 17WEDisplayName2.png

18. Improvements in GDL Object Editing Window (GDL Master Window)

  • 18.1 2D Symbol fragments

The former buttons of 2D symbol window, have been replaced with a new method. The fragments are still operable, but now this works from a layer setting window. That can be brought up after you open the 2D symbol window, and go to Document/Layers/…..Layer Settings (2D) Symbol.

  • 18b2dlayers.png
    • 18.2 Insert New Parameter in Place

In ArchiCAD 15, when you click New to create a new parameter, the new line is inserted at the place where your cursor is located in the parameter list (rather than at the bottom of the list).

  • 18.3 Search Parameters

Enter a text string in the new search field to locate any part of that string in the Variable, Name, or Value columns. The cursor jumps to the first found instance. Use the Find next/Find previous buttons to jump to additional found instances.

  • 18-3Search.png
    • 18.4 New Migration Script Fields (For Users who Script GDL Objects)

“Migration” table: If you are scripting a library part, make sure you fill out the table in the Migration window. (Click the new Migration button, below Parameters.)

  • 18-5ANewMigration.png

– Fill in the main GUID of any old object that can be migrated to this new, currently opened object. – Fill in a version number for the old object (typically the version of a previous ArchiCAD): when the project is saved back to the previous version (and if “Convert library objects backward” is set in Options), this new object will be migrated to an old object in the migration table which has been assigned the corresponding version number. The Backward Migration script will consider all such rows until the first successful run. Note: if you enter 0 for the version number, backward migration will skip this object. Forward/Backward Migration Scripts: Click the Forward Migration or Backward Migration buttons (in the Scripts section of the GDL Object Editor window) to define how to migrate the parameters of an old instance forward to the current open element (or backward to an older element).

18-5BNewMigration2.png

19. New editing plane for MEP

The former built-in editing plane in MEP is replaced by the new editing plane introduced to ArchiCAD 15. The erronous functioning was that besides the new Editing Plane after starting editing the old grid plane appeared.

  • 19EditingPlaneForMEP.png

20. New Option when Saving Project as Module File (.mod)

When saving a project as a module file (Save as *.mod), the Options dialog box has a new checkbox:

  • 20SaveMod.png

If you choose either Current Story or a range of stories, you have the option (Add displayed elements of other Stories) to include all elements displayed on these specified stories, even if these elements are located elsewhere and do not in fact intersect these stories.

21. New Options for Project North Units

A new pop-up by the Project North control (Options > Preferences > Levels & Project North) lets you choose the unit format for displaying Project North units.

  • 21ProjNorth.png

(The accuracy of these units depends on the accuracy set for Angle Unit in Options > Working Units.)

  • 21BAccuracy.png

22. Launch New Instance of ArchiCAD

A new Work Environment option ensures that a new instance of ArchiCAD is launched every time you open an ArchiCAD project from either the Recent list or by dragging a project onto a running ArchiCAD. This checkbox is at Options > Work Environment > More Options. (By default, it is unchecked.)

  • 22LaunchNew.png

23. Mirroring text now mirrors the anchor point

From now on the mirrored instance or the mirrored copy of a text mirrors the anchor point of the text as well.

23mirror.png

24. Fill Area Text’s are transferable via the eyedropper/syringe

The properties and parameters in the Dimension Text Settings of the Fill’s Area Text can be transfered by using the eyedropper/syringe tool.

  • 24transfer.png

25. Right click on Layouts and Masters to edit their settings

When a Layout or a Master Layout item is active window and we rightclick on it, the context menu from now on brings up the ‘Layout Settings’ and ‘Master Layout Settings’.

  • 25LayoutSettigns.png

26. Snap point size and thickness for ‘True Line weight’

The size of snap points increases when the setting ‘True Line weight’ is turned on. (On-Screen View Options setting in View Menu) In previous versions of ArchiCAD when the above mentionned was turned on the thickness of the lines overwhelmed the snap point.

  • 26SnapPoint.png

27. Trial licence handling has changed in ArchiCAD version 15

In former ArchiCAD versions, trial licence file was stored within the Graphisoft/ArchiCAD folder. In some rare cases, users uninstalled Trial version of ArchiCAD which caused the deletion of the lic file as well, although they were notified about this action. The result was that the PLN files written by Trial version could not be opened anymore. In ArchiCAD 15 trial licence handling has changed: even after the Trial version has been uninstalled, the user will be able to open a Trial PLN file on the same machine using a valid licence key (Codemeter or Wibu)

28. Show user photos in lists checkbox

Allows you to display or hide the preset photos of users in Team Work dialogues. This can be accessed via Options/Work Environment/ Dialog Boxes and Palettes.

  • 28UserPhoto.png

29. Direct feedback in tracker on the length of an arc

When creating an arc the tracker shows new parameters about the Chord and the Arc length.

  • 29ArcTracker.png

30. SEO enhancements

When elements or objects are selected on the floor plan, and then the Solid Element Operation is activated, the previously selected elements will be set as targets for the operation in the opened dialogue.

  • 30SEOselect.png
  • Was this Helpful ?
  • 0   ​0

Related content

Top 12 ArchiCAD Commands You Should Use all the Time

Would you like to work faster and more efficiently in ArchiCAD? We have collected 12 lesser known shortcuts in ArchiCAD International version that can ease your daily workflow: Highlight Toggle Shortcut: TAB Have you ever wanted to select a Zone instead…

On-Screen View Options

The View > On-Screen View Options command produces a list of items (generally aids in editing) that can be shown or hidden on screen, depending on your preferences. Other items in this list let you toggle between line weight options and vectorial vs…

3D Navigation Extras

Other controls useful in modifying the 3D view are available from the View > 3D Navigation Extras (or a toolbar containing 3D window commands). These controls allow you to: Interactively set the target point for the perspective ( Look to ). Switch to…

3D View Options

When using ArchiCAD’s Internal 3D engine, three 3D viewing modes are offered: Wireframe, Hidden Line, and Shading. They can be chosen from the View > 3D View Options > 3D Window Settings dialog box or using the commands of the View > 3D View…

Editing Plane Display

The Editing Plane is shown by default in the 3D window. To hide it, use the toggle at View > Editing Plane Display. Note: Regardless of the state of this toggle, the Editing Plane will be temporarily displayed whenever necessary: for example, after you…

Working Units

To set working units for the current project, use the dialog box at Options > Project Preferences > Working Units. If you open a Teamwork project from the server, its Working Units will have default values based on the template used to create the…

SketchUp Add-On

  SketchUp Add-On is fully integrated to the package of  Google Earth Connections Add-On. SketchUp Add-On means, in day-to-day design terms, a smoother workflow from a building's very conception through to a 3D model. Now even these earliest sketch…

WIBU Key not found for ArchiCAD 7, 8 and 9

Issue On OS X 10.6 Launching AC 7, 8, or 9 Warning message appears, "No WIBU-KEY driver found. (501)”, ArchiCAD cannot be launched. Cause Wibu key driver 6.00e was installed on that machine during the installation of ArchiCAD 16. This driver cannot run…

Tips to work with Guide Lines

[no_toc] Guide Lines are drafting aids which help you find special points and projections, to ensure precise input in both 2D and 3D windows. Guide Lines are based on the cursor’s relationship to the input plane and to existing elements. 1. - Show/Hide…

ARCHICAD 16 Changes Guide

This list contains a collection of changes that are not reflected in the ArchiCAD 16 Reference Guide. These include retired features, bug fixes, and smaller usability or interface changes which were made to the program after the Reference Guide was…

Layer Extras

Updating Views and Layer Combinations via the Context Menu – by Link Ellis, Worldwide Consultant "If I am working along in a view and decided that I want to turn a couple layers off so I click and hide them through right click, or through the palette, is…

Solid Element Operations in Archicad

ForWikiEditors : ToDoTechTip/ - check and update article Originally published at AECBytes: http://www.aecbytes.com/tipsandtricks/2006/issue10-archicad.html written by Eric Bobrow Principal, Bobrow Consulting Group Archicad's Solid Element Operations…

What are ifc's

Originally published at Digital Vision Automation, Inc.: http://www.digitalvis.com/archicadtips written by John Stebbins Associate AIA ifc is a 3d file format specific to the Building Industry that allows a user of 3d software to Save as or export a file…