macOS 10.12.4 Update: crash & display issues

by Csaba Kézér and Gábor Almási · updated: 05.15.2017

Affected versions: All ARCHICAD versions | Severity: Workaround applicable | ID: 225917, 225992


Apple has fixed this issue with the macOS 10.12.5 Update, released on 05.15.2017.


Issue

Upper part of the workspace may appear blank on macOS Sierra 10.12.4 Update (released on 03.27.2017) with Intel Iris graphic cards:

intel iris display issue

When switching to the 3D window ARCHICAD can become unresponsive & can crash.

The issues are present only with Macs having Intel Iris Graphics cards. Macs with dedicated (AMD/Nvidia) Graphics cards are unaffected.

Cause

Apple has made changes to the Intel graphics driver in the 10.12.4 update that causes issues with ARCHICAD.

Workaround

All of the above issues can be circumvented with turning off the Antialiasing feature of ARCHICAD. To do so:

  • start up ARCHICAD
  • navigate to: Options » Work Enviroment » Advanced Redraw Options menu
  • turn off 2D Drawing Antialiasing & 3D OpenGL Antialiasing
  • click OK
  • Restart ARCHICAD (these changes take effect only after ARCHICAD is restarted)

If ARCHICAD crashes during the startup process and the above mentioned workaround cannot be accomplished, Antialiasing can be turned off manually by changing a preferences file on your Mac. To turn off Antialiasing in the ARCHICAD preferences file follow the steps below:

  • Navigate to: ~/Library/Preferences/com.graphisoft.AC-64 20.0.0 INT v1.plist
  • Open it in a Plist editor app like Pref Setter, PlistEdit Pro or Xcode
  • Select the OpenGL (integer) folder
  • Select the key called Antialiasing Mode.
  • Change this key to -1
  • Press cmd+S to save & cmd+Q to close the application with the change applied.

Please note restarting the computer might be necessary to apply the changes.

Solution

This issue has been resolved by Apple in the macOS 10.12.5 Update.

Related content

Typical 3D and 2D Speed Problems - Troubleshooting Guide

This Article describes how to troubleshoot 3D and 2D performance problems Too many polygons count number of polygons with PolyCounter tool (Help menu > ArchiCAD [version] Downloads) to determine polygon count find objects with too many polygons watch out for…

What is OpenGL?

OpenGL is a fast display method for 2D / 3D-like elements developed by Silicon_Graphics . It is optimized for fast interactive navigation among 3D polygons in a fancy and fast way. This makes it especially suited for professional CAD programs. More info…