Configuration

Start ARCHICAD

Double-click on the ARCHICAD icon in your program folder to start the program.
 
When you start ARCHICAD, the program automatically …

The ARCHICAD User Interface

The following sections contain information on the main features of the ARCHICAD user interface, and how to customize them.
Arranging Palettes, …

Create New Solo Project

If ARCHICAD is running:
Use File > New > New to create a new solo project (file extension .pln).
 
Note: If you press Alt …

Open a Solo Project

This information refers to opening an ARCHICAD project.
For information on working with other file formats, see Interoperability.
If ARCHICAD …

Close a Solo Project

If you use File > Close to close the Floor Plan, you close the entire Project. You will be prompted to save recent changes, if any. …

Saving from ARCHICAD

Use File > Save to save your project.
Choosing File > Save as allows you to save the Project under a new name, archive it or save the …

File Compression

When saving certain file types from ARCHICAD (.pln, .tpl, .pla, .mod), the Options button in the Save dialog box presents you with the option …

Template Files

A template is a read-only project file with extension tpl. It contains all project preferences settings, placed elements and tool default settings …

Backup Files

Opening a Backup Project file (.bpn) allows you to recover the latest backup copy of a damaged project file, provided that the Make Backup …

Archive Files

Documents saved as Archives are stored together with their Library Parts (in a Library Container File, with extension .lcf), and properties …

Troubleshooting Problem Files

If you encounter an error in a project that requires technical support, the problem can be resolved much more efficiently if the support personnel …

License Information

Use the License Information dialog box to borrow, reserve or connect to licenses need to run ARCHICAD and certain Add-Ons.
Do one of the …

Add-Ons and Goodies

Add-Ons are small applications that extend ARCHICAD’s core functionality. Many add-ons are integrated as ARCHICAD menu commands.
Goodies …

Working Units

To set working units for the current project, use the dialog box at Options > Project Preferences > Working Units.
 
Model …

Project Preferences

The Options > Project Preferences menu contains the Project Preferences tab pages where you set standards and working methods specific to …

Scale

To set the scale of the currently active model window, do one of the following:
•Use the Scale pop-up from the Quick Options Bar at the …

Attributes

ARCHICAD Attributes are groups of defined settings available to your project. For example, Line Types and Surfaces are Attributes which you can …

Libraries

 Each version of ARCHICAD is shipped with a standard object library containing hundreds of preconfigured, editable objects (also known as GDL …

Favorites

Use Favorites to save and apply tool settings configurations that you use frequently.
Favorites are saved with your project file, and can …

ARCHICAD License Types

This page explains the different types of ARCHICAD Licenses, including Demo Mode.
Commercial License
To run the commercial license of ARCHICAD …