GDL Object Editor

For a placed object: select the object, then use File > Libraries and Objects > Open Object (or choose this shortcut command from the Edit GDL Library Parts toolbar)
For any object file (and if no placed object is selected): use File > Libraries and Objects > Open Object, then browse for the desired object.
The Preview Picture window can be viewed in one of five formats.
Object’s subtype: Displays the subtype of the open object.
You can change an object’s subtype by clicking the Select Subtype button, which will open the Subtype Hierarchy dialog box. Changing the Object’s subtype modifies its behavior and adds the parameters and functionality needed for the new subtype. For example, you can change a plain object into a light source by changing its subtype to Light.
Use as subtype: If you check this box, the object will be saved as a template to be included in the list of available Subtypes. The new template will appear in the Subtype Hierarchy dialog box, and any new objects that you associate to this subtype will take on all of the parameters of the subtype.
The Placeable checkbox is enabled by default. If you uncheck it, the Object will behave as a macro. If this box is unchecked, this means that
Enter an Author. (If you leave this blank, the name you used to register on BIM Components will be used as the author, after the object is shared.)
Assign a Copyright. Three options are available here:
Commercial. Use this kind of copyright if you are selling the object over the internet. An object with Commercial copyright cannot be shared to BIM Components. Click the Info button to navigate to a webpage containing details.
Password (available if the copyright is Attribution-NoDerivs0” or “Commercial.”). Click Set Password to define an optional password. Such objects can be freely viewed and downloaded, but the user cannot open the object to edit or copy its script without a password.
Description. Enter an optional description of the object. This text will appear when you click the Info button in the Settings dialog box, as well as in BIM Components, if the object has been shared there. Also, Description text will be considered when you use the Search function for locating library parts through a library part Settings dialog box.
The Compatibility Options dialog box, accessible from the GDL Object Editor’s Details page, concerns item (instance) sizes.
Note: Doors and Windows have different controls in the Details dialog box: see next section.
Object Instance Sizes: Use these radio buttons to set how you want your placed objects (object instances) to store their parameter values.
Store the ratio of current/default A/B sizes: Placed objects will proportionally follow any changes in default A and/or B parameters.
Store fixed values: Placed objects will not change when their default A/B parameters are later changed.
Hotspot on bounding box: Check this box (if applicable) to place five hotspots at the edges of the 2D symbol of the Library Part. These are independent of hotspots defined in the part’s GDL script. These five hotspots will be located at the four corners and at the center of the symbol’s bounding box. The default hotspot used for placement of the object on your Project will be the lower left one of the five. (This is indicated by a heavy square highlighting the hotspots on the 2D symbol in the Tool Settings dialog for the Library Part, where you can change the active hotspot.)
Fit Size to 2D Drawing: Check this box to transfer the current 2D Symbol’s A and B axis dimensions into the default A and B dimension fields of the Master Window.
Derived Sizes: Use the edit fields in this section of the dialog box to define the geometric relationship between the wall opening and the Door or Window. Use numerical GDL expressions.
Nominal Frame Thickness: Specify the Nominal Frame Thickness here.
Parapet Wall Inset: Specify the Parapet Wall Inset here.
Opening Oversizing: Specify opening oversizing relative to the nominal (A and B) sizes here for Y +, Y- (at the top and bottom) and X +, X- (at the right and left).
Orientation Displaying: Use these controls to define the way the opening’s orientation is displayed (e.g., with R for right and L for left).
Default: Click this button to display Door/Window opening orientation as a standard default setting.
Reverse: Click this button to display Door/Window opening orientation in reverse as a standard default setting.
Custom: Click this button to customize the display of Door/Window opening orientation.
Switch off 3D Contours: Check this to hide the 3D contour of the selected Door/Window object (when shown in Wireframe or Hidden Line modes).
Search Parameters: Enter a text string in the search field to locate any part of that string in the Variable, Name, or Value columns. The cursor jumps to the first found instance. Use the Find next/Find previous buttons to jump to additional found instances.
The parameters that appear in blue are the obligatory parameters (such as A and B dimensions) that belong to the edited Object’s subtype.
New parameters can be created by pressing the New button at the top of the Master Window. Remove existing parameters by selecting them in the list then pressing Delete next to the New button.
The Type icons control how the values are interpreted by ARCHICAD. Clicking a Type icon displays a dialog box where you can redefine the parameter’s type by choosing another icon.
Note: If any of the Surface, Line Type, Fill Pattern or Pen Color parameter types is selected, a button appears at the right end of the parameter line where you can bring up a pop-up list of corresponding settings. Any of the attributes currently available to ARCHICAD can be chosen.
Note: Depending on how you write your GDL descriptions, the parameters you use can affect both the 2D and 3D aspects of the Library Part.
Pressing the first icon, Hide Parameter, will remove the highlighted parameter from the Parameters panel in the Object Settings dialog box.
The second icon, Subordinate, will create a hierarchy among parameters. When a parameter is ordered under another one, the subordinate parameters appear in a sublist within the parameter list of the Object Settings dialog box. The sublist can be opened and closed by pressing the small triangle next to the superior parameter. The superior parameter can be of any type; however, a Title type parameter cannot be subordinated.
Pressing the third icon, Bold, will make the parameter name appear in bold type.
The fourth, Unique icon (if activated) means that the current parameter will NOT be transferred if you transfer the rest of this object’s parameters to another object.
Note: Once array values have been defined for a parameter, the Array Values dialog box can only be opened by pressing the Set button at the top of the Master Window.
Fill in the main GUID of any old object that can be migrated to this new, currently opened object.
Fill in a version number for the old object (typically the version of a previous ARCHICAD): when the project is saved back to the previous version (and if “Convert library objects backward” is set in Options from the Save As dialog box), this new object will be migrated to an old object in the migration table which has been assigned the corresponding version number. The Backward Migration script will consider all such rows until the first successful run.
Note: if you enter 0 for the version number, backward migration will skip this object.
Click New to create a component.
DB Set: Select Database from this pop-up menu.
Key: Select one of the Keys from this pop-up menu.
Note: This pop-up menu is only available if your loaded library contains Key description.
Code: Define a Code for new Components or modify the Code of a selected one in this box.
Quantity: Define the Quantity for new Components or modify the Quantity of a selected one in this box.
Unit: Select one of the predefined Units from this pop-up menu.
Note: This pop-up menu is only available if your loaded library contains Unit description.
Proportional with: Select one of the predefined GDL expressions from this pop-up menu, or select the Custom button and enter any GDL expression in the long edit box above.
Click New to create a descriptor.
Link to Database Item: Click this button to link a Component or Descriptor to an external database residing in the selected databases of the loaded Library. While a Component or Descriptor is linked to the selected database, it cannot be edited. To modify it, click the Remove Link to Database button to unlink the Component or Descriptor.
Change Link: Click this to re-define an existing link to another external database
Text: Click this button to open the Descriptor Full Text dialog box displaying the whole Descriptor text.
Short Text: Enter Short Text for a new Descriptor in this box.
The Master Script will be executed each time any of the other scripts are executed. The primary benefit of this script is that you can globally define variables or operations, or access external data before executing other Scripts.
In the 2D Script window, you can create a parametric 2D symbol using the transformations and elements available for the two-dimensional space in GDL. This script will be used to generate the 2D Full View of the Object.
In the 3D Script window, you can find and edit the 3D description of the GDL Object. The script will be used to generate the 3D View of the Object.
With the Property Script, you can attach descriptions and technical data to the Object using its variables and the related GDL commands and expressions. Component quantities (weight, price, paint, etc.) can be calculated according to the expressions in the Properties Script and included in the lists. To use the custom Properties Script as the default in the element’s settings dialog box, click the Set as Default button at the top of the screen.
Note: When there is a Property Script defined, the listing commands will use this script, even if you previously created Components and Descriptors in the corresponding sections of the dialog box.
Using the Parameter Script, you can define the choices available as a value of a given parameter. For example, you can restrict the choice of the surface of a table top to wooden surfaces, or define the different panel styles of a given door by their name.
The Interface Script allows you to define a custom user interface for your GDL Objects, including the graphic explanation of additional parameters. If an Interface Script exists, the settings dialog box of the given library part will include a Custom Settings panel. To use the custom Interface Script as the default in the element’s settings dialog box, click the Set as Default button at the top of the screen.
Forward/Backward Migration Scripts: Click the Forward Migration or Backward Migration buttons to define how to migrate the parameters of an old instance forward to the current open element (or backward to an older element).
Note: You can select more than one line.
Note: When you are working in a Script window, all of these functions are also available as menu commands from the Edit menu, along with other special script window editing commands.
Note: The Property, Interface and Parameter Script editing windows also include a Preview button to show a preview of the custom script.
To see the fragments of the 2D Symbol, select the 2D Symbol button, then go to Options > Element Attributes > Layer settings. The appearing list window shows the fragments of the 2D Symbol: these are useful for organizing the graphic elements that compose the plan symbol of the Library Part.
Note: Fragments that are hidden are not available for storing new graphic elements. If you select a hidden Fragment in the dialog box of the Tool you are using for editing the symbol, you will get a warning asking you to change your selection or Show the selected Fragment.
3.
Go to View > 3D View Options > 3D Projection Settings. Choose a projection type and set up a view angle that show the typical features of your Object. Click OK.
4.
Go to View > 3D View Options > 3D Window Settings. Set the window’s height and width to the same value to obtain a square shaped window.
5.
Choose Document > Creative Imaging > PhotoRendering Settings. Define a pixel size that you will be able to insert in the preview without any distortion, and choose a neutral background for the Object (for example, white color for both the Sky and the Ground).
6.
With the Object still selected, choose Document > Creative Imaging > PhotoRender Projection. A Model Picture is generated.
7.
Choose Edit > Select All, then Edit > Copy.
8.
Go back to the Floor Plan. With the Object still selected, choose File > Libraries and Objects > Open Object. This will open the Master Window of the selected Object.
You can also save your item using the Save or Save as commands from any of the library item’s windows. (From the 3D View, you can only save the image using Save as.) After saving, you can choose the View > Refresh > Rebuild command for the Floor Plan or 3D window to view the modified GDL Object.
1.
Activate the 3D View of the GDL Object.
2.
Choose Top View in View > 3D View Options > 3D Projections Settings > Parallel Projections, and set the angle to 270°.
3.
Choose Edit > Select All, then Edit > Copy. Activate the GDL Object’s 2D Symbol window and choose Edit > Paste. This will place the top view of the object (as a wireframe or hidden line) into the symbol window. It should match the dimensions and position of the 2D symbol.
Choose Side View instead of Top View (the angle should still be 270°).
Note: When you place a wireframe view, redundant lines are removed. Using Hidden Lines will give you an accurate view, but underlying lines will be hidden.
  • Was this Helpful ?
  • 2   ​0