SMALL INTERFACE CHANGES

 

Apart from thematic feature developments and performance improvements, ARCHICAD 20 contains a number of fixes, UI changes and renamed controls, all aimed at improving your user experience in small but useful ways. These include the following.
New Find & Select Criteria
Building Material Name and Surface Name criteria now available in Find & Select (was previously in IES only)
OpenGL Previews in Object Settings
OpenGL previews are available in all Library-part type Settings dialog boxes.
Changes in Model Viewer Support
The Project Reviewer application is no longer included in ARCHICAD.
Instead, we recommend the professional PDF viewers available from Bluebeam (e.g. Vu and Revu).
Changed Grass Rendering Settings
Grass Rendering Option no longer uses separate antialiasing settings; a very high antialiasing quality is used by default.
Model View Options: Override Fill Display
These settings are now part of Graphic Override Rules (Document > Graphic Overrides).
Option to Show Dimension Text Only
Use this option to display the dimension text only, without any lines. This checkbox is available for linear, radial and angle dimensions, to comply with some local standards.
You can display a reference line (on-screen only) for this type of dimension as an aid in editing: turn it on at View > On-Screen View Options > Dimension Reference Lines.
Changed Options When Saving BIMx Model from ARCHICAD
In ARCHICAD 20, the Save as BIMx command is no longer available. Instead, use the File > Publish as BIMx Hyper-model command or the Save Hyper-model option from the Navigator Publisher Map.
Both workflows were available in earlier versions. However, as of AC 20, when you publish a BIMx Hyper-model (*.bimx), you now have full control within ARCHICAD over the Render mode (including GI) and background for each 3D item (view or camera path) contained in the BIMx Hyper-model.
Extra Option at BCF File Import
You can now browse for and locate IFC files referenced by a BCF file imported as a Mark-Up entry. This extra step is useful, for example, if the original composite elements were exploded at export: this way, the exploded parts will be identified as the original element.
Reorganized Menus and Commands
To make ARCHICAD’s default menu structure more logical, and to group related commands together, we have renamed and reorganized some of the menus. Some of the main changes:
The File menu has a new sub-menu called Interoperability (formerly File Special)
Interactive Schedules and other List types are now in separate sub-menus of the Document menu:
The Complex Profiles submenu is now in the Options menu (formerly Design menu).
The Merge Walls/Merge Columns/Merge Beams commands are now in the Edit > Reshape menu.
Other Interface Updates
Undo-Redo Feedback
Whenever you do an Undo or Redo, an on-screen temporary message appears to let you know that the action has been carried out.
Quick Layers Palette
Now docks like a Toolbar, taking up less space on screen.
New Parameter in Skin List Label
Thickness parameter can be turned on and off (previously was always visible.)
Feedback on Contour Lines (Composite Structures)
In the Composite Structures dialog, the first contour now indicates it’s the Outside/Top face, while the last indicates it’s the Inside/Bottom face, in reference to Walls and Slabs. Previously there was no indication which side was which.
Info Box Controls
The Info Box “Element” panel for Library Parts has been tidied up, with Empty Opening and Create/Edit stair now in the popup menu.
Scrolling Through Previews on Mac
On Mac, thumbnail views, such as in Object Settings, now smoothly scroll, no longer jumping from one row to another.
Interactive Schedule Feedback and Selection
When a preview is selected, you now have quicker access to Scale options and info on current scale (previously, Scale was available only in the menu)
Select multiple Schemes to delete them or export them all in one step
Story Settings: Edit Multiple Stories Simultaneously
Multiple Stories can now be selected in the Story Settings dialog to allow Height to Next and show/hide Story levels to be edited for multiple floors at once. Also, multiple stories can be deleted at one time without having to select each story one at a time. Especially useful during early design phases of multi-level buildings.
Tracker Settings: New Display Option
Under Work Environment, Tracker and Coordinate Input, the Tracker (and therefore Element Info Tag if using Tracker colors) can have a separate Frame color. Also the settings have been tidied up to be clearer.
Additional Tab-Opening Preferences
When you open another view/layout, Work Environment controls let you set a preference to open it in either an existing tab or a new one. Now there are two options, so you can set a separate preference for each (views and layouts): see Options > Work Environment > More Options.
On Layouts, a Drawing’s context menu includes an option to “Open source view in New Tab” (in addition to the existing “Open source view.”) This command not available for Floor Plans or 3D views.
Library Part Settings: Search and Display options
When setting Search options in Library Tool Settings, Surface Catalog and Surface Painter: each search location is an on/off control (in previous versions, options were either/or/both).
From the browser Settings pop-up, use Tree View Above or Tree View on Left to change this preference. The folder chooser is automatically hidden, and only appears when the tree view is hidden (by double clicking or dragging up the splitter) – this also applies to the Favorites palette and pop-up in Tool Settings.
  • Was this Helpful ?
  • 5   ​1