Import/Export Settings

 

Importing and exporting model data using IFC takes place according to the settings of the translator you are using. ARCHICAD provides predefined, factory-default IFC Translators, but you can define your own. IFC Translation Setup command (File > Interoperability > IFC) allows you to view or modify translator settings, or to create new translators. The following is a description of the settings found in the IFC Translation Setup dialog box:
Available Translators
By default, you will see the predefined translators (offered for structural, MEP and general connections) shipped with ARCHICAD. Any newly created translators will also be listed here. The program’s default translators for import and export are distinguished by a blue arrow symbol; these default translators will be shown when you execute the import or export commands. You can define any selected translator as the default for export and/or import by choosing the “Default for” symbol in the column marked with the blue arrow.
There are two ways to create a new translator:
“Create New” creates a new translator (by duplicating the “General” translator) with a given name and on a given place.
“Duplicate” duplicates the translator selected in the list. With “Rename”, a custom name can be set for the copied translator.
In both cases the new translator contains the same settings as the one duplicated, but you are free to change any of the settings:
Set whether the translator should be available for use with IFC model import, export, or both: choose the corresponding “Use for” symbol in the column marked with the green arrow. This way, the translator will be available in the pop-up translator list in the corresponding import (Open, Merge, etc.) dialog box and or export (e.g. Save as) dialog box.
Use the Description field to add an optional descriptive text for this translator.
Modify the translator’s Import and Export settings as needed (see below).
Note: A translator that is locked cannot be modified; the settings described below cannot be changed in this case. However, if you duplicate a locked translator, you can change its settings.
Modifications to translator settings take effect when you click Save Settings & Close. Each translator is stored in an .xml file; these files can be exchanged among ARCHICAD users, and imported into ARCHICAD projects using the “Browse” option. The “Location” field under the translator list shows the path of the selected translator’s .xml file.
If you want a customized translator to revert to its original, factory-default settings, first find the original translator file here:
\Program Files\GRAPHISOFT\ARCHICAD version\Defaults\IFC Translators folder (Windows platform), or
/Applications/GRAPHISOFT/ARCHICAD version/Defaults/IFC Translators folder (Mac platform),
then use this file to overwrite the current translator, found at the place given in the Location field.
Use Delete to remove a translator you don’t need from this list.
Import/Export Filter Options
IFC Domain
Displays the default element-type filter for the selected translator. Use the IFC Domain to filter according to the following criteria for IFC import and export: “All” will include all elements from the model; “Structural” will include only the structural building elements (IfcBuildingElement); “HVAC” will include only the mechanical elements (IfcDistributionElement). To see the exact composition of each Domain filter, click “Options”; modifying these options will create a “Custom” filter.
For example, you may create a Custom filter to export AC Zones (IfcSpace) as well as building elements, but nothing else.
Structural function
Use this as an additional (element-level) filter for export and import purposes, which will take into account the elements’ Structural Function classification at export and “LoadBearing” IFC Property at import.
The Structural Function filter has no effect on ARCHICAD Zones (IfcSpaces). In other words, Zones will be exported if they are available for the chosen exported method (Visible elements, Selected elements only or Entire project.) Thus, Zones can be exported together with Load-Bearing building elements, which can be useful, since Zones provide important input data for the structural design (e.g. for load definition).
“All elements” will not take the elements’ Structural Function classification into account.
Filtering by Structural Function works differently for IFC Import and IFC Export:
At IFC Import, the filter considers the “LoadBearing” IFC property. “Load-Bearing elements only” means that only those elements whose IFC Property “LoadBearing Element” has a “True” value will be imported from the IFC file to ARCHICAD. Although IfcPile and IfcFooting elements have no “LoadBearing” property, they are always handled as “LoadBearing True” elements by definition (by buildingSMART).
At IFC Export, the filter considers the ARCHICAD “Structural Function” classification. “Load-Bearing elements only” means that only those elements classified as “Load-Bearing Element” (plus ARCHICAD Zones) will be exported from ARCHICAD to IFC.
Notes:
If no Structural Function classification has taken place in the ARCHICAD project, or if you have not finished the classifying process in ARCHICAD, then you should choose “All Elements” here: either of the other two settings (“Load-Bearing elements only” or “Non-Load-Bearing elements only”) can result an empty IFC file, or one that is missing elements you might need.
The default Import/Export Filter Options set here can be overwritten during the export/import process using the Model Filter options.
IfcPile and IfcFooting entities are load-bearing structural elements by definition, although they have no “LoadBearing” property in the standard IFC scheme. They are always handled as load-bearing elements at both export/import.
Convert IFC Annotations and ARCHICAD 2D elements
If you check this box, the export process of the following 2D elements is allowed: Texts, Labels, Fills, Lines, Arcs, Circles, Polylines, Splines and all dimension types.
However, the inclusion of 2D elements in the exported file is also affected by the “Export” option set in the export IFC dialog boxes.
If a 3D view is currently active, the 2D elements can be included only if the “Entire project” option is used.
If a Floor Plan is active, the “Visible” option means only the visible 2D elements will be saved, and “Selected elements only” means that only the selected 2D elements will be saved.
These 2D elements will show up in the IFC scheme structure as IfcAnnotation. Dimensions will be exploded into lines and texts, since the IFC 2×3 standard documentation does not include a dimension element.
During import, all IfcAnnotation-type elements (including exploded dimension elements) of the IFC file will be imported into ARCHICAD and converted into 2D elements (texts and lines) by checking the box.
Convert Grid elements
If you check this box, the export process will include the Grid Elements and the grid members of the Grid Systems (Design) in the IFC file.
However, the inclusion of grids in the exported file is also affected by the settings of the “Export” options in the IFC export dialog boxes. Both in Floor Plan and 3D views, the “Visible” option means only the visible grids will be saved, and “Selected elements only” means that only the selected grids will be saved.
These grid elements will show up in the IFC structure as IfcGrid.
During import, all IfcGrid elements of the IFC file will be imported into ARCHICAD and converted into grouped ARCHICAD Grid Elements by checking the box.
Convert 2D symbols of Doors and Windows
If you check this box, the export process will include the 2D symbols of doors and windows besides their 3D model geometry. This is handy provided that the recipient program recognizes these data and can correctly display, for example, the door opening directions.
During import, all generated doors and windows will be displayed with correct opening direction and sizes in floor plan views based on their imported 2D symbols.
Import Options
For import, the following options are editable:
Show Model Filter on import
If this option is active, then – after you issue an import command – the Model Filter window will open.
This gives you the chance to overwrite, for the purposes of the current import process, the “Import/Export Filter Options” settings of the translator you are using, to fine-tune the elements to be imported (e.g. import only certain element types, or just the elements from a certain story).
Geometry Conversion
Use Conversion Options to define the geometry creation method (and concurrently the type of the ARCHICAD element being created) for the following IFC element types:
Building Elements: IFC elements whose supertype is IfcBuilding (IfcWall, IfcColumn, IfcBeam, etc.) can be imported as editable ARCHICAD elements (“Construction elements”: Wall, Column, Beam, etc.), or as Morphs or as Objects. Of course, even if you choose the “Construction element” option, not all elements can be imported in this form (such as non-extruded (BREP geometry) elements, or those elements having no counterpart in ARCHICAD): for such elements, you can choose to convert them as either an editable Morph or an Object (“otherwise Objects/otherwise Morphs”). The advantage of converting the imported elements to AC tool-based construction elements is that they remain parametric, and ARCHICAD functions (such as automatic intersections) will apply to them. By choosing to convert elements to Morphs or Objects, you will guarantee perfect geometry import. The resulting Morphs will be editable, while the resulting Objects will be Library Parts, whose subtype will match the IFC entity type: for example, an IfcColumn converted to an ARCHICAD Object will have the subtype “Column”.
Distribution elements: When importing elements whose domain is MEP (IfcDistributionElement), you have three options: generate an object, or generate an editable Morph (as described above); or, if GRAPHISOFT MEP Modeler Add-On has been installed, then you can generate parametric MEP elements. Even if you choose this latter option, however, the MEP IFC model might not contain sufficient data to generate the parameters, in which case non-parametric MEP Equipment elements will be generated, or – in case of limited data – Objects will be generated.
Other elements: Elements that are neither building elements nor distribution elements (such as furnishing and transportation elements) can be converted to editable Morphs, or to Objects.
IFC Site geometry: Check this box if you want to include the geometry of the imported IfcSite. (The option to include or exclude this geometry is available only here, and cannot be set in the Model Filter dialog box.) If you opt to include the IFC Site geometry, then you can further decide whether the converted element should be an editable Morph or an Object. (IfcSite geometry cannot be converted to an ARCHICAD Mesh.)
Notes:
To optimize the management of shared geometry, ARCHICAD creates as few geometric elements (when generating Morphs) or as few Library Parts (when generating Objects) as possible.
Objects can be placed in the project’s Embedded Library, or else saved to a given linked library (see IFC Options).
Some IFC models may contain elements with special geometry which cannot be converted to Morphs, even if you choose the Morph conversion option. In this case, ARCHICAD will generate Objects, to achieve perfect geometry import.
Imported IfcSpace elements will always be generated as ARCHICAD Zones, which will always retain the imported elements’ original geometry.
After importing MEP elements to an MEP Modeler environment, you can use the Collision Detection function (see Collision Detection).
Layer Conversion
Define the method for placing the imported elements onto ARCHICAD layers.
“Keep original layers” means that ARCHICAD will create new layers that correspond to the original layer names (IfcPresentationLayerAssignment) of the IFC model, and will place the imported elements onto these layers.
“Keep original layers and add extension”: This will create new ARCHICAD layers corresponding to the original layers of the IFC model, but will add a custom extension (such as “Structural Model”) to each of these layer names. The advantage is that, following the file import, you will be able to sort the layers by extension in ARCHICAD’s Layer Settings dialog box.
“Place elements on one layer”: This means that the imported elements will be placed onto a newly created, single layer that you define (such as the “IFC Import” layer). In this case, the import will delete the original layer names of the IFC model.
Notes:
The import process automatically sets an intersection group number for all imported layers, and this number will be different from the current project layers’ intersection group number. This difference ensures that the elements on the imported layers will not intersect with the existing project elements.
If the elements have been converted to their counterpart ARCHICAD tool-based construction elements (that is, they have not been converted to Objects or Morphs; see Geometry Conversion above), then elements on identical layers might have their geometries modified due to automatic intersections. If you want to avoid this, set the intersection group number to 0.
If layers of the same name already exist in ARCHICAD, no new layers are created; the imported elements are placed onto the corresponding, existing ARCHICAD layers.
If the import involves element whose geometries are generated by Solid Element Operations, then the operator elements are placed on the “IFC Openings” layer, which is hidden. If you will move any of the target elements, make sure to show the operator elements’ layer and move them together, to avoid modifying the original geometry of the imported elements.
Material and Surface Conversion
Choose one of two methods for importing IFC Materials and defining the representation styles of the imported IFC model elements. Both import methods also affect the ARCHICAD project’s attributes.
Note: For IFC elements, color is assigned in one of two ways: to its material or to its geometry. Color assigned to material is handled by the “Material import method for IFC Materials” option and by the material mapping rules; color assigned to geometry is handled by the “Generate Surface Attributes from IFC geometry Surface overrides” option.
Method 1: Create attributes from IFC Materials:
This method imports the materials and their colors (if any) assigned to IFC model elements. It will create new Building Material attributes, named according to the imported IFC Material names. In addition, Surface attributes are created out of any colors assigned to the imported IFC Materials. This method ensures that specific materials (e.g. “C20” concrete quality) used by the structural engineer in the structural model will be imported, displayed and (as needed) listed. The newly created Building Materials will use only data defined in the IFC model (name and/or color), while all other Building Material parameters (Cut Fill type and orientation, pen settings, Intersection Priority, Categories and Properties data) can be defined via mapping rules (see later). In other words, with this method, new attributes are created by duplicating a selected Building Material under a new name and (if the IFC Material had an assigned color) by adding a new Surface attribute. Of course, if your project already contains a Building Material that corresponds in name and color to the imported IFC Material, then no new Building Material attribute will be created.
Method 2: Override with Building Materials
Elements will be imported and displayed according to defined mapping rules between IFC Materials and Building Materials, which specify a Building Material and an associated Surface. With this method, no new attributes are created, and the imported IFC Material’s name and representation styles (if any) are not preserved. This override workflow is recommended if the goal is to display imported elements using your own defined style (rather than the style used to create the IFC model). For example: use the “Steel” Building Material (with a red Surface attribute) to display all steel quality IFC Materials, and use the “Concrete” Building Material (with a blue Surface attribute) to display all concrete quality IFC Materials.
Use Material Mapping: Check the Use material mapping box to assign a mapping rule to either of these import methods.
For Method 1, define the Building Materials which will be duplicated to create the new attributes.
For Method 2, define the Building Materials that will be overridden. The mapping table is defined at the “Material Mapping” dialog box: IFC Materials are paired with Building Materials available in your project.
Example: You can assign ARCHICAD’s “Concrete Structural” Building Material to all concrete materials entitled “C20” that are imported from a structural IFC model:
With Method 1: ARCHICAD will create a new Building Material attribute named “C20” (if it doesn’t already exist), but the new attribute will use the Cut Fill and Pen settings of the existing “Concrete Structural” Building Material.
With Method 2: ARCHICAD will discard the “C20”IFC Material, and the IFC elements that used that material will henceforth use the “Concrete Structural” Building Material with all of its display parameters.
You can fill out the IFC Material column of the mapping table by hand, if you know the names of the incoming IFC Materials (use the “New” command). Alternatively, you can import this data from the IFC model (use the “Merge from IFC” command). In this case, you will be prompted to open the IFC file, and once it is opened, the mapping list will contain all the IFC Material names that were not yet filled out in the column. Use the list under “ARCHICAD Building Material” to pair them. Any IFC Material that has not been paired with an ARCHICAD Building Material will be marked with an exclamation point in the second column. Similarly, if it has been paired with a Building Material that is not currently available in the project, it will be marked with an exclamation point.
Hints:
Some of the default translators include predefined mapping rules, whose settings you are free to expand or edit. It is recommended to duplicate the default translator before modifying it.
Use the “Merge from IFC” function to fill in the mapping tables of the translators; this function will automatically fill in IFC Material names that are not yet in the tables. After you complete the mapping table and save the translator, the data will be available the next time you import a similar IFC model (e.g. from the same contractor using the same program), and you will only need to fill out a few additional IFC Material names, if any.
You cannot import or export these mapping tables as separate files (e.g. xml); you must import/export them together with entire translator file itself (use “Browse” to import).
If the “Use material mapping” option is inactive, then only the “Building Material for non-mapped materials” setting will take effect:
With Method 1: the new Building Material attributes will be created by duplicating the single Building Material defined here
With Method 2: All imported IFC elements will be assigned the single Building Material defined here, and all elements will be displayed in a uniform style (e.g. with a single color)
The settings described above control the materials and the colors (Surface) assigned to the materials. As noted, the IFC element geometries in IFC models can also have an assigned color. If an element has both types of color assignments, then the geometry color is of higher priority. These colors can be managed with the “Generate Surface Attributes from IFC geometry Surface overrides” control:
If the option is on, then ARCHICAD will create Surface attributes using the color assigned to the IFC element geometry. These attributes will override the existing settings as follows:
With Method 1: The geometry color will override the IFC Material’s assigned color
With Method 2: The geometry color will override the Surface of the Building Material being used
To check and modify the resulting surface overrides in ARCHICAD, view the Model panel of the respective Element Settings dialog box.
Renovation Status Conversion
Choose a Renovation Status in ARCHICAD for imported elements that do not have an assigned renovation status.
Notes:
Nearly every model exchange scenario will lack automatic mapping of renovation status. The reason is that the IFC 2×3 standard has no standard format for renovation status, and so the various applications will export this data only as custom IFC properties.
In model exchange with Revit, the ARCHICAD “Renovation Status” item is mapped to Revit’s “Phasing” item, provided that the IFC export and import on the Revit side is carried out using the GRAPHISOFT ARCHICAD Connection Add-In
(http://www.graphisoft.com/support/archicad/downloads/interoperability.)
Export Options
For export, the following options are editable (provided that the translator is not locked).
Elements to export
Use the element filter for export to configure the current translator.
See Step 3 at Export Functions.
This value determines the default filter used by the export process, but you can still change the filter in the export dialog.
Note: If there are selected elements in the project when you start the export, this control automatically changes to “Selected elements only”, regardless of the translator’s default setting.
IFC Scheme and Model View Definition
Choose whether you want to save the IFC model according to a version of the widely used so-called “Coordination view” IFC 2×3 standard, or another (IFC 2×3 or IFC4) Model View Definition (MVD). If the predefined list does not contain the desired Model View Definition, choose “Custom”, and enter the header info required by the MVD in the “Name of custom extended view” field.
Note: Depending on the MVD you choose, some of the following “Geometry representation” and “Derived model data to export” will not be modifiable. For example, if you are using “Coordination View (Surface Geometry)”, the geometry representation of every element is required to be BREP. Another example: the “Concept Design BIM 2010” MVD requires the export of IFC Type Product element geometries, while the “Coordination View” does not allow this.
Properties to export
Use this option to define which property set (IFC Property and Classification Reference) to use when saving the model: either all IFC properties available in the IFC Manager, or just the IFC properties coming from the current IFC Scheme Setup (seen with the “Show only Scheme items” display mode in IFC Manager). Thus, for example, if only the COBie.xml scheme is active in the IFC Scheme Setup dialog box, then if you choose “Current Scheme properties only”, only data defined as part of the COBie scheme will be saved.
Geometry conversion:
Use BREP geometry in current color for all elements: If you would like to export all model elements with their precise but non-parametric geometry (i.e. boundary representation), activate this option. This option also sets BREP geometry representation for all complex elements, elements in Solid Element Operations, elements in junctions, etc. (see later). This option also ensures that element bodies will be exported in color displayed in the current exporter view, so body colors defined by Criteria-based Visualization (link), Renovation Status (link), Revision Status (link) and Mark-Up Style (Correction or Highlight color) can be shared with other consultants/applications via IFC exports.
Triangulate surfaces of BREPs (available only in IFC4 standard code): With this option, the BREP geometry is saved as triangulated surfaces – an option preferred by some model visualization applications when importing IFC files. This option produces a compact geometrical description, which might reduce file size.
Explode Composite and Complex Profile elements into parts: This will save composite elements (e.g. Slab or Wall) and Complex Profiles (e.g. Column, Wall, Beam) as so-called “Building Element Parts”. This means that the main element (e.g. IfcWall) will be saved as a container element without geometry, and its parts (the skins or profile components) will provide the geometry. Use this option to ensure the correct export of the individual colors assigned to the Building Materials of each component. This export option retains the original colors of all building parts, instead of exporting them in all one color.
Export geometries that “Participates in Collision Detection” only: For each Building Material, you can define whether it should participate in participate in collision detection or not (Options > Element Attributes > Building Materials > Categories and Properties). With this export option, you can export composite elements/complex profiles that don’t have solid geometries as real air gaps. This way, for example, MEP engineers (who receive the ARCHICAD IFC file) can place pipes in the gaps without collision detection, and only those element parts having real geometry will participate in collision detection in model-checkers and in GRAPHISOFT MEP Modeler.
Multi-skin complex geometries: This option will affect multi-skin (Composite or Complex Profile) ARCHICAD elements having complex (e.g. slanted) geometry representation.
Building element parts: An element (e.g. Wall) is logically made into an IFC element (e.g. IfcWall) that includes building element parts. The advantage of this option is that each building element is assigned the IFC material or profile that is represented by its Building Material (Cut Fill) in ARCHICAD.
Complex profiles: An element is logically made into an IFC element, to which a profile geometry or material list will be assigned, in the form of an IFC material. (The receiving application will not know the precise order of the different components/skins.)
Note: This option is affected by the “Partial Structure Display” (Document menu) currently in effect, if the view’s visible elements are being exported. For example, if the “Core Only” Partial Structure Display is in effect, then the “Complex profiles” option will have no effect on a slanted composite wall that has a single core, because in this case the wall will not count as a composite element.
Elements in Solid Element Operations
With the extruded/revolved geometry method, elements edited with Solid Element Operations will be exported according to their definition geometry – for example, without any automatically added intersections. With the BREP method, they will be exported as they are displayed in ARCHICAD because of Solid Element Operations.
Extruded/revolved: This is the standard IFC geometry representation, which retains the elements’ parameter values (such as thickness, height, location of reference line or edge, skin structure of composite materials) – however, certain specialized sections are not retained. This is the format usually supported by static analysis programs, because while it is important to retain and possibly to modify the elements’ parameters, their special cut angles (such as the slanted edge of a slab) are not important.
BREP: This method comes closest to reproducing the shape of the element, together with its specialized sections and connections. However, the element’s parameters are lost, and BREP (Boundary Representation) elements from an imported IFC file are transformed into non-editable elements. Since this method provides the most exact reproduction of element geometry, it is useful in the “reference model” workflow.
Elements with junctions:
Choose whether to export the elements as either extruded/revolved geometry or with BREP.
If you prefer the extruded/revolved geometry, you can export the elements without junctions – that is, without the priority-based intersections. In this case, the export process is faster. This option is recommended for structural analysis programs, for which the elements’ reference lines/surface information is sufficient, and detailed intersections are not required.
The difference between BREP and extruded/revolved geometry representations is illustrated here:
Slabs with slanted edge(s): With the extruded method, slabs will be exported with vertical edges, even though their original geometry included a slanted edge. With the BREP method, such slabs will be exported using their correct original geometric representation.
Use legacy geometric methods as in Coordination View 1.0: Use this option if you have created your own, custom MVD that is based on the geometry methods of Coordination View version 1.0.
IFC Site geometry: In ARCHICAD, the IfcSite geometry can be created with Mesh elements, with Objects with subtype “Ifc2x_Site” and any modeling element (e.g. Slab, Morph) classified (Element Classification) as “Site Geometry”. Depending on whether these elements are visible/selected in the view from which you begin the export, and depending on your choices at “Export” options, these elements will be exported. Use the drop-down list to apply a geometric representation to these elements in the IFC model.
Make your choice depending on which kind of site geometry your partner’s application is able to read:
BREP: Geometric representation as solid bodies enclosed by their superficies and boundary surfaces. BREP is a simple form of boundary representation model in which all faces are planar and all edges are straight lines.
Face-based surface (top surface): Geometric representation of the superficies (top surface) only.
Geometric set (wireframe): Geometric representation with contours and points.
Note: ARCHICAD is able to import all three kinds of IFC site geometry representations.
IFC Site location (if Survey Point is available): It is recommended to use a common anchor/reference point to facilitate coordination of models from different programs (e.g. when connecting models submitted by different professionals). In some countries, use of a particular reference point (national datum) is a standard requirement when defining the project. To define this reference point, use the Survey Point object in ARCHICAD.
The position and rotation of the Survey Point defines the global coordinate system (X=0, Y=0, Z=0) of the IFC model. When defining this point position, it is recommended to consider the True North direction (use the default “Follow Project North” parameter). At IFC export, this parameter defines the direction of the Y axis in the global coordinate system.
Notes:
In ARCHICAD, True North is defined by Project North (Options > Project Preferences > Project Location)
The Survey Point is always created at IFC Open. In case of Merge IFC, the model is imported to be aligned to the host file’s Survey Point.
Use this translator option to define the location of the IFC Site entity (i.e. its coordinate system) at export.
At Project Origin: The IFC Site entity is located at the Project Origin. Use this option if you are working close to the ARCHICAD Project Origin, yet still wish to define model coordinates relative to a national datum (using the Survey Point). This way, a far offset is stored in the IFC file not as part of the element coordinates but rather generally. See the following illustration:
At Survey Point position: The IFC Site entity is located at the position of the Survey Point. Use this if you are working at a long distance from the Project Origin, yet you don’t want large offsets to be present in the IFC file (usually with legacy models). See the following illustration:
Notes:
If the project does not contain a Survey Point, then the IFC model’s global coordinate system origin will be the ARCHICAD Project Origin. The IFC Site location will either be at the Project Origin too, or – in case of long distances (approximately one-kilometer coordinates) – at the Center of Weight of Model calculated by the program. Use this option if your earlier models contain elements at long distances (legacy issue). With new projects, the Survey Point option is recommended.
If the project contains multiple Survey Points (though it is recommended to use just one), then the first placed Survey Point will be used. (A warning will alert you to this.)
The program will consider the Survey Point even if it is not visible in the exported view (i.e. if it is on a hidden layer)! Hiding the Survey Point is a good idea anyway, when long distances are involved.
Building Information data to export
The following options enable you to export additional data in addition to the elements, which can be useful for data exchange with facility management, energy analysis or cost estimation programs:
Properties and Quantities
Element Properties: This option exports all ARCHICAD Properties assigned to model elements and Zones (defined by Property Manager (Options menu)) as same name IFC Properties and grouped in property sets having the name of the container Property Groups.
Element Parameters: This option exports all or only the property-type (“IFC Properties only” option) or only the quantity-type (“IFC Quantities only” option) ARCHICAD Parameters (including Library Part and Schedule Parameters). The exported IFC Properties will keep their source Parameter name and be grouped in Property Sets having the name “ARCHICAD Properties” or “(LibraryPartName) Properties”; and the exported IFC Quantities will keep their source Parameter name and be grouped in Property Sets having the name “ARCHICAD Quantities” or “(LibraryPartName) Quantities”. This option can be useful when exchanging data with programs that can read such data. For example, quantity takeoffs can read quantities; a model viewer/checker can read both properties and quantities.
Note: Choosing this option will significantly increase the IFC file size. Thus, use it only if you know that the target application can read these data.
IFC Base Quantities: (size, area and volume): Check this box to add Quantity Takeoff parameters to Wall (IfcWall), Column (IfcColumn), Beam (IfcBeam), Slab (IfcSlab, predefined type Floor), Roof (IfcSlab, predefined type Roof) and Zone (IfcSlab) elements to the IFC model. This data is useful in the interoperability with cost estimation applications.
For example, the following quantities (IfcElementQuantity) can be exported together with IfcWall element: Length; Height; Gross Volume; Net Volume (volume reduced e.g. by columns embedded into the wall); Gross Footprint Area (doors are not considered); Net Footprint Area (area reduced by door footings); Gross Side Area (openings are not considered); Net Side Area (area reduced by openings).
The following table summarizes the base quantities by entity types automatically calculated and exported when using this derived data export option. The values of IfcSite’s base quantities can be set manually at Info > Project Info (Site Gross Perimeter and Site Gross Area).
Window/Door Lining and Panel Parameters: Check this option if you want to export the entities listed as IfcWindowStyle and IfcDoorStyle on the IFC Manager’s “Type Products”
Zone Data
IFC Space Containment: Space containment defines the relationship between ARCHICAD Zones (IfcSpaces) and Furnishing, Mechanical (HVAC) and other contained elements defined by Object, Lamp and Morph tools within the space. Check this box if you would like to send the model to a facility management application.
Note: Object, Lamp and Morph elements will be in space containment only if the center of these elements’ bounding box falls within the ARCHICAD Zone.
Hints:
Space Containment content can be verified in IFC Manager, by viewing the contents of the containment tree in “Space Containment” mode (See IFC Options).
To export an element as Space Containment that was created with a different tool (e.g. a Ceiling element drawn with the Slab tool), you can use the following workaround: change the element into a Morph, because the space relation definition will apply to it. (See IFC Options)
IFC Space Boundaries: ARCHICAD Zones include precise geometry data that are useful to thermal calculation software applications. Zones are 3D solids in geometrical aspect and in normal cases are bordered by two slabs and four walls. Space boundaries define the logical connection between ARCHICAD Zones (IfcSpace) and the building elements that enclose them. In practice, Walls, Slabs, Roofs, Windows, Doors etc. all have different thermal conductivity properties. If you activate the “IFC Space boundaries” option, ARCHICAD will export Space boundaries and their relations (IfcRelSpaceBoundary) together with the Zones (IfcSpace) to the IFC file. In other words, ARCHICAD will calculate the position, size and adjacency of the elements that border each Zone. ARCHICAD divides the Zone boundaries according to the areas defined and cut by connected elements and openings.
Zone Categories as IFC Space Classification Reference: Check this box to export the Zone Categories data (Code and Name) of ARCHICAD Zones as their (IfcSpace) IFC Classification Reference data (ItemReference and Name).
Geometric Data
Bounding Box: Check this box if you would like to export the dimensions of the building elements’ bounding box.
Geometry of IFC Type Products: Use this to save the geometry of the various IFC Type Product elements. Each type (e.g. IfcFurnishingElementType) will use a representative geometry of the elements that belong to it (e.g. IfcFurnishingElement).
IFC model units
Set the unit type globally for the export of all coordinates, geometric parameters and “…Measure”-type IFC Properties (see Custom Data).
Note: When doing an import, the imported elements and data are always displayed using ARCHICAD’s model unit preference (Options > Project Preferences).
IFC Global Unique Identifier attribute (GlobalId)
The “Keep ARCHICAD IFC ID” option means that IFC GlobalId Attributes of elements assigned automatically by ARCHICAD will be kept in the exported IFC model. The “Keep ARCHICAD IFC ID” option is useful when using other programs to compare two IFC model versions arriving from ARCHICAD. The alternative option is “Generate new”. Each new exported IFC file will generate brand new GlobalIds for the elements, so that each new exported version is entirely separate from the previous versions.
Note: The IFC Global Unique Identifier attribute (GlobalId) settings option has no effect on the Merge to IFC Model export process.
  • Was this Helpful ?
  • 5   ​1