Typical 3D and 2D Speed Problems – Troubleshooting Guide

by Greg Kmethy, Katalin Borszéki and GRAPHISOFT · updated: 02.07.2011

3D Summary of Typical problems

Too many polygons

  • count number of polygons with PolyCounter tool (Help menu > ArchiCAD [version] Downloads) to determine polygon count
  • find objects with too many polygons
  • watch out for objects coming from 3DS, C4D formats, and curved objects
  • watch out for element details (door knobs and the like)
  • scale-dependent objects – use right scale!detail level
  • turn off unnecessary layers – use layer combinations
  • Rendering tricks (like using background images)

Element Interactions

  • Find Solid Element Operations
  • Problem objects: meshes
  • Problem objects: Zones
  • Find duplicates
  • interactions between hidden and visible layers
  • registry keys to control SEO

Shadow casting

  • 3D window settings
  • curved elements
  • trees
  • huge polygons (“infinite” slab or mesh)

ArchiCAD 3D redraw slow

There is a new feature since AC14: Per pixel shading. It makes shading of surfaces (especially curved surfaces) much better, but the speed of refreshing 3D might be slower when panning, zooming or rotating a large model.
registrykeysnew--enableshaders

There is a registry key where one can turn off this function and 3D navigation will be faster and better:

  • Windows

Type regedit into the search field of Start menu (Vista/Win7) or into the command prompt window.
Find HKEY_CURRENT_USER/Software/GRAPHISOFT/ArchiCAD(or)ArchiCAD-64/<ArchiCAD version>/OpenGL folder and change the “Enable Shaders” value to 0, then close the perspective/axonometric window and open any 3D window again (rebuild is not enough).

  • MAC

On Mac, first you have to download PrefSetter.
Open Users/<username>/Library/Preferences/com.graphisoft.<AC version>.plist file, find OpenGL folder and change the “Enable Shaders” value to 0, then close the perspective/axonometric window and open any 3D window again (rebuild is not enough).


Polygon Count

The most typical reason for poor 3D performance is the large number of polygons in the 3D model. Note however, that it is not the only contributing factor. As a rule of thumb, a model is “large” when polygon count reaches 1 million, and the performance problems turn severe in the 3-4 million region.

How to check model size

The easiest way to check model size is to use the Polygon counting tool, which you can download from the “ArchiCAD Downloads” site (“ArchiCAD Goodies” in earlier versions), available from ArchiCAD’s help menu. The PolyCount palette will list ArchiCAD elements by type, and displays the number of polygons each element type represents in the project. Library parts are listed by object type – you will many times find that library parts make up for 80-90% of the project

Reducing model size

First of all, make sure that only elements that you really need are displayed in the 3D view:

  • Make sure you turn off unnecessary layers, e.g. layers of elements that you do not even see in 3D – e.g. interior walls and furniture, site improvements, etc… Save a Layer combination that you use for working in 3D
  • Use the Filter elements in 3D feature (It’s in View menu/Elements in 3D view) to turn off element types you do no really need – You might not always need Lamps, Curtain Walls, sometimes not even doors and windows when working in 3D. You can also set here which stories you want to see – you might not need all of them all the time.
  • Use the Marquee tool or the 3D Cutting Planes to show only a part of your model.
  • Some objects have different 3D detail level settings. You can temporarily set this to “Simple” instead of “Detailed” when working in 3D. (Note that you can set the detail level in the the PolyCount palette of the Polygon Counting tool) Similarly, curved objects typically have a “resolution” parameter. You can set it as low as possible without having a major effect on what you see in 3D. Also, some elements have extra fittings that you might also turn off temporarily – e.g. the door handles, stair railings, etc…
  • Curtain walls have a Model View Option for “Full” or “Schematic”
  • The resolution of elements that had been created with the Magic Wand tool can be controlled by the Magic Wand settings (prior creation). Make sure large slabs, meshes, etc… are not over-detailed.

Problem elements

Element types that most typically contribute to large number of polygons:

  • Trees and plants – consider that each leaf is an individual polygon – and if shadow casting is on, then leafs cast shadow on each other, creating a vast amount of shadow polygons. Instead of using trees, you might consider using the “Tree Bitmap” object, which is a single polygon with an image applied as a texture. You can even use your own images to customize this object. (See details in TechNotes/How to put custom images to default bitmap people) Using Alpha Channel, you can achieve proper shadow casting with this object. You can also use other tricks to reduce model size, like Link Ellis‘s rendering tip: TechNotes/Speed up Rendering
  • objects from other applications – e.g. objects imported from Cinema4D or 3DStudio, which were modeled in a completely different scale and are over-detailed compared to their significance in the ArchiCAD model. A boat or a car that was modeled to display all the fine details of the vehicle might just be too much to include in your ArchiCAD model.
  • Meshes – If the mesh was created based on survey data with a fine scale, it might prove over-detailed in ArchiCAD. Consider what detail do you really need for the mesh.
  • Curtain walls – curtain walls are complex, and can be overcomplicated with custom frames, junctions and accessories. You always have the option to display them in “Schematic” mode when you don’t need all the details.
  • Elements with Complex Profile – If the profile is complex, it will increase the overall polygon of the wall, beam or column it is applied to.
  • Accessories – again, watch out for the fine details. If you only need the details for 3D visualization, you might consider applying a custom material with a photo image of the details as texture on the wall/slab/roof instead of actually modeling all the details.

Polygon count of certain element types

Wall without opening 6
Wall with empty opening 10
D1 Door 80
D1 Door with handle (Style 1) 1544
Office Chair 01 (Simple) 2594
Office Chair 01 (Detailed, Resolution=8) 3759
Office Chair 01 (Detailed, Resolution=16) 7433
Tree Deciduous 01 3894
Tree bitmap 1
Man Hands in Pocket 6396
People Bitmap 1 1
Car 01 5583
Vehicle Bitmap 1
Straight StairMaker stair with “Post with Baluster” railing 2093
Straight StairMaker stair with “Simple Surface” railing 789

Element interactions

It may happen that even though the polygon count of your model is not high, it still takes an unusually long time to display it in 3D. In this case there are probably element interactions that take long to calculate. First determine if the problem is caused by GDL elements or other ArchiCAD building elements. Using the Filter elements in 3D command turn off doors, windows, objects, lamps and curtain walls to determine if they cause the slowness or not. If they do, try to determine which cause the problem by turning off/deleting them type by type.

If your project is still slow even without GDL objects, then try unchecking the Enhanced connections for Walls and Beams option in the Options/Project Preferences/Construction Elements settings. This might change how your model look, e.g. if you have connecting walls with different height. If you only have equal height walls, then turning off this setting may boost the 3D performance.

If none of the above helps, you most likely have a problem with Solid Element Operations. Solid element operations are either created automatically (when slabs cut walls, columns cut beams, etc…) or by the user, using the Solid Element Operations… command. They create links between elements that need to be calculated when the 3D model is generated or changed. Solid Element Operations may slow down the project if:

  • they are present in large number (thousands of elements are involved)
  • one or more of the involved elements are very complex (such as meshes, large complex profile walls)
  • the result of the solid operation creates a degenerated (geometrically not sound) body.

To find which elements cause the problem, follow these steps:

  • Make a copy of the file, so you have an original copy and an other copy that you can experiment with
  • Use the Filter elements in 3D function to turn off element types one by one. This will help you determine which type of elements causes the problem
  • If you found the “bad” element type, hide all other element type, and check if 3D rebuild is still slow. You might find that e.g. if you show slabs only, that’s fast, if you show walls only, that’s also fast, but if you show slabs AND walls, then the model rebuilds slowly. This indicates that there is a Solid Element Operation between some slabs and walls that cause the problem
  • Once you have determined the unsound element type(s), first check if there is any repetitive model component that are present in large numbers (e.g. fine details of stairs, railings, furniture or accessories modeled with small walls, slabs or beams. Such components should be saved as library objects)
  • Then check if you have any elements with unusual size or shape. Try deleting these to determine if they are the culprit.
  • Also look for any element with a complex profile. You can use the Find and Select tool to find such element, as it has a criteria for “Complex Profile”

Once you have found the problem elements, try canceling solid operations on them:

  • Open the Solid Element Operations palette,
  • Select he element(s),
  • Use the “Cancel Operations of Selected Elements on…” options – press all three buttons: All targets; All Operators; All other Selected Elements

If you have found the problem element, and you also made sure that canceling the solid operation fixes the problem, try re-create the element and try re-establish the solid operation. This may fix the problem. If it does not, you have one last option to try fix the problem:


Date settings

When the date of the computer is not equal to the current date but set to a former one some operations can be slow. For example placing doors or windows. This issue occurs on MACs only.

2D Summary of Typical problems

Density

  • Using edit selection set to count lines
  • 2D objects from AutoCAD
  • trees, foliage
  • details in different scale (BIM does not mean drawing in 1:1 detail)
  • use bitmap fills in model view
  • number of groups
  • shadows turned on

Parametric objects

  • doors and windows typically draw slower
  • zones interact with walls
  • complex profiles
  • symbolic vs. projected views
  • “Requests” in objects – e.g. door marker that reports which room it belongs to

Feedback problems

  • DirectX problems
  • Trace reference on/off
  • viewpoint or view as Trace reference?
  • try switching off palettes (navigator, navigator preview, info box)
  • “Model Display in 2D Navigation” WorkEnvironment setting

Phenomena

“slow 2D” usually means either of these two phenomena:

  • Rebuild is slow. Rebuild occurs every time after you pan or zoom, or when you use the rebuild command from the View/Refresh menu.
  • Feedback is slow. By feedback we mean all the temporary visual items that appear during the process of element editing, e.g. the ghost elements that follow the cursor when you drag something, or the rubberband that follows your cursor while drawing a wall.

It is important to differentiate between rebuild and feedback related performance problems, since they usually have a different cause.

  • feedback.pngtypical feedback problem: rubber band not following the cursor

Functionalities and components affecting 2D performance

General ArchiCAD elements

The more elements you have, the longer it takes to draw them on screen. ArchiCAD optimizes what elements need to be refreshed after a change in the drawing, so editing elements is not typically slower in a large file than in a small file. Also, if you are zoomed in into a large floor plan, ArchiCAD will ignore rebuilding the elements that are outside the display area, so panning and zooming will be instant.However, if you zoom out, and more elements are displayed, then the rebuild time after panning and zooming will increase, since more and more elements are on your screen. This behavior is normal.

During panning, while you keep the mouse button pressed and drag the screen, the ArchiCAD elements follow your cursor. The level of this feedback can be controlled by a WorkEnvironment setting called Model Display in 2D Navigation.
This setting is under Options/Work Environment/Advanced Redraw Options and its possible values are: Structural Contours Only, Simplified Model and Full Model. In Full Model mode you see every ArchiCAD element during panning and Zooming, the other options filter the elements being displayed during navigation, thus giving a better refresh rate.

navioptions.png

Vectorial fills

Vectorial fills are scale-dependent, which means that they need to be recalculated if the zoom level changes. Depending on the zoom level and the pattern and the size of the fill, this could mean hundreds of thousands of lines that have to be calculated and drawn on screen. For optimizing redraw speed, if the density of the pattern reaches a certain level (when you can’t tell apart the different lines in the fill), ArchiCAD substitutes the pattern with a solid fill. However, to further increase 2D speed during drafting, ArchiCAD can substitute vectorial fills with scale-independent bitmap fills. Go to View menu/On-Screen View options and deselect theVectorial Hatching option. The appearance of the fills will change on screen, but this option will not affect the output – the fills will print with the correct scale.

GDL elements

Smart objects intelligently react to their environment. E.g. a window cuts a correct size hole in the wall, and a room stamp displays the exact area of the room. To keep these element up-to date, their script has to be run again if something that may affect their behavior is changed. This background calculation adds to rebuild times. Needless to say, not all GDL elements are recalculated after each change to the drawing, but the first opening of a view that contains many GDL objects could be relatively “slow”. To optimize speed, you can set the object’s 2D detail level to low while drafting.

Trace and Reference

See also: Trace Reference Causes ArchiCAD to Slow

It might, or might not be obvious that using a Trace Reference adds some extra time to the rebuild time of the active window, as there are more elements displayed on the screen. During rebuild (after panning/zooming), the content of the Trace Reference is also refreshed. If the Trace Reference is a section or an elevation, then the 3D model also needs to be partially rebuilt so that the changes propagate to the appropriate views. This step (partial rebuild of the model) can be considerably slower than rebuilding a view with only 2D content. As a result, the overall rebuild time of the active window if a Trace Reference is used can be significantly slower than without the Trace Reference.

You can disable automatic refreshing of the Trace Reference either with:

updateoff.png

*Note that this setting has an effect on the behavior of all of the sections/elevations in the project. When working in these views, you will need to manually rebuild them after you have edited elements, otherwise elements will temporarily not show properly after editing. (e.g. you move a wall, and the intersection with other walls will not clean up until you hit rebuild)

Special Snap Points Setting

It might happen that your plan has many lines with many intersection. If you have the Snap Points setting set to Between Intersection Points, it might slow down the pre/selection. If you not some feedback slowness, try to change the Special Snap Points setting first to Along Entire Element.

snappoint.png

The use of View map items as Trace Reference

If you wish to use e.g. an elevation as Trace Reference under your floor plan, you can do it in two ways:

  • Select the elevation in the navigator’s Project Map, and select “show as Trace Reference”
  • Select the elevation in the navigator’s View Map, and select “show as Trace Reference”

In the first case, the Trace Reference will use the same layer settings and model view options as the active view. In the second case, the Trace Reference and the floor plan will use different layer settings and model view options. This latter scenario will result in a much slower 2D rebuild, because the refreshing of the Trace Reference involves changing layer and model view states. So, if possible, use Project Map items instead of View Map items as Trace Reference.

Using a Trace Reference that has a different Dimension Style setting than the active view causes even worse performance problems, since due to technical causes changing dimension style between views is a fairly slow process. Make sure dimension styles (which technically can be different in every view) are uniform across all views in the project, if possible.

  • settrace.png

Sun Shadows

Section, Elevation and 3D Document views have the possibility to generate Sun and Shadow effects. Most cases it slows down the rebuild of the model. <
It can be turned off view by view in View’s Settings dialog » Model Display » Sun and Shadows.


Hardware optimization

Generally speaking, the CPU has the most effect on how “fast” your 2D display is. However, for some drawing functions, ArchiCAD uses hardware acceleration provided by the graphic card.

ArchiCAD uses 2D display technology to display temporary visual feedback items, such as rubber bands, guidelines, element highlights, etc. Up to ArchiCAD 10 these items were displayed by just simply repainting the necessary pixels on the display. Since ArchiCAD 11 the overlay technology is used, which means that ArchiCAD uses multiple drawing “layers” to display different overlaying items. This enables smoother transitions and nice semi-transparent effects at no cost of performance, since these effects make use of the hardware acceleration provided by video cards. On the PC platform ArchiCAD uses DirectX technology, on the Mac platform ArchiCAD uses the Quartz drawing engine, which manages the OpenGL hardware acceleration provided by video cards.

On PC, when ArchiCAD starts, it automatically checks if DirectX version is supported by the system, and if not, ArchiCAD will use software emulation to emulate the same effects at the cost of CPU time. On Mac, hardware acceleration is handled by the system (Quartz engine) so there is no direct hardware acceleration control in ArchiCAD. If there is a problem with hardware acceleration, the phenomenon is that feedback during element editing is not instant. The most visible phenomenon occurs while dragging a Trace Reference, as this is the situation where the temporary visual feedback is the most complex. Hardware acceleration does NOT affect rebuild times.

PC users: to optimize DirectX settings, and to learn how to disable hardware acceleration, read article DirectX


If you believe that you are experiencing abnormal 2D performance, please contact your local ArchiCAD distributor with the following details of the problem:

  • step-by-step description of a concrete example where ArchiCAD is slow. E.g.: “I open the view Elevation/West Elevation with no Trace Reference on. I select and drag a couple of lines. The feedback during dragging the elements is instant, but after I click to place the elements, the hourglass cursor appears for 6-7 seconds”
  • Start the GSReport application in your ArchiCAD folder and save a .rep file. This captures your system’s components and settings
  • Send an example ArchiCAD project file in archive (.PLA) format. This is necessary even if the problem is not file-specific, as the file includes your common project preference settings.
  • If possible, send a screen capture movie that captures the problem
  • Was this Helpful ?
  • 4   ​1

Related content

GDL Object Downloads for ARCHICAD

  Objects on BIMcomponents.com ArchiCAD 16’s new modeling capabilities, connected with the cloud-based BIM Component database allows you to create, search, upload, and download custom BIM components of your choice. The fully-integrated web portal…

What is OpenGL?

OpenGL is a fast display method for 2D / 3D-like elements developed by Silicon_Graphics . It is optimized for fast interactive navigation among 3D polygons in a fancy and fast way. This makes it especially suited for professional CAD programs. More info…

Polygon Counting Tool

The complexity of a plan, especially the 3D model mainly depends on how many polygons it contains. Polygons are the most basic 2 dimensional plain geometric elements that form the 3D model. Polygon Counting Tool is an ARCHICAD add-on that helps you…

Placing Doors or Windows

Windows and Doors can only be inserted into Walls; they cannot be placed independently in the project. Follow these steps: 1. In the Floor Plan or 3D Window, activate the Window or Door Tool, and choose the desired Window/Door object from the library…

Meshes

About Meshes Display of Meshes Create a Mesh Edit Elevation of a Mesh Point Add New Points to the Mesh Create a Hole in the Mesh Mesh Tool Settings

Details

About Details Create a Detail Drawing Viewpoint with Model Source Contents of the Detail Viewpoint Place a Linked Detail Marker Place an Unlinked Marker Create an Independent Detail Viewpoint Display of Detail/Worksheet Boundary Update Detail/Worksheet…

3D Cutting Planes

3D Cutaway is an imaging mode in ArchiCAD that allows flexible visualization of building spaces. 3D Cutaway works by applying Cutting Planes to the model (Floor Plan, Section, or 3D window). The 3D Cutaways you define are stored within the project, so you…

Magic Wand Settings

Use the Options > Magic Wand Settings command to open this dialog box. When creating curved Walls and polygon-type elements based on Arcs, Circles and Splines, the approximation is based on the state of the Magic Wand Settings dialog box. With the two…

Cancel Operations

By successively pressing the Esc key , you will achieve the following actions: 1. Cancel current operation entirely (during input) 2. Deselect selected item(s), if any 3. Remove Marquee selection, if any 4. If nothing is selected: Switch to…

How to use custom images as default bitmap people

In the Default ArchiCAD Library you can find many different bitmap pictures and an empty custom field. With a few easy steps you can create your own bitmap image. Select a picture Transparent background set up It is recommended that you change the…

Link Construction Elements to Stories

Each Construction Element and 3D Object in ArchiCAD is linked to a specific Story, called its Home Story. The elevation of the Element is determined by the elevation of its Home Story If its Home Story is deleted, the element will be deleted with it…