IFC based data exchange – Troubleshooting guide

by Katalin Borszéki and Márta Trón · updated: 04.13.2016

General recommendations for IFC based data exchange between ArchiCAD and Revit products

Always use the up-to-date version of ArchiCAD and the Revit Add-Ins as GRAPHISOFT constantly improves the data exchange between the two applications through the combination of these.

Known issues

Show visible function is not updated by Viewsets

Affected version: 16-19 | Severity: workaround applicable | ID: 200171

{i} Note: This issue was fixed in ARCHICAD 19 Update 6006.

Issue

The content of the IFC Manager tree doesn’t refresh when changing Viewsets, even if the “List visible model elements only” option is turned on in the IFC Manager dialog.

Cause

The “Show model selection in list” function doesn’t work on elements which can be seen in the model, but cannot be seen in the IFC Manager because of the missing refresh function. It doesn’t refresh after closing and reopening the IFC manager either.

Workaround

These elements will appear in the tree only if turning off and on again the “‘List visible model elements only” button. But this could take time, depending on the size of the model.

IFCListVisible

IFC SCheme Setup

Issue

The two default IFC schemes: Concept Design BIM 2010.xml and COBie.xml are troublesome to find when using the Merge command in IFC Scheme Setup.

ifc.png

Cause

The Merge command of the IFC Scheme Setup Window (File > File Special > IFC 2×3) opens the last selected folder instead of the IFC Scheme folder located here: Applications/GRAPHISOFT/ArchiCAD XX/Defaults/IFC Schemes.

Solution

Please navigate to Applications/GRAPHISOFT/ArchiCAD XX/Defaults/IFC Schemes to locate the default XMLs.
XX is the version of your ArchiCAD.

IFC Import Populates Embedded Library

Issue

IFC import can populate the embedded library. This behavior can lead to very large embedded libraries and possible performance problems.

IFCembeddedLibrary_80.png

Solution

ArchiCAD 18 and newer

When you import an IFC file ArchiCAD 18 will ask where you would like to place the objects to be created. Select Linked Library and define a path. It is suggested to compress the library into a Library Container File (.lcf).

If you have selected not to show this dialog again, you can change these IFC library settings in IFC Options (File menu/File Special/IFC 2×3/)

ArchiCAD 17

You can change the location of the imported objects in IFC Options (File menu/File Special/IFC 2×3/). Select Linked Library and define a path.It is suggested to compress the library into a Library Container File (.lcf).

ArchiCAD 16

This new behavior was introduced with ArchiCAD 16 Hotfix 3 build 3480. To activate it the EnableLinkedLibrary key needs to be added to the Registry under the IFC registry folder. On a Mac a new key with a Boolean type needs to be added with its value set to “True.” The below example shows this key on Windows. (with an Australian ArchiCAD version).

{i} If the IFC folder is not present this generally means you haven’t yet run an IFC import on your computer. Navigate in an open instance of ArchiCAD 16 to File / File Special / IFC 2×3 / IFC Translation Setup and press save [Save Settings & Close] button.

Note for Teamwork Users

In a teamwork environment linked libraries cannot be used. It is prudent to import an IFC file outside of a teamwork environment, and then hotlink it into the teamwork project as a mod file that you created as part of the IFC import. The linked library that was created can be used to update or create a Bim Server library that is associated with the teamwork project.

Workflow suggestions

After activating this behavior your IFC imports will not populate the embedded library with objects. Instead a folder named after the IFC file and located on the given path (17 and 18) or in the same directory as the source IFC file (16) will be created, unless this folder already exists. Within this folder a folder will be created based on the date and time in seconds that the import took place. This folder will be automatically linked to the imported project.

In the below example a file called “2020Sherman_WestWing.ifc” was imported. Since this was the first time a project of that name was imported a new folder “2020Sherman_WestWing” was created. Under the “2020Sherman_WestWing” folder another folder was created. It was named 20130103_154222_000 and linked to the imported file. The 20130103_154222_000 folder contains all of the library objects generated in this import.

IFCfirstImport_80.png

The second time an IFC file is imported with the same name only the sub-folder 20130103_160343_000 is created to store the new objects. This is a nice way of keeping your imports sorted.

IFCSecondImportLibrary_80.png

A new IFC file name will create a new folder and link. Thus your IFC libraries can be clearly organized using the name of the IFC file that created them and then further organized by the time the IFC file was imported.

IFCEastWingImport_80.png

 Text Size do not Appear Correctly in Revit after Export

Issue

If you use DWG files to exchange information between ArchiCAD and Revit, the text size may be not correct, it will not react to scale changes.

Cause

Revit has two types of text: simple text and model text. If you import text from DWG, it automatically becomes simple text in Revit, that reacts dynamically to scale changes.
But after import, Revit handles the DWG file as one block, so it will be in the scale that it was imported from. After an explode command, the text will dynamically change, but you have to be aware that it will use the scale that has been set before the explode command.
Note, that if you link drawing or use Xref, exploding is not possible.

Solution

The are two possible workarounds to solve this situation:

1. Do not import the drawing using Link CAD but Import CAD, that creates a copy directly into drawing – this is the way to use explode. After the import you have to set the scale to the one used in the source drawing, then explode.

ImportCAD3.png

Disadvantages of this solution: the connection between the two drawings is lost, the file size will increase, the drawing will be more complicated.

2. Use ArchiCAD to connect the drawings – if you export the drawing as an Xref, the text elements will also change dynamically.

The IFC file has missing elements on Windows, while on Mac it is complete

Affected version: 17 and older | Severity: workaround applicable | ID: 171216

{i} Note: This issue was fixed in ARCHICAD 17 Update 8000

The problem is caused by the length of the path to the file in question. The file/folder path can not be longer than 256 characters. Some elements will be imported as objects and for that the object file is created in the system. When the object file is created the name of the ifc file is used. Since the name of the file is too long, the path is too long and the import fails.

The workaround is to shorten the name of the file.

Windows and doors are placed outside of walls in Revit products

Affected version: 15,16| Severity: workaround applicable | ID: 132274

{i} Note: This issue was fixed in ARCHICAD 16 Release Version.

In some circumstances when Revit loads ArchiCAD saved IFCs, windows and doors are placed far from the wall where they belong to.

To fix the representation:

  • After the IFC is open in Revit, select the window or door
  • Click on Edit Type
  • Choose a different Family – there should be quite a few with similar look
  • Then the window should jump back to its place

In many cases door or window objects are not important for e.g. structural or MEP consultants. In such cases the best is not exporting the doors and windows, only their openings only.

A couple of ways how doors and windows can be filtered out:

  • Filter elements in 3D
    • Go to View menuElements in 3D ViewFilter Elements in 3D
    • Check out Doors and Windows
    • Save this as a new view and use the view when creating IFCs
  • Use Model View Options
    • Document menuSet Model ViewModel View Options
    • Create a new Model View Option or customize an existing one
    • Under Options for Construction Elements choose Show Opening Only for Doors and Windows
    • Save a new using this filter and use it when creating IFCs

Cannot use more language versions of Revit Add-Ins

Issue: After installing more than one language version of the interoperability Add-Ins, like the Improved ArchiCAD Connection Add-In for Revit Structure/MEP or the MEP Export to ArchiCAD Add-In for Revit MEP, the Revit application works incorrectly. Only one of the language versions appear of the Add-Ins.

Cause: More than one language version of these Add-Ins cannot run simultaneously with Revit.

Solution: Before installing another language version of the Improved ArchiCAD Connection Add-In for Revit Structure/MEP and/or the MEP Export to ArchiCAD Add-In for Revit MEP uninstall the previously installed Add-In.

Overlapping Zones create hole in Revit

Issue: When opening an IFC file in Revit, only one zone with a hole is visible instead of two zones .

001.jpg

Cause: Two zones were created in ArchiCAD on each other. Saving the file as IFC and opening it in Revit gives different result. Revit does not support overlapping zones.

02.jpg

Layer management problem for IFCs coming from Revit MEP Add-In

Affected version: 16 and earlier| Severity: no workaround applicable | ID: 129649

{i} Note: This issue was fixed in ARCHICAD 15 Hotfix 4.

Issue: When opening/merging IFC files from Revit saved with the help of the Revit MEP Add-In: Even though the option ‘Imported layers with extension’ was used everything will be set to the IFCLayer.extension. layernam.png

Cause: The layer information is not considered in case the IFC file comes from Revit MEP.

Solution: This bug will be eliminated in the next Revit MEP Add-In.

/!\ Note that this affects only IFC files saved with Revit MEP Add-In.

Imported Structural Model is not displayed

Issue: How is it possible that I import a structural model, yet it is not displayed with the current Partial Structure Display setting?

Cause: This can happen if Partial Structure Display is set to “Core of Load-Bearing Elements Only.” Even though the structural engineer determines which elements are load-bearing, some structural applications nevertheless do not classify these elements as “Load-Bearing” when saving the model in IFC format.

As a result, if you Merge the model to ArchiCAD or use the Detect IFC Model Changes command, and if the ArchiCAD view is set to “Core of Load-Bearing Elements Only,” then the elements (or the changed elements) will not be displayed in that view – because only the elements defined as “Load-Bearing” are displayed.

Solution: The solution is easy: change the view to a different Partial Structure Display setting, such as “Entire Model.”

Can not merge IFC model into a TeamWork project

Affected version: 15 | Severity: workaround applicable | ID: 129190, 130286

{i} Note: This issue was fixed in ARCHICAD 16 Release version.

The program gives ‘You need the next access right(s) to IFC: Exlusive Access to Create or Modify Stories’ error message while merging the model even the current user has team leader role (with all rights).
IFCTW.PNG
By reserving the story settings the right(s) can be guaranteed.

Opening of the IFC file with Revit Add-ins is not possible in Revit Viewer 2013 or in Revit in Viewer mode

The opening process requires data saving, and it is not allowed in Viewer or in Viewer mode.

Some elements could not be exported due to missing geometry

missing geom

 

 

 

 

 

 

 

 

 

 

In ArchiCAD 17 when there is a problem during export, the interface informs users about the GUID of the problematic element. This method is at times too sensitive, it shows the warning in case of empty openings (Doors and Windows empty rams in a Curtain Wall) despite of the fact that the IFC file stays correct. The listed GUIDs could belong to Simple Door/Window Openings.

The resulting IFC file is correct. If one navigates to these empty doors in Solibri e.g.., the objects are exported/present in the file.

The reasons for the export ambiguity are the following:

– In ArchiCAD a door/window is one element, but in IFC they are two entities: the door structure (IfcDoor) and the opening (IfcOpening).

– In case of an empty opening in ArchiCAD only one entity will be exported, the IfcOpening, and AC misses the IfcDoor, that does not really exist.

These error messages are not saved into the IFC file.

 

  • Was this Helpful ?
  • 1   ​3

Subtopics