DXF-DWG Import Translator Settings

by GRAPHISOFT, ShaunCoomber and Katalin Götz · updated: 12.06.2012

 

File/File Special/DXF-DWG Translation Setup

 

By clicking on a Translator during import, you can see and edit its content in the fields below, which falls into five main groups:

main_groups.png

DXF-DWG Translator Settings

 

Drawing Unit

  • Select the correct value of 1 DXF/DWG Drawing Unit in ArchiCAD according to the drawing unit used in the DWG. The correct size and distance conversion factor must be set to ensure that ArchiCAD interprets the data correctly.
  • Prefer Drawing Unit definition in DXF/DWG file. This checkbox means that ArchiCAD will use the Drawing Unit definition as set in the original imported DXF-DWG file.
  • If no such original definition is available, or if you want to redefine it, use the pop-up list to choose either a standard drawing unit (1 meter, 1 millimeter, 1 inch, 1 foot); or a custom unit (any number of millimeters or inches).

The pop-up list has four items for standard drawing units (1 meter, 1 millimeter, 1 inch, 1 foot) and two custom units (Custom [mm] and Custom [inch]). Selecting either of the custom options will display a field to enter the custom value.

  • The scale factor to ensure the correct ratios of elements drawn in AutoCAD can also be set. This particularly applies to texts, arrowheads, symbol line types and symbol fills:
    Set scale factor separately with each conversion: a dialog box to set the scale appears each time a DWG is imported.
    Use constant factor for all conversions: set a scale factor for ArchiCAD to use for all conversions.
    Always use the scale set in the currently active ArchiCAD window: The scale of the ArchiCAD floor plan will be used for conversion.

Open Options

In Open Options select the translation method of the following elements: AutoCAD Blocks, Dimensions and Pictures

OpenOptions.png

  • Translate AutoCAD Blocks as:
    2D Elements: imported AutoCAD blocks are exploded into basic ArchiCAD elements.
    Grouped 2D Elements: imported AutoCAD blocks are exploded into basic ArchiCAD elements, but remain grouped.
    Library Parts: imported AutoCAD blocks saved as ArchiCAD library objects. (In the appearing field you can choose between the Library formats of 3D data.)
  • Translate Dimensions As:
    Lines and Text: imported dimensions are converted to lines, arrowheads and text, maintaining the same appearance and positions as in AutoCAD.
    Single Dimension Units: each dimension in the AutoCAD file gets converted into an ArchiCAD dimension. There may be some visual differences between ArchiCAD and AutoCAD. For example, AutoCAD allows custom arrowheads, whereas ArchiCAD has a fixed set.
    Dimension Chains: dimensions in the AutoCAD file get converted into ArchiCAD dimensions, which are linked as dimension chains where possible.
  • Associative Dimensions where applicable: Checking this option will look for imported elements which to associate the processed dimensions. This may be time-consuming, so the default behavior is to create hotspots on the element and associate the linear dimension to the hotspots. The most recent versions of AutoCAD contain associative dimensions for certain elements, but these cannot be converted in ArchiCAD. ADT has also introduced a kind of associative dimension, but this can only be associated to ADT objects. Radial dimensions require a circular element to be associated to.
  • Import AutoCAD Hatch Blocks: This option converts AutoCAD fills into unnamed groups of individual lines (hatch blocks), which will not be recognized as fill types in ArchiCAD. When importing a file from AutoCAD R14 or later, hatches will be converted into fill types in ArchiCAD.
  • Import Viewports as Embedded Drawings: Check this box to ensure that AutoCAD viewpoints are imported as embedded drawings on ArchiCAD layouts. If this option is not selected, viewports will be converted to ArchiCAD views, linked to the model data.
  • Convert Pictures to Format: Select a file format to use in converting pictures, or retain the pictures’ original formats.
  • Enable partial open: Filter the elements to be imported, by layer. The DWG’s layers and layers’ statuses will be listed in a dialog box allowing individual layers to be selected.
  • Convert 3D Solids, Regions and Bodies into GDL objects: Check this box to convert the listed items into GDL objects upon opening the file in ArchiCAD.

Attributes

The attributes (divided into five groups: Layers, Pens & Colors, Line Types, Fills, and Font-Style Conversion) of the dxf/dwg file can be imported with specialized settings:

 

Layers

Layer Name Conversion

LayerConversion.png

When importing DWG data, any layers names that don’t exist in the ArchiCAD project will be created. It is possible to specify that the data is moved to existing ArchiCAD layers instead, using layer name conversion.
Note: The newly imported AutoCAD layers will be available and can be set to locked/unlocked – visible/hidden separately from ArchiCAD layers in the Layer Settings dialog.

The data on each layer in the DWG can be moved to a specified layer in the ArchiCAD project by adding entries to the conversion table. The ArchiCAD layer can either by typed or selected from the drop-down menu. If a template has not been specified in the translator then the name of the DWG layer must be typed.

If a template has been specified, the DWG layers can be selected in the drop-down menu too.
Note that the template file can only be selected in the Save Options. This settings page can be accessed if the Translator is opened through the File>Save or File>File Special menus.

Custom layers are available from the drop-down menu if the Translator contains dxf-dwg Layers linked to ArchiCAD items. This settings page can be accessed if the Translator is opened through the File>Save or File>File Special menus.

 

Pens and Colors

Pens and Colors conversion settings match AutoCAD Colors to ArchiCAD Pens.

Pen-color conversion

PenConversion.png

When opening a DXF/DWG file, the AutoCAD pens will be imported and set as ArchiCAD’s current pen table with the same ID numbers. With any other open operation (Merge, Attach XREF, Open Object, etc.) each AutoCAD color will be mapped to the ArchiCAD pen with the most similar RGB value.
Alternatively, the option to Use Pen-color conversion table can be activated.

While you create a new item or edit an existing one, the following dialog appears.

The pen-color conversion table pairs ArchiCAD pens with AutoCAD colors. During import the ID number of the pens will be converted according to this table. The pairs defined in the pen-color conversion dictionary will take precedence over automatic conversion methods.
All AutoCAD pens with an RGB value have a pen index number of 255 or lower. These will have their pen index changed to 255 in ArchiCAD.
Read more about color matching: How to match DWG colors to ArchiCAD Pen colors
If a template has been specified, more pens can be selected from the list.
Note that the template file can only be selected in the Save Options. This settings page can be accessed if the Translator is opened through the File>Save or File>File Special menus.

 

Line types

Methods

Line types defined in the current ArchiCAD project will be kept as well as the line types imported from the DXF/DWG file if you check Keep Existing Line Types on Open checkbox. If the same name is used in both files, the line type will not be imported from the DWG and the ArchiCAD line type will be kept.
If this checkbox is not checked, all line types from the DXF/DWG file will be imported, and none of the existing ArchiCAD line types will be kept.
The LTScale value in output File variable used in DWG files are correctly interpreted when opening or merging DWG files in ArchiCAD. New line types will be created as needed, regardless of the length of the original line pattern.

Linetype-Linetype Conversion

LineTypeConversion.png

This conversion dictionary works exactly the same way as the layer conversion, but is used to control the import of linetypes.

Each linetype conversion item will translate a linetype from the DWG into a specified ArchiCAD linetype. You can create new item or the ArchiCAD line type name can be selected from the pop-up list and its name will appear in the ArchiCAD line type field. In the AutoCAD line type field, type the name of the line type that should be converted to the ArchiCAD type. If a template has been specified, the DWG lines can be selected in the drop-down menu too.
Note that the template file can only be selected in the Save Options. This settings page can be accessed if the Translator is opened through the File>Save or File>File Special menus.

Note: Hairlines (with zero line thickness) will be interpreted as lines appearing with the appropriate pen color. Polylines will be imported as Hairlines.

 

Fills

Fills from the dxf/dwg file can be imported to ArchiCAD. Their settings are defined in the following fields:

FillMethods.png

Methods

The inactive export options are used while DWG/Export. The activated Use the fill conversion table checkbox converts AutoCAD hatches to ArchiCAD fills using the Fill Conversion table.

Fill-Hatch Conversion

FillConversion.png

Click New to define each new correspondence which requires that you have selected an AutoCAD template file in the Save Options page of the DXF-DWG Translation Dialog Box, and the template file includes at least one placed instance of the desired hatch.

To load DWG fills, first select a DWG file to use as a template to load them. An AutoCAD template file must be selected in the Save Options page of the DXF-DWG Translation dialog box, and the template file must include at least one placed instance of the desired hatch.
Note that the template file can only be selected in the Save Options. This settings page can be accessed if the translator is opened through the File>Save or File>File Special menus.

 

Font-Style Conversion

Font names are stored differently in DXF/DWG files and in ArchiCAD. Even when one-by-one font matching is possible, a dictionary is necessary. (On Windows, ArchiCAD supports all available fonts including those installed by AutoCAD).

FontConversion.png

When importing a DWG, if a text’s font is listed in the dictionary, it will be converted according to the conversion table, from the AutoCAD style to the ArchiCAD style. The ArchiCAD font can be selected in the drop-down menu. The AutoCAD style can be selected from the drop-down list if a template has been selected in the Save Options.
The Save Options settings page can be accessed if the Translator is opened through the File>Save or File>File Special menus.
With oblique angle option you can set the degree value of the font.

If the slant parameter is 15 (15 degrees) or greater, the imported text will be in italics. Usually, an italic style has an oblique angle of 75 degrees. Unless a template file is selected, the style will use the AutoCAD counterpart of the ArchiCAD font. (A font conversion file specifies the best match, regardless of the platform ArchiCAD is running on).


Miscellaneous

This group of settings contains options for Font conversion, for spline convert and the opportunity for purging the unused Attributes.

Miscellaneous.png

Font styles that are not listed in the font conversion tables will be replaced with the font defined under Replace Missing Fonts with setting.

Allow national characters in layer, linetype, block names: If the recipient AutoCAD works in the same national environment as your ArchiCAD, you can check this checkbox.

Write binary DXF: This compressed version of DXF takes up about half the space of the text DXF format.

Check Convert Splines into Polylines box to convert splines into polylines in ArchiCAD. ArchiCAD will approximate the AutoCAD spline using a series of connected straight line segments. This may be useful when in some rare cases, the converted ArchiCAD Spline still looks a bit different from its AutoCAD counterpart, or when converting a file containing splines with a huge number of nodes. If this box is unchecked, AutoCAD splines will be converted into ArchiCAD splines.


Custom Functions

Open Extras

OpenExtras.png

Custom Functions contains add-ons for both Open (Open Extras) and Save (Save Extras) operations. Several functions are loaded by default; you need only turn them on or off using the checkboxes.

Points to…

  • Import points as hotspots: use this option to convert AutoCAD points to ArchiCAD hotspots. Without this option, points will be imported as lines.

Meshes to ArchiCAD fills

  • Convert 3D Face to ArchiCAD mesh: converts AutoCAD 3D Faces into ArchiCAD Mesh elements. Only non-vertical faces will be converted.
  • Convert 3D Face – Compatibility: converts AutoCAD 3D Faces into ArchiCAD Lines. Even the invisible edges will be visible.
  • Convert 3D Face to Empty Fill – transparent: converts AutoCAD 3D Faces into empty ArchiCAD Fills. The background color will be transparent.
  • Convert 3D Face to Empty Fill – screen background: converts AutoCAD 3D Faces into empty ArchiCAD Fills. The background color will be the screen background.
  • Convert 3D Face to Empty Fill – contour color: converts AutoCAD 3D Faces into empty ArchiCAD Fills. The background color will be the same as the contour.

Fix 1-line text positions

  • Correct invalid Text Positions: to view available custom functions for the selected element type, browse its subheadings.

Meshes to ArchiCAD meshes

  • Convert Polygon Mesh to ArchiCAD Mesh: converts AutoCAD Polygon Meshes into ArchiCAD Mesh elements. Only non-vertical faces will be converted.

Leaders to Labels

  • Convert Leaders to labels: AutoCAD Leaders will be imported as ArchiCAD Labels, if the Leader’s content is Text or Mtext. Without this option, leaders will be converted to text, polylines and fills.
  • Was this Helpful ?
  • 0   ​0

Related content

SlabPen

Pens & Colors

Each Pen has a specific color and line weight. You assign pens to ArchiCAD elements in their own tool settings dialog box. Note: Your current On-Screen View Options (Bold Cut Lines, True Line Weight) may affect the on-screen display of your lines. See…

Fill Types

ArchiCAD includes a predefined set of default fill patterns, or fill types. You can access them from Options > Element Attributes > Fill Types where you can define, edit, duplicate, rename or delete them. Related Topics: Fill Types Dialog Box Fills
dwg-import-matchpencolors--matchcolor

How to Match DWG colors to any ArchiCAD Pen Colors

AutoCAD offers two methods of setting the color of drawing elements: ByLayer or ByBlock. In ArchiCAD you can use your default or template pen colors, if you match the AutoCAD and ArchiCAD colors following this workflow: Demo file: Ross Street House…
dwg-icon3

Importing DXF/DWG files into ArchiCAD

The DXF/DWG Add-On is installed together with the ArchiCAD package and is smoothly integrated in the ArchiCAD user interface. It allows you to: Open AutoCAD drawings as ArchiCAD Project or ArchiCAD Library Parts File » Open It is worth to use it if you…
dwg-export--saveas

ArchiCAD Export to DWG/DXF

  Save as DWG: You can save a project view or layout from ArchiCAD to DXF and DWG formats. To save only one part of the view, use the Marquee to delimit the project and select Save As command. When Save Plan dialog is displayed, choose DXF or DWG…
dwg-dxf-dwgtranslator--translatoricon

DXF-DWG Translator

Use this dialog box to define how elements in ArchiCAD will be interpreted when exported as DXF/DWG files, and vice versa: how the elements in DXF/DWG files will be interpreted when imported into ArchiCAD. Because of the difference between AutoCAD and…
dwg-export-translator--saveoptionslist

DXF-DWG Export Translator Settings

Available: File > File Special > DXF-DWG Translation Setup   By clicking on a Translator during export, you can see and edit its content in the fields below, which falls into five main groups: Drawing Units Select the correct value of 1 DXF/DWG…