ARCHICAD supports 3D Printing and Computer Aided Manufacturing

by GRAPHISOFT, Katalin Borszéki and Emőke Csikós · updated: 01.03.2017

Introduction

As of version 17 ARCHICAD can directly save and open Stereolitography (.stl) files using the built-in STL In-Out Add-On.

add-on-manager


STL File Format

STL files only carry the surface geometry of a 3D model without any additional information such as color, material etc. It contains the surface divided into triangles. The format is usually used for rapid prototyping, 3D printing, and computer-aided manufacturing. STL format has two kinds of representation: ASCII and Binary

  • ASCII STL
    • An ASCII STL file lists the triangles with the coordinates of their nodes in a readable format for any text editor application.

as-ascii

  • Binary STL
    • In a Binary STL file the data is compressed and is only readable for the appropriate STL application/machine.

Binary representation is more commonly used due to its smaller file size.

Read more about STL file extension on Wikipedia.

How to Use “STL In-Out” Add-On

  • To export to STL format:
    • Open 3D window with only those elements visible that you wish to export.
    • Open File menu/Save as dialogue
    • Select StereoLithograpy File as file type
    • Browse for the destination folder
    • Enter the file name
    • Click Save
    • On the Save 3D as STL dialogue choose from Binary or ASCII representation
    • Click Save

save-as

 

There is a new save option introduced in ARCHCAD 20: you can exclude all elements that have transparent surfaces (such as glass panels of doors and windows or glass railings of balconies) globally with one setting in the Save 3D as STL dialog shown above. You can define a threshold value of transparency over which the element with a transparent surface will not be included in the .stl file. (The value of transparency for the certain Surface is set in the Surface Settings dialog.) The default threshold value in the Save 3D as STL dialog is 100. This means that all elements with all values of transparency will be exported.

transparency

 

To import STL files there are two options: Open or Merge. An STL model will be imported as Morph.

  • Open STL file
    • Open File menu/Open/Open file dialogue
    • Select StereoLithograpy File as file type
    • Browse for the STL file
    • Click Open
  • Merge STL file into existing model
    • Open File menu/File Special/Merge file dialogue
    • Select StereoLithograpy File as file type
    • Browse for the STL file
    • Click Open

Tips and Tricks

  • It is advised to leave doors and windows out of the model since they raise the number of polygons dramatically while leaving them out also makes it possible to get a view into the model. Uncheck Door/Window/Skylight/Curtainwall in View > Elements in 3D View > Filter and Cut Elements in 3D or exclude transparent surfaces using the save option mentioned above.
  • The model should be correct. The BIM model can deal with e.g. the roof joining a wall by its side, but the same is not true for a physical model. The material continuity has to be checked.
  • The number of polygons must be kept in check to manage the memory capacity of 3D printers. Objects that are not necessary for the model should be hidden or deleted as well for saving memory as for saving on material costs.
  • Only the elements in the 3D view get to be exported. All the filtering, hiding, deleting is best achieved in the 3D view then.
  • Be aware that you will not get transparent forms or effects especially like glass ballustrades…tip: delete glass balustrades from ARCHICAD models and glue them in afterwards, with a solid plastic, like perspex.
  • A couple of elements that are not solids in ARCHICAD thus might not print properly:
    • lights, downspouts, shutters use 0 height elements and some grids and old 3D dimensions have unconnected free standing edges
    • several construction elements can also have 0 height: shells, walls and slabs for example
    • openings with visible Opening Direction Lines also have unconnected free standing edges
    • all morphs could be non-solids, please check the morph settings!

check-solidity-1

  • A standard 3D printer can handle about 1.0 mm as minimum thickness depending what 3D printing material you would use too – there are all sorts of resin and/or plastic. The detailing can be a bit tricky with models at 1:200 scale (usually required for planning permission) as blade-like structures can look rather bulky and tend to get very fragile.
  • If you want to achieve nice internal detail you can print the building storey by storey and then glue it up at the end. This requires extra work though so if you are after cheap and quick process you would probably go for an all-in-one thing. Again be aware that you will not get transparent forms or effects especially where they are required to be shown (as mentioned with glass balustrades).

Limitations

  • ARCHICAD does not check the exported STL file for errors, e.g. in terms of solidity. These are usually done by the 3D printer. There are however, 3rd party STL checker programs available:
  • Please note the following if you use ARCHICAD 17:
    • The STL file does not store the scale and unit of the model, these have to be set in the viewer/printer. ARCHICAD always exports 1 m as 1 STL unit. So
      • if you open it in a viewer that thinks 1 STL unit = 1mm, then you get a 1:1000 scale model,
      • if you do it with a viewer that considers 1 STL unit = 1 inch, it’ll show up as ~1:40 scale, and so on.
    • Since the file can not contain any info about what unit was used during saving, any resizing we could do during export will not guarantee that the viewer / printer will automatically scale it correctly. So the proper scaling has to be set up on the viewer / printer side, either:
      • by providing the above definition that 1 STL unit = 1m and the necessary zoom factor, or
      • by measuring the main dimensions and providing them to the printer for control.
  • As of version 18 both STL unit and scale can be properly set in the Save 3D as STL dialog.
  • If the imported geometry is very complex it may affect the performance of ARCHICAD. The following warning dialogue indicates this:

warning

 

  • Note that if the geometry of the model is overly complex, there is a chance that the import will fail and no Morph will be generated.
  • Was this Helpful ?
  • 1   ​0

Related content

AllStories3D

Filter and Cut Elements in 3D

Go to View > Elements in 3D View > Filter and Cut Elements in 3D to open this dialog box. Activate or deactivate the checkboxes of the different elements: only those elements whose checkbox is active will be displayed in the 3D window. See also…