Importing DXF/DWG files into ArchiCAD

by GRAPHISOFT and Katalin Götz · updated: 12.28.2012

The DXF/DWG Add-On is installed together with the ArchiCAD package and is smoothly integrated in the ArchiCAD user interface. It allows you to:

Open AutoCAD drawings as ArchiCAD Project or ArchiCAD Library Parts
File » Open
It is worth to use it if you would like to work on a DWG file as a new project in ArchiCAD.

Merge AutoCAD drawings with your ArchiCAD Project file
File > File Special > Merge
You can merge DWG files into the currently open ArchiCAD Project with all the existing DWG Layers. You can decide which content (Model Space or Paper Space) of the DWG file should be merged.
See also: Merge DXF-DWG in ArchiCAD Help

  •  TIP: Use Smart Merge (round-trip conversion) if you are merging the DXF or DWG file back into the same ArchiCAD file from which you saved it, because it can be exchanged the additional information with minimal loss and interference.
    See also: Smart Merge in ArchiCAD Help

Add AutoCAD drawings as external references (XREFs)
From the Floor Plan, Detail or Worksheet window, use File > External Content > Attach XREF.
XREFs are similar to Hotlinked Modules, except that they are DXF or DWG files and not ArchiCAD files.
It is worth to use it if you would like to import the DWG as one, non editable block into your ArchiCAD project that can be reloaded when the DWG file has been modified. You can detach it after import and to delete all Attributes of the DWG in one step.
See also: XREFs and About XREFs in ArchiCAD Help

Place as Drawing to Layouts or Model Views
File > External Content > Place External Drawing
It is worth to use this method if you would like to use the DWG as a reference file (like Trace), do not want to modify its content in ArchiCAD and would like to avoid to import unused Attributes. The Snap points of the DWG can be detected and the parameters can be picked up in the Drawing. You can customize and resize the placed DWG as a general Drawing.

TIP: If you want to edit the DWG as Drawing element, choose Edit > Reshape > Explode into Current View and then rework the linework and text as desired. This approach has the side benefit that all the components end up on the same layer as the Drawing element, rather than adding multiple layers to your project layer list.

Opening a DWG file as Library Part
File > Libraries and Objects > Open Object
This command will open the GDL Object Editor Window. Here you can browse for any DWG files, then save it as a new object by clicking on File » Save as… command. With this method you can open 3D DWG files.
Read more: How to import 3D DWG files

Import Blocks from DXF/DWG
File > Libraries and Objects > Import Blocks from DXF/DWG
The Import Blocks feature converts ArchiCAD Library Parts from AutoCAD blocks. The newly created Library Parts are stored in the Embedded Library of the project and can be placed as any other Object.

See also: Opening DWG/DXF Files in ArchiCAD Help

 

Note: Sometimes the location of imported DWG may differ from its original AutoCAD position, if the DWG file was saved with UCS (User Coordinate System) actived.
In AutoCAD UCS (User Cordinate System) or WCS (World Cordinate System) can be set as origin. ArchiCAD always uses the imported DWG’s original WCS and places your project in the calculated distance from ArchiCAD’s project origin.
If you have set UCS in AutoCAD, changing the DWG file origin back to world coords (WCS) solves the problem.

As an other solution the ArchiCAD model can be moved to Project Origin with the following way: Relocate Projects Placed Far From Origin


Which one is the best choice to import my DWG file?

 

Open Merge XREF Drawing Object
Can Attributes (Lines, Fills) be imported? Yes Yes Yes No No
Can the imported Attributes be edited? Yes, all can be edited separately Yes, all can be edited separately Yes, after Detach - -
Can the imported Attributes be incorporated? Yes, while Open they become the part of the project Yes, while Merge they become the part of the project Yes, after Bind Yes, use Explode command No
Can Layers be imported? Yes Yes Yes Yes Yes
Can the imported Layers be turned On/Off? Yes No Yes, without detaching Yes No
Can the DWG be placed into Model View? Yes Yes Yes Yes Yes
Can the DWG be placed into Layout View? Yes, the content of Paper Space(s) can be append to Layout Book Yes, can append Paper Space(s) to Layout Book No Yes No
Do Translator Settings apply to import? Yes Yes Yes No No
Can the file have its own Pen Set? Yes No No No No
Can 3D data be imported? No No No No Yes

DXF-DWG Translation

How DWG data is imported by ArchiCAD depends on the settings used in the DXF-DWG Translator; this dialog box defines how elements in ArchiCAD will be interpreted when importing DXF/DWG files.
Depending on how the Translator is opened, not all settings will be available. For example, if the dialog box is opened during an Open, Merge operation or is attached as XREF, then the Open Options will be listed, but not the Save Options, and vice-versa. If the dialog box is opened from the File>File Special menu then all options are listed.

Further details about DXF-DWG Translator Import Settings

Related content

dwg-import-translator--main_groups

DXF-DWG Import Translator Settings

  File/File Special/DXF-DWG Translation Setup   By clicking on a Translator during import, you can see and edit its content in the fields below, which falls into five main groups: DXF-DWG Translator Settings   Drawing Unit Select the…
dwg-import-xref--attachxreficon

XREFs

XREFs are External reference files: DXF or DWG filetypes which can be imported into ArchiCAD. It facilitates to collaborate with Sturctural Engineers. A common use for XREFs is to draw elements that are common to several kinds of drawings within a…
f0sqcC1iiAU

ArchiCAD Collaboration Tutorial Part 2 INT - 8-3

ArchiCAD Collaboration Interactive Training Guide Part 2. In this movie: Collaborating with Structural engineers - DWG External References (XRef) How ArchiCAD teams can collaborate smoothly with Structural Engineers How to import a DWG file using Xref How…
dwg-import-matchpencolors--matchcolor

How to Match DWG colors to any ArchiCAD Pen Colors

AutoCAD offers two methods of setting the color of drawing elements: ByLayer or ByBlock. In ArchiCAD you can use your default or template pen colors, if you match the AutoCAD and ArchiCAD colors following this workflow: Demo file: Ross Street House…
dwg-import-drawingreference--tracereference

Tips to Import DWG Files as Trace Reference

Sometimes we get reference files such as site plans, drafting aids, plans from co-workers in DWG format that we should not modify. To display two different views concurrently in any ArchiCAD model or layout window, we can use the Trace Reference feature…
howtosuperimpose2dfloorplanonto3dmodel--2dsuperimpose-11

How to superimpose a 2D Floor Plan onto a 3D Model

This topic demonstrates a way to place a 2D linear drawing into the 3D model at the exact vertical position of the Cut Plane from which that 2D Floor Plan View was generated. This can help you to compare the current 3D model with its 2D representation…
dwg-import-layers--embeddedlayers

DWG Layers' visibility in ArchiCAD

  To control the visibility of objects, usually there are more Layers used in DWG projects. Let's see how can the different import options in ArchiCAD manage the DWG layers:   Open File » Open To define how elements in ArchiCAD will be…
sketchrenderingfromfloorplan--opendwginarchicad

Sketch Rendering from Floor Plan

The TechTip July 2002 winner, BertNijs , from Belgium found a way to show Floor Plans in the 3D Window inspired Karl Ottenstein to find a way to create a sketchy look of 2D drawings of ArchiCAD (Floor Plans, Section-Elevation Windows etc.) The idea came…