How to Open and Save 3D DWG or 3DS Files

by GRAPHISOFT and Katalin Götz · updated: 11.28.2014

3D modelling softwares have different engines to compute objects, they have their own file formats. The conversion between these applications goes usually in two ways:

  • Using DWG/DXF format: the content of the file depends on the conversion system of the original modelling software. This decides for example, that the 3D surface in the original file appears in the dwg as block, polyline, 3d primitive, region etc. In case of advanced softwares, you have options to set this.
  • Using 3DS format: this is an other often used format to transfer 3D data. Read more: 3DStudio

Note: If the DWG file contains solid elements, converting settings in the ArchiCAD translator should be checked in the referring checkbox in DWG/DXF-DWGTranslator dialog > Open Options > Convert 3D Solids, Regions and Bodies into GDL objects.


ArchiCAD » AutoCAD

In ArchiCAD with the 3D window in front you can save models to *.3DS format. This 3D model can be placed into AutoCAD using the Insert/3D Studio File Import command.

TIP: How to export ArchiCAD project to 3DStudio Max File (.3ds)


AutoCAD » ArchiCAD

ArchiCAD can open 3D DWG files as ArchiCAD objects:

Method 1: Merge the DWG File

Go to File > File Special > Merge… menu item. Select a DWG file to open, then the project content you want to import. In the appearing “Merge DXF-DWG Model Space” dialog, check in the “Import Model Space content as GDL object” option to import the model content as a single GDL Object.

Merging 3D DWG files tutorial by BIMES Dubai:

http://www.youtube.com/watch?v=i33MRAdbvFM

 

Method 2: Open as GDL Object

Tip: Convert the Library Object to a freely editable MORPH element (available from ArchiCAD 16): Select the Object in 2D or 3D view and go to Design > Convert Selection to Morph(s).

Step 1: Open Object

Select File > Libraries and Objects > Open Object. In the appearing dialog browse for the DWG file and open it. Clicking on “Settings…” button you can check the DXF-DWG Translator Settings which will be used during the DWG import. (Only the options used in 3D DWG conversion are listed.)

Note: If Custom Functions/ Open Extras/ Convert to GDL objects of 3D solids option is not checked in DWG Translator, 3D Solids, Regions and Bodies won’t be imported.

2.jpg

 

Step 2: Save Object

Save the imported object with Save command or while closing the Open Object dialog to the Embedded Library or to a custom folder.

3.jpg.png

Step 3: Place Object

The generated 3D library part will be available from Object Settings Dialog.

Click OK button and place the object. Now you will see the complete 3D object in ArchiCAD.

Note: It can result bad object position, if you would like to replace these objects with original ArchiCAD GDL Library Parts, because ArchiCAD’s intersection point differs from the original DWG intersection point. It can be solved if the DWG block is moved to 0,0,0 location in AutoCad.

4.jpg

 

Method 3: Convert into GDL Objects during the DWG Translation

Upon opening a DWG file, you can select the “Convert 3D Solids, Regions and Bodies into GDL objects” option in the DWG Translator Settings dialog > Open Options.

In this video by EricBobrow you’ll learn how to import manufacturer components as 3D library parts:

Related content

ArchiCAD File Types Opened by ArchiCAD

ArchiCAD Projects (.pln, .pla, .bpn) ArchiCAD 18 can open projects from ArchiCAD 8.1 and up (8.1, 9, 10, 11, 12, 13, 14, 15, 16 and 17). Solo Projects (.pln) are the main native document type of ArchiCAD. A .pln file includes all model data and the…

ArchiCAD File Types Saved by ArchiCAD

ArchiCAD Projects (.pln) ArchiCAD supports unicode file names of essentially unlimited length. Archive (.pla) For details, see Archive Files. ArchiCAD Project Template (.tpl) Choose this option if you want to save the current project settings for…
howtosuperimpose2dfloorplanonto3dmodel--2dsuperimpose-11

How to superimpose a 2D Floor Plan onto a 3D Model

This topic demonstrates a way to place a 2D linear drawing into the 3D model at the exact vertical position of the Cut Plane from which that 2D Floor Plan View was generated. This can help you to compare the current 3D model with its 2D representation…

Morphs

About Morphs Morph Selection Create a 2D Morph Create a Revolved Morph Create a Box Morph Create Morph from Existing Elements Basic Morph Editing Useful Commands for Transforming Morphs Edge Type: Hard, Hidden, Soft Boolean Operations with Morphs Morph…

About Morphs

Use the Morph tool to create freeform elements within ArchiCAD, so you don’t have to import special shapes from other programs. The Morph tool is fully integrated into ArchiCAD, and works with a familiar logic and interface. Like other construction…
dwg-export--saveas

ArchiCAD Export to DWG/DXF

  Save as DWG: You can save a project view or layout from ArchiCAD to DXF and DWG formats. To save only one part of the view, use the Marquee to delimit the project and select Save As command. When Save Plan dialog is displayed, choose DXF or DWG…
3dstudio--download

3D Studio Files in ArchiCAD

Import 3ds Max Files (.3ds) With the help of 3DStudio In Add-On you will be able to convert .3ds files to ArchiCAD GDL objects. By default, it is not integrated into ArchiCAD’s interface.   Download and install "3DStudio In" Add-On You can download…