ARCHICAD 20 Small Improvements

by Márta Trón and Ákos Karóczkai · updated: 06.28.2016

This list contains a collection of changes that may be not reflected in all language versions of the ARCHICAD 20 Reference Guide. These include retired features, bug fixes, and smaller usability or interface changes which were made after the Reference Guide was completed.


Little New Features and Small Improvements

You can find a list of small interface changes in the New features Guide also.

Export ARCHICAD Model to Twinmotion

A new add-on built in to ARCHICAD 20 enables you to save the ARCHICAD model to Twinmotion 2016, using the Save As… Twinmotion (.tma) command from the 3D window.
The resulting file can be opened in Twinmotion version 2016.02.
Twinmotion, owned and developed by Abvent R&D, is a visualization and 3D immersion software dedicated to architecture, urban planning and landscaping.
For more information, see http://twinmotion.abvent.com

Optimized Import of Google Earth Model File (.kmz)

Use new options to speed up import when opening a Google Earth Model file in ARCHICAD:

GE

  • Collect 3D geometry placemarks into a single Library Part: If you check this, ARCHICAD will generate a single GDL object for multi-geometry placemarks (instead of separate ones). This can reduce the time it takes to import the .kmz file.
  • Display 3D geometry placemarks without fills: This option can speed up navigation in large models.

New Find & Select Criteria

Now it is possible to add criteria by Surface and Materials:

SurfaceAndMaterialsinFindandSelect

Automatically Check Status of All Hotlinks in Hotlink Manager

In Work Environment, under Data Safety & Integrity, you have this option: Automatically Check Status of All Hotlinks in Hotlink Manager. It is checked by default.

In projects with many hotlinks, the auto-check process might slow things down. In this case, uncheck this option.

AutomaticallyCheckStatusofHotlinks

Custom Texture Alignment

Custom Texture defined in the 3D Window option was renamed to Custom Texture Alignment.

CustomTextureAlignment

Navigator and Pop-up Navigator Changes

  • The Pop-up Navigator now has a shortcut: Ctrl/Cmd + Shift + N (can also be customized).
  • The Navigator Palette now includes the Hide Navigator option.
  • Right-click the header of the Pop-up Navigator to access a context menu (as previously in the Navigator Palette).

Navigator

Drawing’s context menu changes

On Layouts, a Drawing’s context menu includes an option to “Open source view in New Tab” (in addition to the existing “Open source view.”) This command not available for Floor Plans or 3D views.

OpenSVinNewTab

Extra Option at BCF File Import

You can now browse for and locate IFC files referenced by a BCF file imported as a Mark-Up entry. This extra step is useful, for example, if the original composite elements were exploded at export: this way, the exploded parts will be identified as the original element.

New Options in Support Package Creation

The Help > Create Support Package command now offers additional options for customising the content of the support package. This is especially useful for limiting the size of a package involving large projects and/or Teamwork projects.

  • The new Client Only option is for Teamwork projects: it excludes the logs and Model files from the Server, and sends the Model and Log files only from the Client.

client only

  • The Custom option lets you uncheck any data type that you do not want to include (solo and Teamwork projects).

Custom Package Content

Option to Show Dimension Text Only

Use this option to display the dimension text only, without any lines. This checkbox is available for linear, radial and angle dimensions, to comply with some local standards.
You can display a reference line (on-screen only) for this type of dimension as an aid in editing: turn it on at View > On-Screen View Options > Dimension Reference Lines.
DimensionTextOnly

New Backgrounds When Saving BIMx Model

If you save BIMx Hyper-model from Publisher, you can now choose among different backgrounds: Gradient, Black, Gray, White and the earlier Skybox.

BIMxbackoptions

Info Box for Library Parts Tidied Up

The Info Box “Element” panel for Library Parts has been tidied up, with Empty Opening and Create/Edit stair now in the popup menu.
InfoBoxControls

New Smooth Method for Adding Schedule Parameters

When clicking on Add Fields…, a pop up window with a search field will appear. Double-click the needed parameter to add it to the fields – after this, the window stays open, so you can continue adding the next parameter if needed.
AddParam

New Parameter in Skin List Label

Thickness parameter can be turned on and off (previously was always visible.)

ShowThicknesinLabel

Performance and Stability Improvements

  • No character limit for the file path in the Library Manager, on Windows operating systems.
  • Now it is possible to clean up and manage the Hotlink-related Embedded Library folders in the Library Manager.

Not supported features

PhotoRendering Settings (CineRender)

The Light Mapping Method of Global Illumination is not available in ARCHICAD 20.

  • Was this Helpful ?
  • 17   ​0