Attribute Manager

by GRAPHISOFT, Katalin Götz and Márta Trón · updated: 07.26.2013

The Attribute Manager (Options menu) is a handy tool to create and manage the Company-standards in your ArchiCAD projects.

Its commands allows you to copy (append, overwrite) attributes (Layers, Layer Combinations, Pens & Colors, Line Types, Fill Types, Composite Structures, Materials, Zone Categories and Cities) between two opened files.

Furthermore you can clean up you ArchiCAD projects deleting the unused attributes. It makes sense when importing e.g. DWG/DXF files or GDL objects from the Internet, wherein often unused Layers, Lines, Fill Types and Materials can be found. The unnecessary attributes make the project massed and slow down the work.

Please find below some guidelines how to work effective with Attribute Manager.

Save the attributes of your project

AttributeManager1.PNG

  1. Go to Options > AttributeManager You can see the attributes of the current project on the left side and the right side is empty.

  2. Choose the appropriate Tab page or click on the All tab if you want to save all the attributes in your file.

  3. Click on the Select All button and Append >> or Overwrite >> now you can see all the selected attributes on the right side.

  4. Click on the Save as… button to save the attributes it will get the *.aat extension. Click OK to close this dialog.

Transferring attributes into a file

AttributeManager2.PNG

  1. Open an ArchiCAD file with the default settings: Choose File menu > New… > Create a New Project check the radio button Use Default Project Settings > click on New and Reset. (or by holding Alt-key go to File menu > New and Reset All)

  2. A new ‘Untitled’ project opens up.
  3. The predefined attributes will be overwritten by the ArchiCAD default settings.
  4. Go to Options > Attribute Manager and choose Open… on the right side of the window, and find the appropriate *.aat file.

  5. Click on the appropriate tab page or the All tab, and choose the Select All… and the << Overwrite buttons. After clicking on the Apply button you can get a list confirming the changes whish attributes were created, modified or deleted.

  6. Merge your file from File menu > Merge…

  • Was this Helpful ?
  • 1   ​0

Related content

linefillnormalization--l01

How to clean up Attributes in ArchiCAD?

Line and Fill Normalization Several ArchiCAD features involve the creation of “exploded” elements. Model-based Details, Worksheets and Drawing Sections create 2D elements (lines, fills) out of the model construction elements. Also, imported DWG drawings…