Installation Package creation

by GRAPHISOFT, Andor Szőke and Márta Trón · updated: 01.18.2017

ARCHICAD Network Installation
(Instructions for BIM Managers)

With a Commercial and certain Education licenses, GRAPHISOFT offers you the option of creating an Installation package that contains your company-standard settings.
Using this installation package, you can save time by installing ARCHICAD 20 at multiple workstations according to your customized, company-preferred configuration.
The following settings can be predefined in the network installation package:
Work Environment settings;
DXF/DWG Translators and IFC Translators
Project templates
To do this, choose the special installation option that automatically records your installation process and creates the installation package. The resulting install file can then be started on any number of client machines. This process is detailed below.
Note for Educational Institutions: If your ARCHICAD license is registered to an educational institution, you can use the Installation Package Creation process to create a recorded installation and simplify the installation of multiple identical copies of the program – even if you wish to use factory defaults instead of custom-defined settings.
Network Installation Step by Step
To create a custom installation package, follow these steps:

1) Single-user Installation

The first step is to do a Standard installation of ARCHICAD on a single client machine.
Follow the instructions at “Install ARCHICAD 20: Single License”. Choose the “Typical” Setup.
Next, set up your preferred Work Environment/Template/DXF-DWG and IFC translators, as described below:

2) Customize Work Environment Settings

Start ARCHICAD, then use the dialog boxes at Options > Work Environment to set up your company standard Work Environment settings. Most such options are found in three dialog boxes of Company Standard Schemes: Data Safety & Integrity; Network and Update; and Special Folders.
Once you have set these options, save these settings as schemes, then save the schemes in a company-default profile. To save a profile, go to Options > Work Environment > Work Environment Profiles.

3) Customize Templates

Create and save any number of template files. Template files include links to libraries loaded through Library Manager (e.g. “Office Standard Library”). Templates can also include Project Preferences (e.g. Working Units, Zone calculation preferences), and such items as Master Layouts, Project Info, placed elements (e.g. Elevation markers, entire buildings).
Save each template using File > Save as… (ARCHICAD Template file *.tpl).

4) Customize DXF-DWG Translators

Use the DXF-DWG Translation Setup dialog box (File > File Special > DXF-DWG Translation Setup, to set up DXF/DWG Translators and save them to a shared folder on a server. A DXF-DWG TranslatorList.xml file is also created, which is a list of references to these translators.

5) Customize IFC Translators

Use the IFC Translation Setup dialog box (File > File Special > IFC Translation Setup) to set up IFC Translators and save them to a shared folder on a server. An IFC TranslatorList.xml file is also created, which is a list of references to these translators.

6) Quit ARCHICAD

7) Create “Defaults” Folder

Create a Defaults folder.
Within the Defaults folder, create three sub-folders named as follows:
ARCHICAD
DXF-DWG Translators
IFC Translators
Add your saved, customized defaults using the folders and files as described below.
Add your saved “WorkEnvironment” folder and its contents to the Defaults/ARCHICAD folder
Add your saved Template file(s) (extension .tpl) to the Defaults/ARCHICAD folder.
Add the contents of the saved Translators folders to the Defaults/DXF-DWG Translators folder and the Defaults/IFC Translators folder, respectively.
Add the IFC Translator List.xml file to the Defaults folder.
Add the DXF/DWG Translator List.xml file to the Defaults folder.
Final structure of the Defaults folder:

8) Uninstall ARCHICAD; Re-start Installation

Uninstall ARCHICAD from your computer, then run the Installer again.
Alternatively, run ARCHICAD Installer on the server or on another machine.

9) Start-up Presentation

After you insert the ARCHICAD DVD, or double-click on (extract) the ARCHICAD 20 Download folder, the start-up presentation will be launched.

10) Start Installation Wizard

Click on Install GRAPHISOFT ARCHICAD to start the ARCHICAD Installation Wizard.

11) Welcome Screen

Make sure that you close all running programs before you proceed with the installation.
Click the option for Install as BIM Manager.
Then click Next.

12) Choose License Type

Click the option that corresponds to your license type: Hardware or Software Key for ARCHICAD, or a Serial Number (for Education and Trial Licenses).
Then click Next.

13) License Agreement

Read the license agreement carefully and accept it, then click Next.

14) Program Folder Selection

On this page, you can define the file path of the installation. As a rule, you should choose the path suggested by default, to simplify the installation of any future updates.
To confirm the file path, click Next.

15) Choose Setup Type

To prepare for Network installation, choose the option for Installation Package Creation.
The screens of the Installation Wizard will now show the message “Recorded Installation.”

16) Choose Program Components

Select the features you wish to install.
After you make your choice, click Next.

17) Install Company Standards

Check Install Company Standard Defaults, and enter the file path location of the Defaults folder (containing Work Environment/Translators/Templates) which you created earlier. (See Create “Defaults” Folder at Step 7 above.)
Click Next.

18) Install Customized Work Environment

Choose Predefined Company Standard Profile Set to include your customized Work Environment in the Installation Package.

19) Install Company Standard Template(s)

Check this box to include your saved Template in the Installation Package.

20) Installation Summary

This screen summarizes your chosen configuration, so you can make any needed corrections to the installation settings.
Click Install to begin installation.

21) Installation

Depending on your hardware, this process may take several minutes.

22) Import Work Environment

Do not import any older-version Work Environment; do not change the default choice.
Click Next.

23) Shortcuts/Automatic Updates

Here you can create an “ARCHICAD 20” Desktop shortcut.
Review the setting to Enable ARCHICAD to Check for Updates automatically (checked by default).
Click Next.

24) Restart Computer

If the installation process includes installing CodeMeter, you are prompted to restart your computer now. If you click Yes (recommended), the restart will be carried out on every client computer that uses the install package.

25) Define File Path

Define a file path location for the Installation Package, then click Next to confirm.
The Installation Package will now be written. Depending on your hardware, this process may take several minutes.
Click Finish to close the Installer. You may be prompted to restart your computer.
You have now created an Installation Package. Users who start this package on a client machine will not encounter any options in the Installation wizard, and the installation process will begin immediately.
  • Was this Helpful ?
  • 0   ​0

Related content

install--install

ARCHICAD 20 Installation

Installation and startup troubleshooting guides ArchiCAD 16 ArchiCAD 15 ArchiCAD 14 ArchiCAD 13 ArchiCAD 12 Hotfix BIM Server installation and configuration Educational Version Advanced installation solutions Silent install methods How to create…
OpenEnvironment

Environment Settings

Open this dialog box from the Model Review Palette’s pop-up at the top right; or from Design > Energy Evaluation > Environment Settings . The Environment Settings dialog contains: Settings: Location and Climate, Grade Level, Soil Type…
WESchemes

Work Environment Schemes

Work Environment settings ( Options > Work Environment ) are divided into six self-contained schemes . Each scheme is a thematic collection of settings. 1. User Preference Schemes. These include a wide variety of your preferences for functions such…
TemplateList

Template Files

A template is a read-only project file with extension tpl. It contains all project preferences settings, placed elements and tool default settings of the project. ArchiCAD 17 is shipped with a default template file together with the default library. Upon
templatefiles--save

Template Files

See also: Template Files in ArchiCAD Help A template is a read-only project file with extension tpl. Why should I create my own template Templates are intended to cut down or eliminate the time to create a new project by reducing the repetitive task of…
translator-list.xml--translatorsaveasdxfdwg

Translator List.xml

The 'Translator List.Xml'file is located in the following folder: On PC: C:/Users /<USER>/ AppData/Roaming/Graphisoft/AC/Dxf-Dwg Preferences On the Mac: /Users/<USER>/Library/Preferences/Graphisoft/AC/x86/Dxf-Dwg Preferences Translator…
select_license_type

Activate Educational or Trial license

  Step 1: Register and Download You can register and download ArchiCAD installation files from MyArchicad.com website. Step 2: Start Installation Process After downloading ArchiCAD installer, run installation file and choose “I have a Serial Number…
archicad-office-standards-and-templates--1

ArchiCAD Office Standards and Templates

ForWikiEditors : ToDoTechTip/ - check and update article Originally published at AECBytes: http://aecbytes.com/tipsandtricks/2008/issue30-archicad.html written by Eric Bobrow Principal, Bobrow Consulting Group Office standards set the graphic appearance…
WE_open ArchiCAD

Tips to set up Work Environment

At the bottom of the Start ArchiCAD dialog box, you can select your preferred Work Environment profile. Unlike Project settings, Work Environment settings are saved not as part of the project, but in a local folder on your computer. The individual…