How to migrate to BIM Server 20

by István Moharos · updated: 06.10.2016

New features of BIM Server 20

In version 20 there have been several BIM Server and ARCHICAD side developments which increase the Teamwork performance and stability.

  • Optimized data handling on the Server side to offer better performance
  • Teamwork communication optimization in ARCHICAD
  • More responsive and more stable Teamwork

Migration from older versions

As a first step choose a computer you would like to install the new BIM Server on. This can be either:

  • the computer that runs your current BIM Server
  • any other computer that meets the System Requirements

It is not possible to install BIM Server 20 on top of your current BIM Server. This means it can be installed on the same hardware alongside with older versions, but it will be a separate application and has to be installed into a separate folder.

It is strongly recommended to have the least possible number of BIM Server versions running simultaneously on the same computer. After migrating all data remove/uninstall the older versions to keep all resources available for the latest server.

/!\ Before migration make sure that you have a full backup and appropriate time for the migration process.

Install BIM Server v20

Install the BIM Server using the installer from the DVD/downloaded from the web.

At the end of the installation, the configuration will be done in your default web browser. If you face any difficulties within the browser, try an alternate supported one. You can copy paste the url over to the new browser.

During the server set up you can add a primary address which can be used to connect to the server from ARCHICAD. You can add this address manually or you can use the ‘Show current addresses…’ button where you can choose from existing addresses which the application automatically detected.

BIM Server 20 Set up server address

{i} Note that BIM Server v20 Module cannot be started until the BIM Server is not activated after the configuration.

Firewall, network

Open the new ports on all related firewalls and forward them in the router’s settings if necessary for public access over the Internet.

The new default ports:

  • BIM Server Manager: 20000
  • BIM Server v20 Module: 20001

/!\ Make sure to set up different ports for different BIM Server versions!

A fixed IP address is required and a DNS name is recommended for the computer that runs the BIM Server. If the server is accessed from both the local area network and over the Internet make sure to add all the different addresses (internal IP, external IP, domain name) in the BIM Server Manager Connection settings.

BIM Server 20 Connection settings

Address input

Once BIM Server 20 is installed, to access the BIM Server Manager, open a web browser and type combined address and port into browser address bar. Default port is 20000. Examples of the address format:

http://server.company.com:20000 or http://IP address:20000

Migrate Users and Roles

Use BIM Server Manager to create Users and/or Roles. You can also import previous role and user databases.

Export data in v18 and v19

  • Open the browser based management interface
  • Navigate to ‘Users’ page
  • Click on the tick icon above the users
  • Click on ‘Select all’
  • Export
  • Repeat the same with ‘Roles’

Export data in v17 and older versions

  • Open BIM Server Manager application that belongs to v17 version
  • Go to ‘Users’
  • Export, All users…
  • Go to ‘Roles’
  • Export

Import data in BIM Server 20

  • Open the browser based management interface
  • Navigate to ‘Users’ page
  • Click on ‘+’ next to the ‘Users’
  • Import
  • Browse for the user database you exported previously
  • Repeat the same with ‘Roles’

{i} Please note that the Server Administrator and Project Administrator management roles are not coming over during the migration. These have to be set up manually after the import process.

Upload Libraries

First upload the latest ARCHICAD Library 20 and the migration libraries:

  • Open ARCHICAD 20
  • File>Libraries and Objects>Manage BIMcloud / BIM Server Libraries…
  • Connect to your BIM Server – make sure you use the the full url when connecting, example: http://server.company.com:20000
  • Click on the ‘Upload…’ button
  • Browse for the ARCHICAD Library 20 in your ARCHICAD 20 folder
  • Upload all migration libraries from the ARCHICAD 20 folder you might need for your projects

Upload the libraries from your previous BIM Server

  • Open the previous ARCHICAD version you were using like ARCHICAD 19
  • File>Libraries and Objects>Manage BIM Server Libraries…
  • Select each library and check the ‘Source Folder’ or use ‘Extract…’ to download the library from the Server
  • Go over to ARCHICAD 20 and upload all libraries based on the previous ‘Source Folders’

Migrate Projects

To Migrate Projects from BIM Server 13 through 19, please follow the migration guide. Alternatively you can do it manually:

  • Open project in its current version of ARCHICAD
  • Save as a .PLN (ARCHICAD Solo Project)
  • Open the PLN and change library source from a BIM Server to a Linked library which resides on your workstation or a common file server
  • Save the file and open it in ARCHICAD 20
  • Use the Library Migration service if prompted
  • Share the project from version 20 using Teamwork>Projects>Share…

To share or join projects from ARCHICAD 20 go to Teamwork>Project>Share… or Open/Join Teamwork Project… and enter the combined server address and port, same format as shown above. (server.company.com:20000)

  • Was this Helpful ?
  • 2   ​2

Related content