ArchiCAD 10

by GRAPHISOFT · updated: 07.21.2006

Platforms

Archicad 10 is avaliable for Windows , Mac OS X (PowerPC), Mac OS X (Intel) operating systems

License types

Unlike with previous Archicad releases, there is no separate EDU (or DEMO) version. License type can be chosen upon installation:

  • install-license-options-small.png

COM license

Archicad starts as a full featured commercial version only if a Hardware Protection key is accessible and there are free licenses on it. Depending on the content of the protection key, the license can be permanent, time limited (Pay Per Use) or Not for Resale.

DEMO license

Program switches to Demo mode if Hardware Protection cannot be accessed or there is no free license available. Save, Copy, TeamWork functions are disabled (unlike in previous versions, printing is enabled).

EDU licenses

The student (STU) and university (UNIV) version of Archicad have been combined, so there is only one educational (EDU) version.

Student license registration process

Student versions can be installed only with a serial number which can be obtained at https://eduregistration.graphisoft.com . This registration process has two steps. As a result of the first step, you will receive your personal temporary serial number and a download link to Archicad 10. The process at this level is completely automatic, so you will receive your serial number and the link immediately after you register. This temporary serial number will give you 30-days usage.

At the end of the second step you will receive your personal final serial number that allows you to run Archicad for one year (can be renewed free of charge after expiration). This part of the process involves an “approval” stage, which will be handled by Graphisoft’s local representative.

University license

There are separate Student (STU) and University (UNIV) serial numbers, which affect only the Installer. The difference is an install option for universities which allows multiple Archicads to be installed remotely from one central computer. One University Serial Number will allow an unlimited number of installs for the school / university and expires after two years. University license can be obtained from Graphisoft’s local representatives.

File formats

EDU and commercial project files will have the same file format ( .PLN ), but EDU files have an irremovable logo at the top right corner. This logo will be present on all printouts. Because the new EDU file format is the same as the full, the Archicad 10 EDU version are NOT compatible with the previous educational versions and does NOT read (˛ .PNE , .PAE …) files created with earlier educational versions.

Compatibility issues

EDU project files can be opened with a commercial version of Archicad. In this case, Archicad switches to EDU mode. The logo cannot be removed. Commercial project files can be opened with an EDU version of Archicad. In this case the logo is added, and cannot be removed later. Besides ‘Open’, no other data exchange (copy, paste, merge, hotlink…) is allowed between EDU and commercial project files.


Localized versions

Currently released versions ordered by relase date (as of 2006.09.01):

Code Market
INT International
USA United States
GER Germany
NZE New Zealand
AUS Australia
FRA France
ITA Italy
FIN Finnland
SWE Sweden
HUN Hungary
AUT Austria
CZE Czech Republic
TUR Turkey
JPN Japan
NOR Norway
POL Poland

Build numbers

Every ArchiCAD release have a build number, which can be checked choosing the About Archicad option, thus opening the initial splash screen. The below example belongs to a version with build number 943 (which is a release candidate of the Archicad 10 MacTel version)

build-number-943.png

Different localized versions might have different build numbers. This reflects the changes of the Archicad codebase between the release date of each localization.

Hotfixes

Graphisoft regularly releases hotfixes, which can be accessible using the “Check for Updates” option in the Help menu. This command will open a web page where the system determines whether your Archicad version is up-to-date or not. If your build number is lower than the build number of the latest issued Archicad Update Patch, the web page will display a link where the newest Patch can be downloaded from:

build-number-817.png

If there is no patch applicable, the website displays the following details:

up-to-date-website-small.png


ArchiCAD 10 New Features Overview

Modeling Freedom
Slanted walls, columns and beams Walls can be slanted and double-slanted (battered), columns and beams can be inclined.
Cross-section profiles for walls, beams and columns Custom profiles can be defined with the help of the “Profile Manager”. It is possible to create any profile shape with the fill tool. Components of the profile can have different attributes (material, priority).
Enhanced intersection in 3D on solid basis Walls intersections now affect the 3D wall shape only in the common vertical range of the two walls. Complex walls and beams intersect with each other properly, on a solid 3D basis.
Door and window vertical anchor Doors and windows can be anchored in various ways: to wall or story, by sill height or header.
Door and window fit to slanted and complex wall surfaces Doors and windows can be vertical or aligned, with the opening geometry of a complex wall.
Doors and windows in polygonal walls Doors/windows can be placed and freely dragged, mirrored and rotated within polygonal walls.
3D zones fit to complex element geometry 3D zones fit to slanted and profiled wall surfaces. Trimming 3D zones by slabs and roofs is now based on solid element operation technology.
Complex, multi-story elements Walls, columns, beams, and roofs are automatically shown on all stories they intersect.
New floor-plan display options for construction elements The following display options have been added: Projected, Projected with overhead, and Cut only.
Priority-based dynamic wall–wall intersection on floor-plan Intersection priority can be assigned to wall elements or individual wall skins/ components. Wall skins and wall elements intersect with each other, based on their intersection priority.
Reshaping elements in any view All basic editing commands and new commands specific to complex elements uniformly work in floor-plan, section/elevation and 3D views.
Moving wall openings Doors and windows can be dragged from one wall into another on the same plane, and they can be edited with other element types.
Integrated design and documentation workflow
Integrated layouting Layouting functions of PlotMaker are now integrated into Archicad 10.
Identical editing methods and environment Identical interface and feature set for design and documentation: infobox, pet palette, area-based selection, parametric GDL, etc.
Extended navigator Two new Navigator Panels: Layout Book and Publisher sets. Navigator also includes structure of linked external Project files.
Project organizer An organizing tool to easily set up View Sets, Layout books and Publisher-sets by moving elements between Navigator-like panels.
Drag and drop Navigator items Move or duplicate Navigator items in the tree and between Navigator panels.
Drawing manager Updated drawing management with customizable content, interface and drawing-level status-checking.
Drawing tool New tool box tool dedicated to placing and modifying drawings. Drawing settings also appear in the Infobox.
Parametric drawing titles Parametric (GDL) associative titles can be placed with drawings automatically in Archicad 10.
Direct drawing referencing from S/E and detail markers Section and detail markers can now be linked directly to views/drawings.
PDF drawings in Archicad projects Import pages from PDF documents as drawings into layout sheets, or even into the model.
Interactive element schedule Fully integrated Interactive schedules have become WYSIWYG tabular model views. New schedule drawings can be placed to layout as any other model drawings. Any change in the values is immediate and irreversible.
Project indices View, drawing and layout indices can be defined and placed in a similar manner to Interactive Element Schedules. Alphanumeric values – like drawing names – can be changed from within the index.
Teamworked documenting Teamworking mechanism is extended to the documentation process. Layouts are now part of one’s workspace, similar to stories or layers.
Scalable project setup Multiple project files can be managed in the Navigator/ Organizer. Views of other project files can be placed as drawings on the current file’s layout, or whole layouts/masters can be imported.
Named pen sets Any number of pen sets can be defined. Model views and layouts use two separate pen sets, while drawings can each use separate pen sets.
Autotext features Autotext entries indicate global project, system, layout book information in an automated way.
Separate on-screen and model view options View options that concern on-screen interactions are separated from model view options that pertain directly to a specific view or layout.
Distorted and gradient fills Distorted instances of a vectorial fill can be applied to individual elements. Roofs automatically appear with appropriately distorted fills on the Floor Plan; bi-color linear and radial gradient fill.
Consistent printing and plotting Header/footer; marquee area printing, hi-res large format printing, hairline printing.
Publishing enhancements Concurrent publishing of complete Layouts and individual Model Views; Dynamic Indexes – generated on-the-fly.
Interactions
XP style Every button, pop-up menu or control will look and behave according to Windows XP standards.
Enhanced pop-ups Improved fill-selection and pen-selection pop-up menus. Fills and pens appear with names. A scroll-bar and a preview are included inside the pop-up menu.
Integrated context-sensitive help system Press the right mouse button at any location on your Archicad screen and choose “What’s this?” or “Help” to jump to the relevant section of the Help option.
Reveal hidden features Eyedropper, Syringe, Trim and Adjust tools are accessible from the menu; they can be placed on any toolbar.
Work environment re-design The primary default work environment – including palette layout, menu structure and toolbars – has been re-organized.
Company standard scheme The work environment separates company standards from individual user preferences.
Floor-plan and section attributes on the UI The redesigned floor-plan and section display attributes of construction elements are available from one panel on the info box or the tool settings dialog, using a single interface.
Pre-selection As the mouse moves over an element, the element will be highlighted, and an info tag will show relevant information to ease the identification of that element.
Highlight selected elements The selected element’s color changes temporarily to a user-defined uniform highlight color.
Guide-lines Guide-lines will appear automatically when the user pauses the mouse over an element’s edge or point, to help find directions, angles and special geometry locations.
Element snap Any point or edge of the dragged element(s) snap to any other points or edges of the project’s elements.
Tracker During any graphical operation, the Tracker follows the cursor and provides information about its position. The Tracker also provides an in-place numeric input option.
3D navigation “Orbit mode” for concurrent navigation and editing. “Explore mode” for game-like walk-arounds.
Shaded section/elevations Shaded section/elevation with surfaces using material’s colors.
Story levels in section Story levels can be graphically edited in section windows through story level markers.
Miscellaneous
Project file compression Option for compressing Archicad files when they are saved.
Library container files New, optimized file format (.lcf) for library part storage.
Archicad – DWG translation Model views and the layouts are converted into real model space and paper space in a single operation; BYLAYER-compliant export method.

Related content

ProjectSelectorProfessional_EN

ArchiCAD license types

All available GRAPHISOFT license types, file compatibility between Full, Solo, Educational, Trial and Start Edition versions
troubleshooting-rotatedlayoutssections--rotated-section

Rotated layout and section upon opening

Issue Upon opening the project full layouts and sections are rotated. The angle of rotation is consistently the same on all sheets. The rotation includes the titleblock of the page. Cause Bug in connection with rotated origins. Workaround After closing…
DragWindowFreely

Moving Wall Openings

Use the Drag , Rotate , Mirror and Elevate commands to move wall openings (i.e. Doors and Windows). All these operations are available in the Floor Plan, Section/Elevation/IE windows and the 3D Window, for slanted and straight Walls only. Door/Windows do…
LWSoftShadows

Doors/Windows

The handling and behavior of Windows and Doors are quite similar, therefore they will be described together. Skylights are also analogous to Doors and Windows. For more information, see Skylights . In ArchiCAD, Doors and Windows simulate the look and…

Library Container File

The extension.lcf identifies a “Library Container file”. The default ArchiCAD 17 Library is stored in an.lcf, but you can also create your own Library Container file, or extract its contents, using the File > Libraries and Objects > Create/Extract a…

Pen Sets

ArchiCAD comes with several predefined Pen Sets. These are listed and managed Options > Element Attributes > Pens & Colors or Document > Pen Sets > Pens & Colors . See Predefined Pen Sets for Specific Functions for an overview of the…
CompressFile

File Compression

When saving certain file types from ArchiCAD (.pln, .tpl, .pla, .mod), the Options button in the Save dialog box presents you with the option to “Compress file.” This option is enabled by default, and is recommended in most cases, since file compression…
createlcflibrary--createlcf-00

How to create an LCF (Library Container File)

In certain situations having a full library in an LCF is more useful than having the library in its original hierarchical folder structure form on your hard drive. Such situations are: Library Parts are not modified or not to be modified . Let us say you…
educationalversioninstallation--edu01

Educational Version Installation

  Step 1: Register and Download You can register and download ArchiCAD installation files from MyArchicad.com website. Step 2: Start Installation Process After downloading ArchiCAD installer, run installation file and choose “I have a Serial Number…

Library Update Management

Back to: Teamwork The standard Graphisoft library should first be uploaded from the computer of the administrator of the BIM server. By following this workflow, it is simple to refresh the BIM Server Library, after updating the local copy on the…
archicad-s-3d-views-and-3d-documents--1

ArchiCAD's 3D Views and 3D Documents

ForWikiEditors : ToDo/ - check and update article Originally published at AECBytes: http://aecbytes.com/tipsandtricks/2008/issue35-archicad.html written by Eric Bobrow Principal, Bobrow Consulting Group ArchiCAD makes it easy to create a Virtual…

Link Construction Elements to Stories

Each Construction Element and 3D Object in ArchiCAD is linked to a specific Story, called its Home Story. The elevation of the Element is determined by the elevation of its Home Story If its Home Story is deleted, the element will be deleted with it…