Shell Tool Settings

Reference Line Offset to Home Story: Enter a value here for the elevation, measured to the Home Story, of the initial point of
Current: The Shell’s Home Story will be the Current Story.
Select Home Story: Choose a story to which to link the Shell. Click Select Story to bring up the full list of stories in the project, if they are not all shown in the list.
Reference Line Elevation [to Reference level]: Set the height of the Shell’s starting point as measured from the Reference level (by default, this Reference level is Project Zero). Click the pop-up arrow to change the Reference level, if needed.
Note: Reference levels are defined at Options > Project Preferences > Reference Levels.
Note: The Reference Line Elevation shows the current elevation of the Shell bottom. Thus, this value serves as a calculation tool only, not a link. If you change the position of a Reference level, the Shell will not change its position.
Click one of these icons to define the Wall as Basic or Composite, then choose an attribute that reflects its structural properties:
For a Basic Shell: use the pop-up to choose its Building Material.
For a Composite Shell: use the pop-up to choose its Composite structure.
Note: This pop-up shows only those Composite Structures whose “Use With” control includes Shells. Composites are defined at Options > Element Attributes > Composites.
Shell Thickness: Enter a value for the thickness of the Shell.
See About Shells for more information.
Morphing Rule (for Ruled Shell only): Click on either the “Smooth” or “Paired” method for defining the geometry of a Ruled Shell, based on how the respective nodes of the two profiles should be connected.
Flip: (Editable in Shell Selection Settings.) The Shell is composed of a membrane and a Shell body attached to one side of the membrane. Use Flip to change sides: the Shell body moves to the other side of Shell membrane.
If you are using either the Extrusion method or Revolved method, this panel contains special properties related to the Shell geometry.
Starting angle: The angle between the plane of the Shell and the Shell edge at the initial point of the extrusion vector.
Distortion angle: Angle of the Shell profile, measured to the Shell plane. By default: 90 degrees, but changing it enables you to extrude the Shell profile at a angle, creating a distorted Shell, provided that either its starting or ending angle is other than 90 degrees.
Ending angle: The angle between the plane of the Shell and the Shell edge at the endpoint of the extrusion vector.
Revolution angle: Angle of revolution of the Shell around its axis.
Distortion angle: Angle of the axis of the revolved Shell, measured to the Shell plane angle. Modifying the distortion angle will affect the Shell profile. (Changing the slant angle alone, which is available through graphical editing, will not change the Shell profile, only “tip” it over.)
By circle: Divides a full circle into the given number of segments, and applying that geometry to the existing arc of the Shell.
By arc: Divides the existing arc of the Revolved Shell into the given number of segments.
Show on Stories: Choose an option to define which stories will display the Shell.
All relevant stories: The Shell will be displayed and editable on each story it intersects.
Home Story only: The outline of the Shell will be displayed and editable on its Home Story only.
Floor Plan Display: This pop-up contains five options for displaying the element.
Projected: shows cut part of element’s 3D model, plus its uncut (downward) part.
Projected with Overhead: shows cut part of element’s 3D model (i.e, as cut at the level of the Floor Plan Cut Plane), plus the element’s overhead part (i.e. the part of the element that is above the Floor Plan Cut Plane.
Cut Only: displays only the cut part, as cut with the Floor Plan Cut Plane.
Outlines Only: the entire element’s outline is shown using its uncut attributes. The line type will vary depending on the Shell’s location with respect to the Floor Plan Cut Plane:
Overhead All: the entire element’s outline is shown using its overhead attributes.
Show Projection: This pop-up contains three options. (These are available only when the Floor Plan Display option is set to one of the “Projected” options.)
to Relative Floor Plan Range: Choose to show the element on a range of stories (the current story, plus a given number of stories above and below it.)
to Absolute Display Limit: Set a fixed lower limit (by default, this is Project Zero), then show all parts of the element above this limit.
If you choose this option, then go to Floor Plan Cut Plane Settings to set the Absolute Display Limit for this element.
Entire Element: All visible parts of the element will be displayed.
Cut Surfaces: In this section, set the attributes displayed for cut surfaces both in Section and on the Floor Plan.
For a basic Shell: define the cut line type and pen.
For a basic or composite: If needed, override the fill foreground/background pens of this element (defined by default in the Building Material). To do this, choose Foreground, Background or Both from the Override Cut Fill Pens pop-up to access the respective controls.
Outlines: Use these settings to define line types and pen colors to element outlines that fall above (Overhead) and/or below (Uncut) the Floor Plan Cut Plane.
Overhead Lines will be displayed if the Floor Plan Display pop-up is set to “Projected with Overhead” or “Overhead All”.
Uncut Lines will be displayed if the Floor Plan Display pop-up is set to “Projected” or “Outlines Only.”
Cover Fills: Check this box to display a cover fill using the fill and pen settings chosen here.
Note: Only those Fills defined as Cover Fills in Options > Element Attributes > Fill Types are available here.
Use Fill from Surface: Check this box if you want your cover fill to resemble the surface material (vectorial 3D hatch) assigned to this Shell, either as defined in the Building Material or (if the override is on) its top surface override in the Model panel
Cover Fill Orientation: This control defines the orientation of the fill pattern.
Note: Shell cover fills appear on the Floor Plan only if you have chosen Outlines Only in the Floor Plan Display Options, since that shows the Shell’s top view.
Note: The Cover Fill Orientation control is gray if you have checked the 3D projection option, just below.
Link to Project Origin: The fill pattern will start at the Project Origin, and the part of the pattern that falls within the Fill’s boundary will be displayed. No fill handle appears.
Link to Fill Origin: If you choose this option, then the cover fill will show a fill handle when you place the Shell on the Floor Plan. You can then manipulate the fill orientation by selecting and moving the fill handle. (Use the “Move Sub-Element” command from the pet palette.)
Note: Fill handles are only displayed if you have enabled View > On-Screen View Options > Fill Handles; and make sure that the 3D Projection checkbox (below) is turned off.
Distorted: This option will distort the cover fill, simulating the 3D view of a curved surface on the Floor Plan.
3D Projection: Check this box to display the Cover Fill as derived from its 3D Projection. (If you check this option, the “Cover Fill Orientation” options above are not available.)
Override Surfaces: Click the toggle button of any or all three pop-ups if you wish to override the surface assigned to this element (in its Building Material). You can override the three faces of the Shell: the Reference Side; the Opposite Side; and the Edge.
Note: The Reference Side surface override, if it is a vectorial hatching, can also be applied as a cover fill for the Shell (by checking the “Use Fill from Surface” box in Floor Plan and Section panel of Shell Settings). Moreover, if the cover fill has a customized fill origin (via Link to Fill Origin option), the 3D Model will reflect that fill orientation too.
Note: You can apply custom surface settings to any one or more edges of the Shell, using Custom Edge Settings from the Pet Palette. If you do so, the Model panel of Shell Settings will indicate that one or more edges uses a custom surface, using a yellow patch.
Trimming body: Use this control to define the geometry of the Shell’s trimming body. The trimming body will cut other elements in accordance with this geometry, when you trim another element to this Shell.
Note: To see these trimming bodies while you work (in the 3D window only), turn on Trimming Bodies in the View > On-Screen View Options menu.
  • Was this Helpful ?
  • 0   ​1