Migrating PlotMaker Layout Books to ARCHICAD 20

Note: In this description, version “9” should be understood as either version 8.1 or version 9.
1.
Create Two Separate Files in ARCHICAD 20: The ARCHICAD 9 Project file should be placed into its own Project File in ARCHICAD 20 (this file would contain only Model Views, plus the default Layout Book), and the PlotMaker 9 Layout Book should be placed into a second, separate Project File in ARCHICAD 20 (this file would contain all Layouts with no Model information).
2.
Create a Single File in ARCHICAD 20: If the Project is small enough, both the ARCHICAD 9 Project File (PLN) and the PlotMaker 9 Layout Book (LBK) can be merged into a single file in ARCHICAD 20.
2.
To migrate the PlotMaker 9 Layout Book, use the File > Open command. In the Dialog, select PlotMaker Layout Book (*.lbk) as File Type and select the desired LBK file. Click the Open button to start opening it.
Please note that these generated Title Types have become non-parametric GDL Objects in ARCHICAD 20, displaying the same information as the source Title Type in PlotMaker 9. However, if you used default Title Types in PlotMaker 9, you will find the counterparts of these in the ARCHICAD 20 Library and you may change the generated Title Types into parametric ones shipped with ARCHICAD 20.
4.
Please see Conversion Warnings for a detailed list of conversion warnings.
Also, Layout-specific settings in the Work Environment of ARCHICAD 20 will not be modified by data of the imported Layout Book.
Please note that the program compares only the names (but not content or definition) when checking for matching Attributes/Master Layouts.
3.
In the latter active Project File (the one containing model data), use the File > Interoperability > Merge command to merge data from the other saved ARCHICAD 20 file (the one containing Layout Book data). In the appearing dialog box, choose Layout Book to merge Layout Book data of the file into your active Project File. Click the Merge button.
Note: You should follow the route specified in this guide, that is, merge the PLN File containing Layout Book data into the PLN File containing Model data, and not the other way around. This is because of the rules of merging, and because Views and certain other data would not come through if you merged the Model data into the file containing Layout Book data.
Note: Such drawing links will not be redefined as internal references if the name of the source project file has changed since the drawings were placed. In this case, you should select all such drawings in the Drawing Manager and use the Link To button to re-link these Drawings to their source PLN (the renamed project file).
1.
Printing/Plotting Publisher sets should be reviewed
Some Print/Plot Options in PlotMaker 9 have no equivalent in ARCHICAD, so these settings need reviewing before Printing/Plotting them.
2.
Original output color of Elements drawn or pasted into Layouts has been restored
In PlotMaker 9, in the Book Settings Dialog box, output color of elements on Layouts may be set to grayscale or black. This option has no equivalent in ARCHICAD, so elements will appear in their original color.
3.
Fill-related display and output options could not be converted
In PlotMaker 9 you may apply global settings to Fills. These options have no equivalent in ARCHICAD, so they cannot be converted. Therefore, all fills are displayed as defined in the Fill Settings Dialog Box.
4.
OLE Drawings could not be converted
ARCHICAD does not support OLE technology, so OLE drawings within the LBK file cannot be converted properly. (If the OLE drawing was embedded in the LBK file, with no live link to the source application, you will see the drawing, but you cannot update it.) You can identify OLE drawings using the Drawing Manager palette: look for the OLE icon in the Type column. It is recommended to replace these OLE Drawings with PDF files in ARCHICAD 20.
5.
Edited drawing Layers are restored
In PlotMaker you could modify the show/hide status of Drawing Layers. This option does not exist in ARCHICAD, so these drawing Layers will be displayed according to their original show/hide status.
6.
Text and Markers size changes
In PlotMaker, you could set the size of Texts and Markers to retain their original size even after the Output Scale was modified. (You checked the Fix Size option for Text and Markers in the Drawing Settings dialog box.) This option does not exist in ARCHICAD, so Text and Markers will be resized according to the scale change, just like any other element in the drawing.
7.
Custom line weight is restored to pen line weight
In PlotMaker you could assign a custom line weight to lines, circles and splines. In this case the color of the line came from the assigned pen, but the weight was custom set in the element’s settings dialog box. This option does not exist in ARCHICAD, so the line weights of lines, circles or splines will be set to values specified in the Pens & Colors Dialog.
Layers, Pens, Fills: The ARCHICAD 20 PLN file will inherit the Layers of the LBK Layout Book. The PlotMaker Layer will be renamed to ARCHICAD Layer. Pens and Fills come through unaltered.
Autotext items: All Autotext entries are converted. The name of some of these items will change. The following Autotext items (located in PlotMaker 9’s Book Info Dialog) are now found in the Project Info Dialog of ARCHICAD 20:
Draftsman (CAD Technician in ARCHICAD 20)
Layout Number (Layout ID in ARCHICAD 20)
Subset Number (Subset ID in ARCHICAD 20)
Page Number (Layout Number in ARCHICAD 20)
Number of Pages (Number of Layouts in ARCHICAD 20)
Book Name (File Name in ARCHICAD 20)
Book Path (File Path in ARCHICAD 20)
Drawing Name with Extension (Drawing Name in ARCHICAD 20)
Drawing Number (Drawing ID in ARCHICAD 20)
Drawing Path (File Path in ARCHICAD 20)
Drawing Scale (Original Scale in ARCHICAD 20)
Output Scale (Drawing Scale in ARCHICAD 20)
AC File Name (File Name in ARCHICAD 20)
AC File Path (File Path in ARCHICAD 20)
Master Layout: Layout size is defined differently in ARCHICAD 20. In PlotMaker 9 and earlier versions, the size of the Layout means the printable area of the page (the full size of the paper minus margins on all four sides). In ARCHICAD 20, the size of a Layout means the full size of the paper. This change does not affect either the full size of the Layout (printable area + Margins on all four sides) or the sizes of the printable area or any of the Margins. They will be the same as in previous versions; only the names have changed to better approximate real-world practice, where a Layout is the whole paper used for printing/plotting. So Master Layout sizes are converted accordingly. The Grid for Drawing Numbering and Master Layout default come through unaltered.
Layout settings: comes through unaltered.
Subset settings: comes through unaltered.
Book settings: comes through unaltered, except Output Color settings, which does not come through (no equivalent in ARCHICAD 20 – see Warning 2 above).
Drawing settings: all settings come through (Title is converted into GDL Object), except for Attributes Update Rules, which have no equivalent in ARCHICAD 20. Layer changes are not carried through (see Warning 5 above). If the Text and Markers option in PlotMaker has been set to Fix Size, Warning 6 above is displayed. If a placed Drawing had its own Pen Set, the same Pen Set will be created in ARCHICAD 20 and the Drawing will continue using it. The Output Scale setting will be converted into Drawing Scale.
Note: In ARCHICAD 20, Drawing Scale is the scale of the Drawing on the Layout, which will be output, while “Original Scale” is that of the Drawing’s source view.
Grids: come through unaltered.
Project Preferences: Working Units, Mouse Constraints, Publisher preferences, Uniform Pens and Colors setting, Miscellaneous settings come through. (Since there is no Uniform Pens and Color settings checkbox in ARCHICAD 20, this means in effect that all Drawings will refer to the same Pen Set). If cache data was stored in the Layout File in PlotMaker 9 (the option is in Preferences > Cache Folder), the Drawings will be stored in the Project File in ARCHICAD 20 (see Drawings placed on Layout below). Custom line weights do not come through (no equivalent in ARCHICAD 20 – see Warning 7 above).
Drawings placed on Layouts: In PlotMaker 9, Project links are saved with the Layout Book File (Preferences > Cache Folder > Include Cache in Layout Book). By default, external links (e.g. PMK files, bitmap files) are not saved with the Layout Book File.
If a Drawing was saved with the Layout in PlotMaker 9 (Include all linked files checkbox of the Save as Dialog in PlotMaker 9 is checked), the Drawing generated from it in ARCHICAD 20 will be set to be a manual-update Drawing, and will be saved with the ARCHICAD 20 Project File (the Store Drawing in the Project file checkbox will be checked in the Drawing Settings Dialog).
If a Drawing was not saved with the Layout in PlotMaker 9 (Include all linked files checkbox of the Save as Dialog in PlotMaker 9 is not checked), the Drawing generated from it in ARCHICAD 20 will be set to be an auto-update Drawing, and will not be saved with the ARCHICAD 20 Project File (the Store Drawing in the Project file checkbox will not be checked in the Drawing Settings Dialog).
Background: The modification status checking of Drawings is significantly enhanced in ARCHICAD 20, compared to PlotMaker 9. In PlotMaker 9, the program monitored the last modification date of the Drawings’ source files. If the last modification date of the file had changed, the program assumed that all Drawings coming from that file would need updating.
Background: In PlotMaker 9, the Drawing Name was always the same as the name of the View from which it was created. In ARCHICAD 20, a View Name consists of two parts: View Name and View ID. For this reason, Drawing Name can be either “View Name” or “View Name + View ID” (or Custom).
In ARCHICAD 20, options for Doors and Windows are set separately in Document > Model View > Model View Options, Options for Construction Elements Panel, giving you more flexibility in displaying model views:
If you choose the Show On Plans radio button, but leave the with Markers checkbox unchecked, it will achieve the same result as the Show on Plans option in ARCHICAD 9.
If you choose the Show On Plans radio button, and check the with Markers checkbox, it will achieve the same result as the Show with Dim. option in ARCHICAD 9.
If you choose the Show Opening Only radio button, but leave the with Contours checkbox unchecked, it will achieve the same result as the Hide on Plan options in ARCHICAD 9.
If you choose the Show Opening Only radio button, and check the with Contours checkbox, it will achieve the same result as the Reflected Ceiling options in ARCHICAD  9.
The Hide on Floor Plan radio button is a new choice: it means that Doors/Windows will not be shown on the Floor Plan at all, just as if there were no Doors/Windows in Walls. In Section, Elevation, and Interior Elevation, the Door/Window hole will be visible.
Set Fill-related overrides at Document > Graphic Overrides > Graphic Override Rules.
For Fill Type, Fill Pen, Fill Background Pen: Click one or more icons to the right of the control to choose which category (Drafting Fill, Cover Fill, Cut Fill) should be affected by the override.
Check Show Skin Separators to achieve the same result as the Separators Only option in ARCHICAD 9.
Use Cover Fills – Solid Foreground to achieve the same result as the Solid w/o Separation Lines option in ARCHICAD 9.
Use All Drafting Fills – Solid to achieve the same result as the Solid option in ARCHICAD 9.
Use All Cover Fills – Solid Foreground to replicate the Solid option in ARCHICAD 9.
All Zone Fills – Transparent: This replicates the None option in ARCHICAD 9.
All Zone Fills – Solid Category: This replicates the Category Color option in ARCHICAD 9.
All Zone Fills – Solid Background: This replicates the Solid Background Colored Fill option in ARCHICAD 9.
All Zone Fills – Category Background: This replicates the Fill Pattern on Category option in ARCHICAD 9.
All Zone Fills – No Background: This replicates the Fill Pattern Only option in ARCHICAD 9.
  • Was this Helpful ?
  • 0   ​0