Import Functions

Open (File): opens the entire model or filtered parts of an IFC file as a new project. ARCHICAD will transform the imported elements (e.g. IfcWall) into the corresponding ARCHICAD elements (e.g. Wall).
Merge (File > Interoperability): is available only in Floor Plan view, and inserts a received IFC model in whole or in part into a running ARCHICAD project. Merge preserves your running project, without overwriting its data (this is the “Reference model” concept). So the program always automatically generates new IFC GlobalId (ARCHICAD IFC ID) values for all imported elements to avoid overwriting the IFC GlobalIDs of the host project. However, even in this “Reference model”, the merged elements are real ARCHICAD elements based on the IFC-ARCHICAD mapping convention. Of course, for the purposes of listing and searching, the import process will retain the elements’ original GlobalId values, in the form of a parameter called “External IFC ID”.
Detect IFC Model Changes (File > Interoperability > IFC): detects the geometric differences between two versions (IFC files) of a single model, and merges the modifications (new, deleted and modified elements) only into the currently running project.
Update with IFC Model (File > Interoperability > IFC): updates the current project content with an IFC model (an IFC file). Use this if the project and the IFC file contain elements in common, and if you want to add to or modify the project elements’ data using IFC properties. “Elements in common” are those whose GlobalId Attribute is the same in both the host project and the imported IFC model. “Properties” are IFC Attribute, IFC Property and IFC Classification Reference data. Geometry data (size, color, layer) will not be updated or modified. Using this command, one or more of the following functions can be carried out:
Merge new properties from IFC: IFC data (Attribute, Property and Classification Reference) which do not yet exist in the host project will be added to elements in common. For example: You export your Zones in IFC format to a Zone management application. The application adds new data to your Zones and sends back a new IFC file. Now use this function to add the new data to your existing Zones (provided, of course, that the application has retained the Zones’ GlobalId attributes.)
Override existing project properties: For elements in common, the project data will be modified by the corresponding data values from the merged IFC file. Corresponding data: IFC Property data must have the same Property name and Property Set name; Attribute and Classification Reference must have the same name.
Note: This is a full override: all values for data items having the same name will be modified; the original project values will be overridden.
Remove project properties that do not exist in IFC: For elements in common, those project data will be removed which do not exist in the merged IFC file.
Merge new IFC model elements: Unlike the functions above, this one is not concerned with specific IFC data. Here, the elements which exist only in the merged IFC file are added to the ARCHICAD project. The newly added elements are inserted together with all of their IFC data.
Hint: To narrow the set of “elements in common”, you can use the Model Filter when merging the IFC file – that is, use a Translator that has an active Model Filter (see IFC Translation Setup > Import Options > Show Model Filter on import). This way, for example, you can update just the Zone (IfcSpace) properties, or the properties of all elements on a particular story (IfcBuildingStorey).
Note: All import functions (except the Open command) can be canceled with the Undo function. Nevertheless, it is recommended that you save the ARCHICAD file before you merge an IFC file.
Imported IFC data can be checked in the Settings dialogs of the imported elements and in the IFC Manager. Find & Select, Interactive Element Schedule and Labeling also work for/with the imported IFC data.
Note: If the imported IFC file contains only a single story, then the story chooser option is grayed, and that IFC story is used. During Merge, the elements will end up in the right place if you issue the Merge command from the Floor Plan view of the ARCHICAD story that corresponds to the right position, if such a story exists. If not, and if the current ARCHICAD story is in a different position, then use the default Elevation offset value (the difference between the stories’ absolute elevations).
  • Was this Helpful ?
  • 0   ​0