Managing Hotlinks

Use the Hotlink Manager (File > External Content > Hotlink Manager) to gain an overview of and manage all the modules in your project.
The “Hotlinked Modules” list (in the top half of the dialog box) displays the hierarchy of modules hotlinked into the current project. Each module listed here represents a vertical “slice” (that is, one or more stories) of its source file.
The “Hotlink Sources” list displays the source files of the hotlinked modules, together with the status of each of these files.
You can set the option to “Skip Nested Modules” separately: for each placed instance of a hotlinked module, select the module, go to Module Settings, and check the Skip Nested Modules box.
You can open or update the nested hotlink’s source file in just one step, by clicking the Update or Open in Separate ARCHICAD buttons in the “Hotlink Sources” section below. However, the Relink command is available only for the source files of modules at the top of the hierarchy, not for nested modules.
If you want to clear all the instances of the same Hotlinked Module, you can go to the Hotlink Manager dialog box, select a Hotlink’s name and click the Delete button.
Note: The Break command is not available for Hotlinked Modules in Teamwork. Instead, you can explode a Hotlinked Module instance. (See Explode Hotlinked Module Instance in Teamwork.)
To break the hotlinks and preserve the elements of ALL instances of one or more modules, select the module in the Hotlinked Modules list in Hotlink Manager (File > External Content > Hotlink Manager). Then click the Break Hotlink button. The result: the elements contained in the module are now regular editable ARCHICAD elements, no longer part of a module and no longer linked to any other source file.
To break the hotlink of any single instance of a placed module, select the module and use the Break Hotlink of Selected Module in File > External Content > Hotlinked Module Settings.
If the source file of a hotlinked module is changed, the placed instance of the module will be updated only if you use the Update command in Hotlink Manager. (File > External Content > Hotlink Manager.) The Hotlink Sources list indicates which source files, if any, have been “Modified” and thus are out of date. Select the file and press Update.
Note: If stories have been deleted from the hotlink source file, then after an update, you will be warned of the missing stories.
If you click the Update, Relink or Relocate commands for selected Hotlink Source files, these scheduled actions are noted in the files’ status column with a yellow triangle (at this point, you can still cancel the operation). The actions are not carried out until you press OK to close the Hotlink Manager dialog box.
Warning: Carrying out these actions means that your ARCHICAD project’s entire Undo queue will be cleared!
Warning: After this operation, the Hotlink may still be outdated.
To set update preferences when opening a file containing hotlinks, go to Options > Work Environment > Data Safety & Integrity > Hotlink Update.
Choose File > External Content > Hotlink Manager.
2.
Click the Save as File… button and name the newly created file (it will be a module-type file with extension.mod).
Click Relink and use the appearing “New Hotlink” directory dialog box to provide the location of the Hotlink Source (which is probably missing because it was moved to a new location.) As long as a Hotlinked Source is missing, ARCHICAD cannot update its module instances.
Note: Relink is available only for source files of top-level hotlinked modules; you cannot relink the source file of a nested hotlink. If the source of a nested hotlink is shown as “Missing,” open the file into which the nested hotlink is placed, and relink the source file.
You can also replace a Hotlink Source file with another one: in the Hotlink Sources list in Hotlink Manager, select the source file to replace and click Relink. All module instances based on the original source will now be replaced by modules based on the new source you relinked here.
You can replace multiple source files with a different set of source files if the replacement files are all in the same folder: select the files in Hotlink Manager, then click Relocate. In the directory dialog box, define the location of the folder containing the new source files. The Relocate command is available only if you have selected multiple Hotlink Source files.
  • Was this Helpful ?
  • 0   ​0