Editing Module Content

In Hotlink Manager (File > External Content > Hotlink Manager), choose the desired source file from the Hotlink Sources list. Then click “Open in Separate ARCHICAD.”
Hint: If you want to see the Floor Plan context of the placed module while editing its source in the second ARCHICAD, use the “Trace” function. (See View Context of Hotlinked Module while Editing Module Content.)
Return to the first (host) project. Go to File > External Content > Hotlink Manager. In the Hotlink Source list, note that the Status of the edited module’s Hotlink Source now reads Modified. (If needed, click Refresh Status to get the latest status messages.)
Click Update to update all placed instances of the hotlink. This action is carried out once you click OK to close the Hotlink Manager dialog box.
Note: In Teamwork, you must reserve Hotlink Sources in the Hotlink Manager to be able to update.
1.
Select Module A, then use Save as File… from Module Settings to create a new version, named Module C.
3.
Use Change Hotlink to replace Module A with Module C.
2.
Choose File > External Content > Hotlinked Module Settings.
Note: In Teamwork, the Break Hotlink function is not available. Instead, you can Explode the Hotlinked Module. (See Explode Hotlinked Module Instance in Teamwork.)
4.
Edit the elements as needed. (Use Edit > Grouping > Suspend Groups to enable editing.)
5.
Select the elements again and choose File > External Content > Save Selection as Module.
Note: If you choose the old name of the module file, you will overwrite the previous source file and thereby overwrite all placed instances of the module file, not just the selected module.
Note: By checking Replace selection with this hotlinked module file in the Save Hotlinked Module dialog box, the new, edited Hotlinked module is placed automatically.
Check both the Replace selection with this hotlinked module file and Apply offset/rotation of most recently broken hotlinked module boxes. Click the Save button.
  • Was this Helpful ?
  • 0   ​0

Subtopics